]> git.pld-linux.org Git - packages/gmp.git/commitdiff
- updated to 6.3.0 master auto/th/gmp-6.3.0-1
authorJakub Bogusz <qboosh@pld-linux.org>
Sun, 3 Sep 2023 17:35:05 +0000 (19:35 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Sun, 3 Sep 2023 17:35:05 +0000 (19:35 +0200)
gmp-cpu.patch
gmp.spec

index 7c88dce1482d168e154a0c699172ab42953c9615..80453d93927693089db3bb7567eaa2ce78b19cc5 100644 (file)
@@ -1,6 +1,6 @@
---- gmp-6.1.2/configure.ac.orig        2016-12-16 16:45:27.000000000 +0100
-+++ gmp-6.1.2/configure.ac     2016-12-26 20:45:03.083263267 +0100
-@@ -276,8 +276,12 @@
+--- gmp-6.3.0/configure.ac.orig        2023-07-29 15:42:16.000000000 +0200
++++ gmp-6.3.0/configure.ac     2023-09-03 19:25:28.172771749 +0200
+@@ -277,8 +277,12 @@ if test $enable_fake_cpuid = yes && test
    AC_MSG_ERROR([--enable-fake-cpuid requires --enable-fat])
  fi
  
@@ -15,7 +15,7 @@
  AC_DEFINE_UNQUOTED(HAVE_HOST_CPU_$tmp_host)
  GMP_DEFINE_RAW("define_not_for_expansion(\`HAVE_HOST_CPU_$tmp_host')", POST)
  
-@@ -455,7 +459,7 @@
+@@ -480,7 +484,7 @@ case $host in
  
    alpha*-*-*)
      AC_DEFINE(HAVE_HOST_CPU_FAMILY_alpha)
@@ -24,7 +24,7 @@
        alphaev5* | alphapca5*)
        path="alpha/ev5 alpha" ;;
        alphaev67 | alphaev68 | alphaev7*)
-@@ -482,7 +486,7 @@
+@@ -507,7 +511,7 @@ case $host in
      # compiler errors too easily and is rejected by GMP_PROG_CC_WORKS.  Each
      # -mcpu=ev6 below has a fallback to -mcpu=ev56 for this reason.
      #
@@ -33,7 +33,7 @@
        alpha)        gcc_cflags_cpu="-mcpu=ev4" ;;
        alphaev5)     gcc_cflags_cpu="-mcpu=ev5" ;;
        alphaev56)    gcc_cflags_cpu="-mcpu=ev56" ;;
-@@ -515,7 +519,7 @@
+@@ -540,7 +544,7 @@ case $host in
      # Insns like ctlz which were never available as macros are always
      # accepted and always generate their plain code.
      #
@@ -42,7 +42,7 @@
        alpha)        gcc_cflags_asm="-Wa,-arch,ev4 -Wa,-mev4" ;;
        alphaev5)     gcc_cflags_asm="-Wa,-arch,ev5 -Wa,-mev5" ;;
        alphaev56)    gcc_cflags_asm="-Wa,-arch,ev56 -Wa,-mev56" ;;
-@@ -550,7 +554,7 @@
+@@ -575,7 +579,7 @@ case $host in
        # DEC C V5.9-005 knows ev4, ev5, ev56, pca56, ev6.
        # Compaq C V6.3-029 adds ev67.
        #
@@ -51,7 +51,7 @@
          alpha)       cc_cflags_cpu="-arch~ev4~-tune~ev4" ;;
          alphaev5)    cc_cflags_cpu="-arch~ev5~-tune~ev5" ;;
          alphaev56)   cc_cflags_cpu="-arch~ev56~-tune~ev56" ;;
-@@ -616,7 +620,7 @@
+@@ -643,7 +647,7 @@ case $host in
      # FIXME: We make mandatory compiler options optional here.  We should
      # either enforce them, or organise to strip paths as the corresponding
      # options fail.
@@ -60,7 +60,7 @@
        armxscale | arm7ej | arm9te | arm9e* | arm10* | armv5*)
        path="arm/v5 arm"
        gcc_cflags_arch="-march=armv5"
-@@ -782,7 +786,7 @@
+@@ -828,7 +832,7 @@ case $host in
      # (Can't remember why this isn't done already, have to check what .asm
      # files are available in each and how they run on a typical 2.0 cpu.)
      #
@@ -69,7 +69,7 @@
        hppa1.0*)    path="pa32" ;;
        hppa7000*)   path="pa32/hppa1_1 pa32" ;;
        hppa2.0* | hppa64)
-@@ -800,13 +804,13 @@
+@@ -846,13 +850,13 @@ case $host in
      # probably be safe, but let's not take the chance.  In any case, a
      # configuration like --host=hppa2.0 ABI=1.0 is far from optimal.
      #
@@ -85,7 +85,7 @@
        hppa1.0*)    cc_cflags="+O2" ;;
        *)           # default to 7100
                     cc_cflags="+DA1.1 +O2" ;;
-@@ -868,7 +872,7 @@
+@@ -913,7 +917,7 @@ case $host in
      SPEED_CYCLECOUNTER_OBJ=ia64.lo
      any_32_testlist="sizeof-long-4"
  
@@ -94,7 +94,7 @@
        itanium)   path="ia64/itanium  ia64" ;;
        itanium2)  path="ia64/itanium2 ia64" ;;
        *)         path="ia64" ;;
-@@ -878,7 +882,7 @@
+@@ -923,7 +927,7 @@ case $host in
      gcc_32_cflags_optlist=$gcc_64_cflags_optlist
  
      # gcc pre-release 3.4 adds -mtune itanium and itanium2
        itanium)   gcc_cflags_tune="-mtune=itanium" ;;
        itanium2)  gcc_cflags_tune="-mtune=itanium2" ;;
      esac
-@@ -941,7 +945,7 @@
+@@ -986,7 +990,7 @@ case $host in
      # gcc 2.95 adds -mcpu32, -m68060.
      # FIXME: Maybe "-m68020 -mnobitfield" would suit cpu32 on 2.7.2.
      #
      m68020)  gcc_cflags_arch="-m68020" ;;
      m68030)  gcc_cflags_arch="-m68030" ;;
      m68040)  gcc_cflags_arch="-m68040" ;;
-@@ -953,7 +957,7 @@
+@@ -998,7 +1002,7 @@ case $host in
      # FIXME: m68k/mc68020 looks like it's ok for cpu32, but this wants to be
      # tested.  Will need to introduce an m68k/cpu32 if m68k/mc68020 ever uses
      # the bitfield instructions.
      [m680[234]0 | m68360])  path="m68k/mc68020 m68k" ;;
      *)                      path="m68k" ;;
      esac
-@@ -1058,7 +1062,7 @@
+@@ -1118,7 +1122,7 @@ case $host in
      SPEED_CYCLECOUNTER_OBJ=powerpc.lo
      cyclecounter_size=0
  
        powerpc740 | powerpc750)
          path="powerpc32/750 powerpc32" ;;
        powerpc7400 | powerpc7410)
-@@ -1069,7 +1073,7 @@
+@@ -1129,7 +1133,7 @@ case $host in
          path="powerpc32" ;;
      esac
  
        powerpc401)   gcc_cflags_cpu="-mcpu=401" ;;
        powerpc403)   gcc_cflags_cpu="-mcpu=403"
                    xlc_cflags_arch="-qarch=403 -qarch=ppc" ;;
-@@ -1306,7 +1310,7 @@
-     fi
+@@ -1381,7 +1385,7 @@ case $host in
      gcc_32_cflags_maybe="-m31"
  
+     unset cpu
 -    case $host_cpu in
 +    case $gmp_cpu in
        s390)
        ;;
        z900 | z900esa)
-@@ -1362,7 +1366,7 @@
-       cclist_64="gcc"
-       gcc_64_cflags_optlist="arch"
-       gcc_64_cflags="$gcc_cflags -m64"
--      path_64="s390_64/$host_cpu s390_64"
-+      path_64="s390_64/$gmp_cpu s390_64"
-       extra_functions=""
-       ;;
-       esac
-@@ -1387,7 +1391,7 @@
+@@ -1471,7 +1475,7 @@ case $host in
      any_testlist="sizeof-long-4"
      GMP_INCLUDE_MPN(sparc32/sparc-defs.m4)
  
        sparcv8 | microsparc | turbosparc)
          path="sparc32/v8 sparc32" ;;
        supersparc)
-@@ -1423,7 +1427,7 @@
+@@ -1507,7 +1511,7 @@ case $host in
      #   plain -m forms will disappear.
      # gcc 3.3 adds ultrasparc3.
      #
        supersparc*)
                        gcc_cflags_cpu="-mcpu=supersparc -msupersparc"
                        gcc_cflags_asm="-Wa,-Av8 -Wa,-xarch=v8";;
-@@ -1471,7 +1475,7 @@
+@@ -1555,7 +1559,7 @@ case $host in
  
          # SunOS cc doesn't know -xarch, apparently always generating v7
          # code, so make this optional
          sparcv8 | microsparc* | supersparc* | turbosparc | hypersparc*)
                        cc_cflags_arch="-xarch=v8";;
            [ultrasparct[345]])
-@@ -1487,7 +1491,7 @@
+@@ -1571,7 +1575,7 @@ case $host in
        #   micro2, hyper, hyper2, powerup, ultra, ultra2, ultra2i.
        # SunPRO cc 6 adds -xchip=ultra2e, ultra3cu.
          #
          supersparc*)  cc_cflags_cpu="-xchip=super" ;;
          microsparc*)  cc_cflags_cpu="-xchip=micro" ;;
          turbosparc)   cc_cflags_cpu="-xchip=micro2" ;;
-@@ -1506,7 +1510,7 @@
+@@ -1590,7 +1594,7 @@ case $host in
        esac
      esac
  
        sparc64 | sparcv9* | ultrasparc*)
          case $host in
            # Solaris 6 and earlier cannot run ABI=64 since it doesn't save
-@@ -1533,7 +1537,7 @@
+@@ -1617,7 +1621,7 @@ case $host in
            *) abilist="64 32" ;;
          esac
  
          ultrasparc | ultrasparc2 | ultrasparc2i)
            path_64="sparc64/ultrasparc1234 sparc64" ;;
          [ultrasparc[34]])
-@@ -1574,7 +1578,7 @@
+@@ -1661,7 +1665,7 @@ case $host in
              #
              cclist_64="$cclist_64 cc"
              cc_64_cflags_optlist="cpu"
                [ultrasparct[345]])
                  cc_64_cflags="$cc_64_cflags -xO3 -xarch=v9d" ;;
                *)
-@@ -1622,7 +1626,7 @@
+@@ -1709,7 +1713,7 @@ case $host in
    #
    # -m32 forces 32-bit mode on a bi-arch 32/64 amd64 build of gcc.  -m64 is
    # the default in such a build (we think), so -m32 is essential for ABI=32.
    # get such a gcc into the right mode to cross-compile to say i486-*-*.
    #
    # -m32 is not available in gcc 2.95 and earlier, hence cflags_maybe to use
-@@ -1680,7 +1684,7 @@
+@@ -1772,7 +1776,7 @@ case $host in
      # like k8 for x86_64, then it can be the -mtune at the start, no need to
      # duplicate anything.
      #
index a1f3fa5b9e05d5a5c6ea53f96af2f5f828c3abcc..0b0675505199768791a58e1266795618a94effe6 100644 (file)
--- a/gmp.spec
+++ b/gmp.spec
@@ -12,12 +12,12 @@ Summary(pt_BR.UTF-8):       Biblioteca de precisão arbitrária da GNU
 Summary(uk.UTF-8):     Бібліотека GNU довільної точності
 Summary(ru.UTF-8):     Библиотека GNU произвольной точности
 Name:          gmp
-Version:       6.2.1
+Version:       6.3.0
 Release:       1
 License:       LGPL v3+
 Group:         Libraries
 Source0:       https://ftp.gnu.org/gnu/gmp/%{name}-%{version}.tar.lz
-# Source0-md5: 03a31d8cbaf29d136252f8f38875ed82
+# Source0-md5: db3f4050677df3ff2bd23422c0d3caa1
 Patch0:                %{name}-info.patch
 Patch1:                %{name}-multilib.patch
 Patch2:                %{name}-cpu.patch
@@ -30,7 +30,7 @@ BuildRequires:        libtool >= 2:2
 BuildRequires: lzip
 BuildRequires: tar >= 1:1.22
 BuildRequires: texinfo
-Obsoletes:     libgmp3
+Obsoletes:     libgmp3 < 4
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -107,7 +107,7 @@ Summary(uk.UTF-8):  Інструменти розробки для бібліот
 Summary(ru.UTF-8):     Инструменты разработки для библиотеки GNU произвольной точности
 Group:         Development/Libraries
 Requires:      %{name} = %{version}-%{release}
-Obsoletes:     libgmp3-devel
+Obsoletes:     libgmp3-devel < 4
 
 %description devel
 The header files and documentation for using the GNU MP arbitrary
This page took 0.124216 seconds and 4 git commands to generate.