]> git.pld-linux.org Git - packages/gmetadom.git/blob - gmetadom.spec
- x32 rebuild
[packages/gmetadom.git] / gmetadom.spec
1 #
2 # Conditional build:
3 %bcond_without  ocaml   # don't build OCaml binding
4 #
5 %define         ocaml_ver       1:3.09.3
6 Summary:        gdome2 binding for various programming languages
7 Summary(pl.UTF-8):      Wiązania gdome2 dla różnych języków programowania
8 Name:           gmetadom
9 Version:        0.2.6
10 Release:        7
11 License:        LGPL v2.1+
12 Group:          Libraries
13 Source0:        http://dl.sourceforge.net/gmetadom/%{name}-%{version}.tar.gz
14 # Source0-md5:  7bfb5d9c6f20ffa5e790b63d1f8cb481
15 Patch0:         %{name}-gcc43.patch
16 URL:            http://gmetadom.sourceforge.net/
17 BuildRequires:  autoconf >= 2.50
18 BuildRequires:  automake
19 BuildRequires:  gdome2-devel >= 0.8.0
20 BuildRequires:  libstdc++-devel
21 BuildRequires:  libtool >= 2:1.5
22 %{?with_ocaml:BuildRequires:    ocaml >= %{ocaml_ver}}
23 BuildRequires:  pkgconfig
24 BuildRequires:  rpmbuild(macros) >= 1.198
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 gdome2 binding for various programming languages. gdome2 is a fast,
29 light and complete DOM level2 implementation based on libxml2.
30
31 %description -l pl.UTF-8
32 Wiązania gdome2 dla różnych języków programowania. gdome2 jest szybką,
33 lekką i kompletną implementacją DOM poziom 2 opartą o libxml2.
34
35 %package -n ocaml-gdome2
36 Summary:        gdome2 binding for OCaml
37 Summary(pl.UTF-8):      Wiązania gdome2 dla OCamla
38 Group:          Libraries
39 Requires:       gdome2 >= 0.8.0
40 %requires_eq    ocaml-runtime
41
42 %description -n ocaml-gdome2
43 gdome2 binding for OCaml. gdome2 is a fast, light and complete DOM
44 level2 implementation based on libxml2.
45
46 This package contains files needed to run bytecode executables using
47 this library.
48
49 %description -n ocaml-gdome2 -l pl.UTF-8
50 Wiązania gdome2 dla OCamla. gdome2 jest szybką, lekką i kompletną
51 implementacją DOM poziom 2 opartą o libxml2.
52
53 Pakiet ten zawiera binaria potrzebne do uruchamiania programów
54 używających tej biblioteki.
55
56 %package -n ocaml-gdome2-devel
57 Summary:        gdome2 binding for OCaml - development part
58 Summary(pl.UTF-8):      Wiązania gdome2 dla OCamla - cześć programistyczna
59 Group:          Development/Libraries
60 Requires:       %{name} = %{version}-%{release}
61 Requires:       ocaml-gdome2 = %{version}-%{release}
62 %requires_eq    ocaml
63
64 %description -n ocaml-gdome2-devel
65 gdome2 binding for OCaml. gdome2 is a fast, light and complete DOM
66 level2 implementation based on libxml2.
67
68 This package contains files needed to develop OCaml programs using
69 this library.
70
71 %description -n ocaml-gdome2-devel -l pl.UTF-8
72 Wiązania gdome2 dla OCamla. gdome2 jest szybką, lekką i kompletną
73 implementacją DOM poziom 2 opartą o libxml2.
74
75 Pakiet ten zawiera pliki niezbędne do tworzenia programów używających
76 tej biblioteki.
77
78 %package -n gdome2-cpp_smart
79 Summary:        gdome2 binding for C++/smart pointers
80 Summary(pl.UTF-8):      Wiązania gdome2 dla C++/mądre wskaźniki
81 Group:          Libraries
82 Requires:       gdome2 >= 0.8.0
83
84 %description -n gdome2-cpp_smart
85 gdome2 binding for C++ with smart pointers. gdome2 is a fast, light
86 and complete DOM level2 implementation based on libxml2.
87
88 %description -n gdome2-cpp_smart -l pl.UTF-8
89 Wiązania gdome2 dla C++ z mądrymi wskaźnikami. gdome2 jest szybką,
90 lekką i kompletną implementacją DOM poziom 2 opartą o libxml2.
91
92 %package -n gdome2-cpp_smart-devel
93 Summary:        gdome2 binding for C++/smart pointers - development part
94 Summary(pl.UTF-8):      Wiązania gdome2 dla C++/mądre wskaźniki - cześć programistyczna
95 Group:          Development/Libraries
96 Requires:       %{name} = %{version}-%{release}
97 Requires:       gdome2-cpp_smart = %{version}-%{release}
98 Requires:       gdome2-devel >= 0.8.0
99 Requires:       libstdc++-devel
100
101 %description -n gdome2-cpp_smart-devel
102 gdome2 binding for C++ with smart pointers. gdome2 is a fast, light
103 and complete DOM level2 implementation based on libxml2.
104
105 This package contains header files needed to develop programs using
106 gdome2-cpp_smart.
107
108 %description -n gdome2-cpp_smart-devel -l pl.UTF-8
109 Wiązania gdome2 dla C++ z mądrymi wskaźnikami. gdome2 jest szybką,
110 lekką i kompletną implementacją DOM poziom 2 opartą o libxml2.
111
112 Pakiet ten zawiera pliki nagłówkowe niezbędne do rozwijania programów
113 korzystających z gdome2-cpp_smart.
114
115 %package -n gdome2-cpp_smart-static
116 Summary:        gdome2 binding for C++/smart pointers - static libraries
117 Summary(pl.UTF-8):      Wiązania gdome2 dla C++/mądre wskaźniki - biblioteki statyczne
118 Group:          Development/Libraries
119 Requires:       gdome2-cpp_smart-devel = %{version}-%{release}
120
121 %description -n gdome2-cpp_smart-static
122 gdome2 binding for C++ with smart pointers. gdome2 is a fast, light
123 and complete DOM level2 implementation based on libxml2.
124
125 This package contains static libraries needed to develop programs
126 using gdome2-cpp_smart.
127
128 %description -n gdome2-cpp_smart-static -l pl.UTF-8
129 Wiązania gdome2 dla C++ z mądrymi wskaźnikami. gdome2 jest szybką,
130 lekką i kompletną implementacją DOM poziom 2 opartą o libxml2.
131
132 Pakiet ten zawiera statyczne biblioteki niezbędne do rozwijania
133 programów korzystających z gdome2-cpp_smart.
134
135 %prep
136 %setup -q
137 %patch0 -p1
138
139 # clean up CVS dirs in xml tree
140 find -name CVS | xargs rm -rf
141
142 %build
143 %{__libtoolize}
144 %{__aclocal}
145 %{__autoconf}
146 %{__automake}
147
148 %configure \
149         --with-modules="gdome_cpp_smart%{?with_ocaml: gdome_caml}"
150
151 %{__make} -j1
152
153 %install
154 rm -rf $RPM_BUILD_ROOT
155
156 %{__make} install \
157         DESTDIR=$RPM_BUILD_ROOT
158
159 install -d $RPM_BUILD_ROOT%{_examplesdir}/ocaml-gdome2-%{version}
160 install src/gdome_caml/examples/*.ml $RPM_BUILD_ROOT%{_examplesdir}/ocaml-gdome2-%{version}
161
162 %if %{with ocaml}
163 rm $RPM_BUILD_ROOT%{_libdir}/ocaml/gdome2/*.{ml,mli}
164 %endif
165
166 %clean
167 rm -rf $RPM_BUILD_ROOT
168
169 %post   -n gdome2-cpp_smart -p /sbin/ldconfig
170 %postun -n gdome2-cpp_smart -p /sbin/ldconfig
171
172 %files
173 %defattr(644,root,root,755)
174 %doc xml/DOM/* AUTHORS ChangeLog HISTORY LICENSE
175 %dir %{_includedir}/gmetadom
176
177 %if %{with ocaml}
178 %files -n ocaml-gdome2
179 %defattr(644,root,root,755)
180 %dir %{_libdir}/ocaml/gdome2
181 %attr(755,root,root) %{_libdir}/ocaml/stublibs/dllmlgdome.so
182
183 %files -n ocaml-gdome2-devel
184 %defattr(644,root,root,755)
185 %doc src/gdome_caml/ocaml/gdome.mli
186 %{_libdir}/ocaml/gdome2/*.cm[ixao]*
187 %{_libdir}/ocaml/gdome2/*.[hao]
188 %{_examplesdir}/ocaml-gdome2-%{version}
189 %endif
190
191 %files -n gdome2-cpp_smart
192 %defattr(644,root,root,755)
193 %attr(755,root,root) %{_libdir}/libgmetadom_gdome_cpp_smart.so.*.*.*
194 %attr(755,root,root) %ghost %{_libdir}/libgmetadom_gdome_cpp_smart.so.0
195
196 %files -n gdome2-cpp_smart-devel
197 %defattr(644,root,root,755)
198 %attr(755,root,root) %{_libdir}/libgmetadom_gdome_cpp_smart.so
199 %{_libdir}/libgmetadom_gdome_cpp_smart.la
200 %{_includedir}/gmetadom
201 %{_pkgconfigdir}/gdome2-cpp-smart.pc
202
203 %files -n gdome2-cpp_smart-static
204 %defattr(644,root,root,755)
205 %{_libdir}/libgmetadom_gdome_cpp_smart.a
This page took 0.394985 seconds and 3 git commands to generate.