]> git.pld-linux.org Git - packages/ghc-zlib.git/commitdiff
- initial revision auto/th/ghc-zlib-0_5_2_0-1
authorJan Rękorajski <baggins@pld-linux.org>
Thu, 8 Apr 2010 22:00:06 +0000 (22:00 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    ghc-zlib.spec -> 1.1

ghc-zlib.spec [new file with mode: 0644]

diff --git a/ghc-zlib.spec b/ghc-zlib.spec
new file mode 100644 (file)
index 0000000..a48fb90
--- /dev/null
@@ -0,0 +1,67 @@
+%define        pkgname zlib
+Summary:       Compression and decompression in the gzip and zlib formats
+Name:          ghc-%{pkgname}
+Version:       0.5.2.0
+Release:       1
+License:       BSD
+Group:         Development/Languages
+Source0:       http://hackage.haskell.org/packages/archive/%{pkgname}/%{version}/%{pkgname}-%{version}.tar.gz
+# Source0-md5: 19859e241dc18ef1501a5d44d8523507
+URL:           http://hackage.haskell.org/package/%{pkgname}/
+BuildRequires: ghc >= 6.10
+%requires_eq   ghc
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%define                libsubdir       ghc-%(/usr/bin/ghc --numeric-version)/%{pkgname}-%{version}
+
+%description
+This package provides a pure interface for compressing and
+decompressing streams of data represented as lazy
+'ByteString's. It uses the zlib C library so it has high
+performance. It supports the "zlib", "gzip" and "raw"
+compression formats.
+
+It provides a convenient high level API suitable for most
+tasks and for the few cases where more control is needed it
+provides access to the full zlib feature set.
+
+%prep
+%setup -q -n %{pkgname}-%{version}
+
+%build
+runhaskell Setup.hs configure -v2 \
+       --prefix=%{_prefix} \
+       --libdir=%{_libdir} \
+       --libexecdir=%{_libexecdir} \
+       --libsubdir=%{libsubdir} \
+       --docdir=%{_defaultdocdir}/%{name}-%{version}
+
+runhaskell Setup.hs build
+runhaskell Setup.hs haddock --executables
+
+%install
+rm -rf $RPM_BUILD_ROOT
+runhaskell Setup.hs copy --destdir=$RPM_BUILD_ROOT
+
+# work around automatic haddock docs installation
+rm -rf %{name}-%{version}-doc
+cp -a $RPM_BUILD_ROOT%{_defaultdocdir}/%{name}-%{version} %{name}-%{version}-doc
+
+runhaskell Setup.hs register \
+       --gen-pkg-config=$RPM_BUILD_ROOT/%{_libdir}/%{libsubdir}/%{pkgname}.conf
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%post
+/usr/bin/ghc-pkg update %{_libdir}/%{libsubdir}/%{pkgname}.conf
+
+%postun
+if [ "$1" = "0" ]; then
+       /usr/bin/ghc-pkg unregister %{pkgname}-%{version}
+fi
+
+%files
+%defattr(644,root,root,755)
+%doc %{name}-%{version}-doc/html
+%{_libdir}/%{libsubdir}
This page took 0.05462 seconds and 4 git commands to generate.