]> git.pld-linux.org Git - packages/ghc-zlib.git/blob - ghc-zlib.spec
- release 3
[packages/ghc-zlib.git] / ghc-zlib.spec
1 %define         pkgname zlib
2 Summary:        Compression and decompression in the gzip and zlib formats
3 Name:           ghc-%{pkgname}
4 Version:        0.5.2.0
5 Release:        3
6 License:        BSD
7 Group:          Development/Languages
8 Source0:        http://hackage.haskell.org/packages/archive/%{pkgname}/%{version}/%{pkgname}-%{version}.tar.gz
9 # Source0-md5:  19859e241dc18ef1501a5d44d8523507
10 URL:            http://hackage.haskell.org/package/zlib/
11 BuildRequires:  ghc >= 6.12.3
12 BuildRequires:  rpmbuild(macros) >= 1.608
13 %requires_releq ghc
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16 %description
17 This package provides a pure interface for compressing and
18 decompressing streams of data represented as lazy
19 'ByteString's. It uses the zlib C library so it has high
20 performance. It supports the "zlib", "gzip" and "raw"
21 compression formats.
22
23 It provides a convenient high level API suitable for most
24 tasks and for the few cases where more control is needed it
25 provides access to the full zlib feature set.
26
27 %prep
28 %setup -q -n %{pkgname}-%{version}
29
30 %build
31 runhaskell Setup.hs configure -v2 \
32         --prefix=%{_prefix} \
33         --libdir=%{_libdir} \
34         --libexecdir=%{_libexecdir} \
35         --docdir=%{_docdir}/%{name}-%{version}
36
37 runhaskell Setup.hs build
38 runhaskell Setup.hs haddock --executables
39
40 %install
41 rm -rf $RPM_BUILD_ROOT
42 install -d $RPM_BUILD_ROOT%{_libdir}/%{ghcdir}/package.conf.d
43
44 runhaskell Setup.hs copy --destdir=$RPM_BUILD_ROOT
45
46 # work around automatic haddock docs installation
47 rm -rf %{name}-%{version}-doc
48 cp -a $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version} %{name}-%{version}-doc
49
50 runhaskell Setup.hs register \
51         --gen-pkg-config=$RPM_BUILD_ROOT/%{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
52
53 %clean
54 rm -rf $RPM_BUILD_ROOT
55
56 %post
57 %ghc_pkg_recache
58
59 %postun
60 %ghc_pkg_recache
61
62 %files
63 %defattr(644,root,root,755)
64 %doc %{name}-%{version}-doc/html
65 %{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
66 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}
This page took 0.041194 seconds and 4 git commands to generate.