]> git.pld-linux.org Git - packages/ghc-zip-archive.git/commitdiff
- up to 0.4.1 auto/th/ghc-zip-archive-0.4.1-1
authorJan Rękorajski <baggins@pld-linux.org>
Sun, 24 May 2020 15:04:08 +0000 (17:04 +0200)
committerJan Rękorajski <baggins@pld-linux.org>
Sun, 24 May 2020 15:04:08 +0000 (17:04 +0200)
ghc-zip-archive.spec

index 7a4d73cc1e86a2f9b4ab8c9b0bb5b93264838ae8..118a3cf54fedba1ed34c2578205d42ff4634a3de 100644 (file)
@@ -6,26 +6,25 @@
 Summary:       Library for creating and modifying zip archives
 Summary(pl.UTF-8):     Biblioteka do tworzenia i modyfikowania archiwów zip
 Name:          ghc-%{pkgname}
-Version:       0.2
+Version:       0.4.1
 Release:       1
 License:       BSD
 Group:         Development/Languages
 #Source0Download: http://hackage.haskell.org/package/zip-archive
 Source0:       http://hackage.haskell.org/package/%{pkgname}-%{version}/%{pkgname}-%{version}.tar.gz
-# Source0-md5: 61d6666aa775ba27090e381721dd4dad
+# Source0-md5: 622fb5b050d4d05771f29d409e0c7f6b
 URL:           http://hackage.haskell.org/package/zip-archive
 BuildRequires: ghc >= 6.12.3
 BuildRequires: ghc-array
 BuildRequires: ghc-base >= 4.2
 BuildRequires: ghc-base < 5
-BuildRequires: ghc-binary >= 0.5
-BuildRequires: ghc-bytestring >= 0.9.0
+BuildRequires: ghc-binary >= 0.6
+BuildRequires: ghc-bytestring >= 0.10.0
 BuildRequires: ghc-containers
 BuildRequires: ghc-digest >= 0.0.0.1
-BuildRequires: ghc-directory >= 1.1
+BuildRequires: ghc-directory >= 1.2
 BuildRequires: ghc-filepath
 BuildRequires: ghc-mtl
-BuildRequires: ghc-old-time
 BuildRequires: ghc-pretty
 BuildRequires: ghc-text >= 0.11
 BuildRequires: ghc-time
@@ -35,14 +34,13 @@ BuildRequires:      ghc-prof >= 6.12.3
 BuildRequires: ghc-array-prof
 BuildRequires: ghc-base-prof >= 4.2
 BuildRequires: ghc-base-prof < 5
-BuildRequires: ghc-binary-prof >= 0.5
-BuildRequires: ghc-bytestring-prof >= 0.9.0
+BuildRequires: ghc-binary-prof >= 0.6
+BuildRequires: ghc-bytestring-prof >= 0.10.0
 BuildRequires: ghc-containers-prof
 BuildRequires: ghc-digest-prof >= 0.0.0.1
-BuildRequires: ghc-directory-prof >= 1.1
+BuildRequires: ghc-directory-prof >= 1.2
 BuildRequires: ghc-filepath-prof
 BuildRequires: ghc-mtl-prof
-BuildRequires: ghc-old-time-prof
 BuildRequires: ghc-pretty-prof
 BuildRequires: ghc-text-prof >= 0.11
 BuildRequires: ghc-time-prof
@@ -54,14 +52,13 @@ Requires(post,postun):      /usr/bin/ghc-pkg
 Requires:      ghc-array
 Requires:      ghc-base >= 4.2
 Requires:      ghc-base < 5
-Requires:      ghc-binary >= 0.5
-Requires:      ghc-bytestring >= 0.9.0
+Requires:      ghc-binary >= 0.6
+Requires:      ghc-bytestring >= 0.10.0
 Requires:      ghc-containers
 Requires:      ghc-digest >= 0.0.0.1
-Requires:      ghc-directory >= 1.1
+Requires:      ghc-directory >= 1.2
 Requires:      ghc-filepath
 Requires:      ghc-mtl
-Requires:      ghc-old-time
 Requires:      ghc-pretty
 Requires:      ghc-text >= 0.11
 Requires:      ghc-time
@@ -90,14 +87,13 @@ Requires:   %{name} = %{version}-%{release}
 Requires:      ghc-array-prof
 Requires:      ghc-base-prof >= 4.2
 Requires:      ghc-base-prof < 5
-Requires:      ghc-binary-prof >= 0.5
-Requires:      ghc-bytestring-prof >= 0.9.0
+Requires:      ghc-binary-prof >= 0.6
+Requires:      ghc-bytestring-prof >= 0.10.0
 Requires:      ghc-containers-prof
 Requires:      ghc-digest-prof >= 0.0.0.1
-Requires:      ghc-directory-prof >= 1.1
+Requires:      ghc-directory-prof >= 1.2
 Requires:      ghc-filepath-prof
 Requires:      ghc-mtl-prof
-Requires:      ghc-old-time-prof
 Requires:      ghc-pretty-prof
 Requires:      ghc-text-prof >= 0.11
 Requires:      ghc-time-prof
@@ -126,28 +122,28 @@ Dokumentacja w formacie HTML dla pakietu ghc %{pkgname}.
 %setup -q -n %{pkgname}-%{version}
 
 %build
-runhaskell Setup.lhs configure -v2 \
+runhaskell Setup.hs configure -v2 \
        %{?with_prof:--enable-library-profiling} \
        --prefix=%{_prefix} \
        --libdir=%{_libdir} \
        --libexecdir=%{_libexecdir} \
        --docdir=%{_docdir}/%{name}-%{version}
 
-runhaskell Setup.lhs build
-runhaskell Setup.lhs haddock --executables
+runhaskell Setup.hs build
+runhaskell Setup.hs haddock --executables
 
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT%{_libdir}/%{ghcdir}/package.conf.d
 
-runhaskell Setup.lhs copy --destdir=$RPM_BUILD_ROOT
+runhaskell Setup.hs copy --destdir=$RPM_BUILD_ROOT
 
 # work around automatic haddock docs installation
 %{__rm} -rf %{name}-%{version}-doc
 cp -a $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version} %{name}-%{version}-doc
 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
 
-runhaskell Setup.lhs register \
+runhaskell Setup.hs register \
        --gen-pkg-config=$RPM_BUILD_ROOT%{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
 
 %clean
@@ -164,16 +160,18 @@ rm -rf $RPM_BUILD_ROOT
 %doc LICENSE
 %{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
 %dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}
-%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/HSzip-archive-%{version}.o
-%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/libHSzip-archive-%{version}.a
+%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/libHSzip-archive-%{version}-*.so
+%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/libHSzip-archive-%{version}-*.a
+%exclude %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/libHSzip-archive-%{version}-*_p.a
 %dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Codec
 %dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Codec/Archive
 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Codec/Archive/Zip.hi
+%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Codec/Archive/Zip.dyn_hi
 
 %if %{with prof}
 %files prof
 %defattr(644,root,root,755)
-%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/libHSzip-archive-%{version}_p.a
+%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/libHSzip-archive-%{version}-*_p.a
 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Codec/Archive/Zip.p_hi
 %endif
 
This page took 0.124472 seconds and 4 git commands to generate.