]> git.pld-linux.org Git - packages/ghc-zip-archive.git/blob - ghc-zip-archive.spec
rebuild with ghc 8.10.7
[packages/ghc-zip-archive.git] / ghc-zip-archive.spec
1 #
2 # Conditional build:
3 %bcond_without  prof    # profiling library
4 #
5 %define         pkgname zip-archive
6 Summary:        Library for creating and modifying zip archives
7 Summary(pl.UTF-8):      Biblioteka do tworzenia i modyfikowania archiwów zip
8 Name:           ghc-%{pkgname}
9 Version:        0.4.1
10 Release:        2
11 License:        BSD
12 Group:          Development/Languages
13 #Source0Download: http://hackage.haskell.org/package/zip-archive
14 Source0:        http://hackage.haskell.org/package/%{pkgname}-%{version}/%{pkgname}-%{version}.tar.gz
15 # Source0-md5:  622fb5b050d4d05771f29d409e0c7f6b
16 URL:            http://hackage.haskell.org/package/zip-archive
17 BuildRequires:  ghc >= 6.12.3
18 BuildRequires:  ghc-array
19 BuildRequires:  ghc-base >= 4.2
20 BuildRequires:  ghc-base < 5
21 BuildRequires:  ghc-binary >= 0.6
22 BuildRequires:  ghc-bytestring >= 0.10.0
23 BuildRequires:  ghc-containers
24 BuildRequires:  ghc-digest >= 0.0.0.1
25 BuildRequires:  ghc-directory >= 1.2
26 BuildRequires:  ghc-filepath
27 BuildRequires:  ghc-mtl
28 BuildRequires:  ghc-pretty
29 BuildRequires:  ghc-text >= 0.11
30 BuildRequires:  ghc-time
31 BuildRequires:  ghc-zlib
32 %if %{with prof}
33 BuildRequires:  ghc-prof >= 6.12.3
34 BuildRequires:  ghc-array-prof
35 BuildRequires:  ghc-base-prof >= 4.2
36 BuildRequires:  ghc-base-prof < 5
37 BuildRequires:  ghc-binary-prof >= 0.6
38 BuildRequires:  ghc-bytestring-prof >= 0.10.0
39 BuildRequires:  ghc-containers-prof
40 BuildRequires:  ghc-digest-prof >= 0.0.0.1
41 BuildRequires:  ghc-directory-prof >= 1.2
42 BuildRequires:  ghc-filepath-prof
43 BuildRequires:  ghc-mtl-prof
44 BuildRequires:  ghc-pretty-prof
45 BuildRequires:  ghc-text-prof >= 0.11
46 BuildRequires:  ghc-time-prof
47 BuildRequires:  ghc-zlib-prof
48 %endif
49 BuildRequires:  rpmbuild(macros) >= 1.608
50 Requires(post,postun):  /usr/bin/ghc-pkg
51 %requires_eq    ghc
52 Requires:       ghc-array
53 Requires:       ghc-base >= 4.2
54 Requires:       ghc-base < 5
55 Requires:       ghc-binary >= 0.6
56 Requires:       ghc-bytestring >= 0.10.0
57 Requires:       ghc-containers
58 Requires:       ghc-digest >= 0.0.0.1
59 Requires:       ghc-directory >= 1.2
60 Requires:       ghc-filepath
61 Requires:       ghc-mtl
62 Requires:       ghc-pretty
63 Requires:       ghc-text >= 0.11
64 Requires:       ghc-time
65 Requires:       ghc-zlib
66 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
67
68 # debuginfo is not useful for ghc
69 %define         _enable_debug_packages  0
70
71 # don't compress haddock files
72 %define         _noautocompressdoc      *.haddock
73
74 %description
75 The zip-archive library provides functions for creating, modifying,
76 and extracting files from zip archives.
77
78 %description -l pl.UTF-8
79 Biblioteka zip-archive udostępnia funkcje do tworzenia, modyfikowania
80 oraz wydobywania plików z archiwów zip.
81
82 %package prof
83 Summary:        Profiling %{pkgname} library for GHC
84 Summary(pl.UTF-8):      Biblioteka profilująca %{pkgname} dla GHC
85 Group:          Development/Libraries
86 Requires:       %{name} = %{version}-%{release}
87 Requires:       ghc-array-prof
88 Requires:       ghc-base-prof >= 4.2
89 Requires:       ghc-base-prof < 5
90 Requires:       ghc-binary-prof >= 0.6
91 Requires:       ghc-bytestring-prof >= 0.10.0
92 Requires:       ghc-containers-prof
93 Requires:       ghc-digest-prof >= 0.0.0.1
94 Requires:       ghc-directory-prof >= 1.2
95 Requires:       ghc-filepath-prof
96 Requires:       ghc-mtl-prof
97 Requires:       ghc-pretty-prof
98 Requires:       ghc-text-prof >= 0.11
99 Requires:       ghc-time-prof
100 Requires:       ghc-zlib-prof
101
102 %description prof
103 Profiling %{pkgname} library for GHC. Should be installed when
104 GHC's profiling subsystem is needed.
105
106 %description prof -l pl.UTF-8
107 Biblioteka profilująca %{pkgname} dla GHC. Powinna być zainstalowana
108 kiedy potrzebujemy systemu profilującego z GHC.
109
110 %package doc
111 Summary:        HTML documentation for ghc %{pkgname} package
112 Summary(pl.UTF-8):      Dokumentacja w formacie HTML dla pakietu ghc %{pkgname}
113 Group:          Documentation
114
115 %description doc
116 HTML documentation for ghc %{pkgname} package.
117
118 %description doc -l pl.UTF-8
119 Dokumentacja w formacie HTML dla pakietu ghc %{pkgname}.
120
121 %prep
122 %setup -q -n %{pkgname}-%{version}
123
124 %build
125 runhaskell Setup.hs configure -v2 \
126         %{?with_prof:--enable-library-profiling} \
127         --prefix=%{_prefix} \
128         --libdir=%{_libdir} \
129         --libexecdir=%{_libexecdir} \
130         --docdir=%{_docdir}/%{name}-%{version}
131
132 runhaskell Setup.hs build
133 runhaskell Setup.hs haddock --executables
134
135 %install
136 rm -rf $RPM_BUILD_ROOT
137 install -d $RPM_BUILD_ROOT%{_libdir}/%{ghcdir}/package.conf.d
138
139 runhaskell Setup.hs copy --destdir=$RPM_BUILD_ROOT
140
141 # work around automatic haddock docs installation
142 %{__rm} -rf %{name}-%{version}-doc
143 cp -a $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version} %{name}-%{version}-doc
144 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
145
146 runhaskell Setup.hs register \
147         --gen-pkg-config=$RPM_BUILD_ROOT%{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
148
149 %clean
150 rm -rf $RPM_BUILD_ROOT
151
152 %post
153 %ghc_pkg_recache
154
155 %postun
156 %ghc_pkg_recache
157
158 %files
159 %defattr(644,root,root,755)
160 %doc LICENSE
161 %{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
162 %dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}
163 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/libHSzip-archive-%{version}-*.so
164 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/libHSzip-archive-%{version}-*.a
165 %exclude %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/libHSzip-archive-%{version}-*_p.a
166 %dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Codec
167 %dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Codec/Archive
168 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Codec/Archive/Zip.hi
169 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Codec/Archive/Zip.dyn_hi
170
171 %if %{with prof}
172 %files prof
173 %defattr(644,root,root,755)
174 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/libHSzip-archive-%{version}-*_p.a
175 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Codec/Archive/Zip.p_hi
176 %endif
177
178 %files doc
179 %defattr(644,root,root,755)
180 %doc %{name}-%{version}-doc/*
This page took 0.102184 seconds and 3 git commands to generate.