]> git.pld-linux.org Git - packages/ghc-xmonad-contrib.git/blob - ghc-xmonad-contrib.spec
up to 0.12
[packages/ghc-xmonad-contrib.git] / ghc-xmonad-contrib.spec
1 %define         pkgname xmonad-contrib
2 Summary:        Third party extensions for xmonad
3 Name:           ghc-%{pkgname}
4 Version:        0.12
5 Release:        1
6 License:        BSD
7 Group:          Development/Languages
8 Source0:        http://hackage.haskell.org/package/%{pkgname}-%{version}/%{pkgname}-%{version}.tar.gz
9 # Source0-md5:  39345f462f069f2f0e4a488f7e435dbb
10 URL:            http://www.xmonad.org
11 BuildRequires:  ghc >= 6.12.3
12 BuildRequires:  ghc-X11 >= 1.6.1
13 BuildRequires:  ghc-extensible-exceptions
14 BuildRequires:  ghc-mtl
15 BuildRequires:  ghc-random
16 BuildRequires:  ghc-utf8-string
17 BuildRequires:  rpmbuild(macros) >= 1.608
18 BuildRequires:  xmonad >= 0.12
19 %requires_eq    ghc
20 Requires:       ghc-X11 >= 1.6.1
21 Requires:       ghc-extensible-exceptions
22 Requires:       ghc-mtl
23 Requires:       ghc-random
24 Requires:       ghc-utf8-string
25 Requires:       xmonad >= 0.12
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 # debuginfo is not useful for ghc
29 %define         _enable_debug_packages  0
30
31 %description
32 Third party extensions for xmonad.
33
34 %package doc
35 Summary:        HTML documentation for %{pkgname}
36 Summary(pl.UTF-8):      Dokumentacja w formacie HTML dla %{pkgname}
37 Group:          Documentation
38
39 %description doc
40 HTML documentation for %{pkgname}.
41
42 %description doc -l pl.UTF-8
43 Dokumentacja w formacie HTML dla %{pkgname}.
44
45 %prep
46 %setup -q -n %{pkgname}-%{version}
47
48 %build
49 runhaskell Setup.lhs configure -v2 \
50         --prefix=%{_prefix} \
51         --libdir=%{_libdir} \
52         --libexecdir=%{_libexecdir} \
53         --docdir=%{_docdir}/%{name}-%{version}
54
55 runhaskell Setup.lhs build
56 runhaskell Setup.lhs haddock --executables
57
58 %install
59 rm -rf $RPM_BUILD_ROOT
60 install -d $RPM_BUILD_ROOT%{_libdir}/%{ghcdir}/package.conf.d
61
62 runhaskell Setup.lhs copy --destdir=$RPM_BUILD_ROOT
63
64 # work around automatic haddock docs installation
65 rm -rf %{name}-%{version}-doc
66 cp -a $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/html %{name}-%{version}-doc
67 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
68
69 runhaskell Setup.lhs register \
70         --gen-pkg-config=$RPM_BUILD_ROOT/%{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
71
72 %clean
73 rm -rf $RPM_BUILD_ROOT
74
75 %post
76 %ghc_pkg_recache
77
78 %postun
79 %ghc_pkg_recache
80
81 %files
82 %defattr(644,root,root,755)
83 %{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
84 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}
85
86 %files doc
87 %defattr(644,root,root,755)
88 %doc %{name}-%{version}-doc/*
This page took 0.088955 seconds and 3 git commands to generate.