]> git.pld-linux.org Git - packages/geoclue2.git/blob - geoclue2.spec
- updated to 2.4.13
[packages/geoclue2.git] / geoclue2.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # static library
4 #
5 Summary:        A modular geoinformation service
6 Summary(pl.UTF-8):      Modularna usługa geoinformacyjna
7 Name:           geoclue2
8 Version:        2.4.13
9 Release:        1
10 License:        GPL v2+ (programs), LGPL v2.1+ (library)
11 Group:          Applications
12 #Source0Download: https://gitlab.freedesktop.org/geoclue/geoclue/-/tags
13 Source0:        https://gitlab.freedesktop.org/geoclue/geoclue/-/archive/%{version}/geoclue-%{version}.tar.bz2
14 # Source0-md5:  19dd149851b3e15c74ede07ecd5c7a36
15 URL:            https://geoclue.freedesktop.org/
16 BuildRequires:  ModemManager-devel >= 1.6
17 BuildRequires:  autoconf >= 2.63
18 BuildRequires:  automake >= 1:1.11
19 BuildRequires:  avahi-devel >= 0.6.10
20 BuildRequires:  avahi-glib-devel >= 0.6.10
21 BuildRequires:  glib2-devel >= 1:2.44.0
22 BuildRequires:  gnome-common
23 BuildRequires:  gobject-introspection-devel >= 0.10
24 BuildRequires:  gtk-doc >= 1.0
25 BuildRequires:  gtk-doc-automake >= 1.0
26 BuildRequires:  intltool >= 0.40.0
27 BuildRequires:  json-glib-devel >= 0.14
28 BuildRequires:  libnotify-devel
29 BuildRequires:  libsoup-devel >= 2.42
30 BuildRequires:  libtool >= 2:2.2
31 BuildRequires:  pkgconfig >= 1:0.22
32 BuildRequires:  tar >= 1:1.22
33 BuildRequires:  yelp-tools
34 BuildRequires:  xz
35 Requires:       %{name}-libs = %{version}-%{release}
36 Requires:       avahi-libs >= 0.6.10
37 Requires:       avahi-glib >= 0.6.10
38 Requires:       dbus
39 Requires:       json-glib >= 0.14
40 Requires:       libsoup >= 2.42
41 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
43 %description
44 Geoclue is a modular geoinformation service built on top of the D-Bus
45 messaging system. The goal of the Geoclue project is to make creating
46 location-aware applications as simple as possible.
47
48 %description -l pl.UTF-8
49 Geoclue to modularna usługa geoinformacyjna zbudowana w oparciu o
50 system komunikacji D-Bus. Celem projektu jest jak największe
51 ułatwienie tworzenia aplikacji uwzględniających lokalizację.
52
53 %package libs
54 Summary:        Library to interact with Geoclue service
55 Summary(pl.UTF-8):      Biblioteka do współpracy z usługą Geoclue
56 License:        LGPL v2.1+
57 Group:          Libraries
58 Requires:       glib2 >= 1:2.44.0
59
60 %description libs
61 Library to interact with Geoclue service.
62
63 %description libs -l pl.UTF-8
64 Biblioteka do współpracy z usługą Geoclue.
65
66 %package devel
67 Summary:        Development package for geoclue2
68 Summary(pl.UTF-8):      Pakiet programistyczny geoclue2
69 License:        LGPL v2.1+
70 Group:          Development/Libraries
71 Requires:       %{name}-libs = %{version}-%{release}
72 Requires:       glib2-devel >= 1:2.44.0
73
74 %description devel
75 Header files for development with geoclue2.
76
77 %description devel -l pl.UTF-8
78 Pliki nagłówkowe do programowania z użyciem geoclue2.
79
80 %package static
81 Summary:        Static geoclue2 library
82 Summary(pl.UTF-8):      Statyczna biblioteka geoclue2
83 License:        LGPL v2.1+
84 Group:          Development/Libraries
85 Requires:       %{name}-devel = %{version}-%{release}
86
87 %description static
88 Static geoclue2 library.
89
90 %description static -l pl.UTF-8
91 Statyczna biblioteka geoclue2.
92
93 %package -n vala-geoclue2
94 Summary:        Vala API for geoclue2 library
95 Summary(pl.UTF-8):      Interfejs języka Vala do biblioteki geoclue2
96 License:        LGPL v2.1+
97 Group:          Development/Libraries
98 Requires:       %{name}-devel = %{version}-%{release}
99
100 %description -n vala-geoclue2
101 Vala API for geoclue2 library.
102
103 %description -n vala-geoclue2 -l pl.UTF-8
104 Interfejs języka Vala do biblioteki geoclue2.
105
106 %prep
107 %setup -q -n geoclue-%{version}
108
109 %build
110 %{__gtkdocize}
111 %{__intltoolize}
112 %{__libtoolize}
113 %{__aclocal} -I m4
114 %{__autoconf}
115 %{__autoheader}
116 %{__automake}
117 %configure \
118         --enable-demo-agent \
119         --disable-silent-rules \
120         %{?with_static_libs:--enable-static} \
121         --with-systemdsystemunitdir=%{systemdunitdir}
122
123 %{__make}
124
125 %install
126 rm -rf $RPM_BUILD_ROOT
127
128 %{__make} install \
129         DESTDIR=$RPM_BUILD_ROOT
130
131 # obsoleted by pkg-config
132 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libgeoclue-2.la
133
134 %clean
135 rm -rf $RPM_BUILD_ROOT
136
137 %post   libs -p /sbin/ldconfig
138 %postun libs -p /sbin/ldconfig
139
140 %files
141 %defattr(644,root,root,755)
142 %doc NEWS README
143 %attr(755,root,root) %{_libexecdir}/geoclue
144 %dir %{_sysconfdir}/geoclue
145 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/geoclue/geoclue.conf
146 %{systemdunitdir}/geoclue.service
147 /etc/dbus-1/system.d/org.freedesktop.GeoClue2.conf
148 /etc/dbus-1/system.d/org.freedesktop.GeoClue2.Agent.conf
149 %{_datadir}/dbus-1/system-services/org.freedesktop.GeoClue2.service
150 # demos
151 /etc/xdg/autostart/geoclue-demo-agent.desktop
152 %dir %{_libexecdir}/geoclue-2.0
153 %dir %{_libexecdir}/geoclue-2.0/demos
154 %attr(755,root,root) %{_libexecdir}/geoclue-2.0/demos/agent
155 %attr(755,root,root) %{_libexecdir}/geoclue-2.0/demos/where-am-i
156 %{_desktopdir}/geoclue-demo-agent.desktop
157 %{_desktopdir}/geoclue-where-am-i.desktop
158
159 %files libs
160 %defattr(644,root,root,755)
161 %attr(755,root,root) %{_libdir}/libgeoclue-2.so.*.*.*
162 %attr(755,root,root) %ghost %{_libdir}/libgeoclue-2.so.0
163 %{_libdir}/girepository-1.0/Geoclue-2.0.typelib
164
165 %files devel
166 %defattr(644,root,root,755)
167 %attr(755,root,root) %{_libdir}/libgeoclue-2.so
168 %{_includedir}/libgeoclue-2.0
169 %{_datadir}/gir-1.0/Geoclue-2.0.gir
170 %{_pkgconfigdir}/geoclue-2.0.pc
171 %{_pkgconfigdir}/libgeoclue-2.0.pc
172 %{_datadir}/dbus-1/interfaces/org.freedesktop.GeoClue2.xml
173 %{_datadir}/dbus-1/interfaces/org.freedesktop.GeoClue2.Agent.xml
174 %{_datadir}/dbus-1/interfaces/org.freedesktop.GeoClue2.Client.xml
175 %{_datadir}/dbus-1/interfaces/org.freedesktop.GeoClue2.Location.xml
176 %{_datadir}/dbus-1/interfaces/org.freedesktop.GeoClue2.Manager.xml
177
178 %if %{with static_libs}
179 %files static
180 %defattr(644,root,root,755)
181 %{_libdir}/libgeoclue-2.a
182 %endif
183
184 %files -n vala-geoclue2
185 %defattr(644,root,root,755)
186 %{_datadir}/vala/vapi/libgeoclue-2.0.deps
187 %{_datadir}/vala/vapi/libgeoclue-2.0.vapi
This page took 0.060392 seconds and 3 git commands to generate.