]> git.pld-linux.org Git - packages/geninitrd.git/commitdiff
- rel 4; support for compressed modules used in 3.18.x kernels auto/th/geninitrd-12736-4
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Tue, 14 Oct 2014 08:05:34 +0000 (10:05 +0200)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Tue, 14 Oct 2014 08:05:34 +0000 (10:05 +0200)
geninitrd-git.patch
geninitrd.spec

index 59fae927726639c5f9b6c6f325c06d747aaa5e4b..864d1ea84b0c58ebbbd0d973937e1bf710236206 100644 (file)
@@ -61,3 +61,41 @@ index 2478063..f31f00d 100755
  mount_proc
  
  kmsg "geninitrd/$VERSION starting"
+diff --git a/geninitrd b/geninitrd
+index f31f00d..74d8b70 100755
+--- a/geninitrd
++++ b/geninitrd
+@@ -784,9 +784,22 @@ modules_install() {
+               MODULEDIR=${mod%/*}
+               inst_d "/lib/modules/$kernel/$MODULEDIR"
+               cp -a "/lib/modules/$kernel/$mod" "$DESTDIR/lib/modules/$kernel/$mod"
+-              gunzip "$DESTDIR/lib/modules/$kernel/$mod" 2> /dev/null
++              case $mod in
++                      *.gz)
++                              gunzip "$DESTDIR/lib/modules/$kernel/$mod"
++                              mod=${mod%.gz}
++                              ;;
++                      *.xz)
++                              xz -d "$DESTDIR/lib/modules/$kernel/$mod"
++                              mod=${mod%.xz}
++                              ;;
++                      *.bz2)
++                              bzip2 -d "$DESTDIR/lib/modules/$kernel/$mod"
++                              mod=${mod%.bz2}
++                              ;;
++              esac
+               if [ "$STRIP" ] && [ -x "$STRIP" ]; then
+-                      $STRIP -g --remove-section=.comment "$DESTDIR/lib/modules/$kernel/${mod%.gz}"
++                      $STRIP -g --remove-section=.comment "$DESTDIR/lib/modules/$kernel/${mod}"
+               fi
+       done
+ }
+@@ -797,6 +810,8 @@ modules_add_linuxrc() {
+       for mod in "$@"; do
+               # module path without optional compression
+               modpath=${mod%.gz}
++              modpath=${modpath%.xz}
++              modpath=${modpath%.bz2}
+               # name of the module
+               local module=${modpath##*/}; module=${module%$modext}
index 6005d3dd3d9aeba05762c04f78437db16f145d98..0b7a0011725e98de805e6b649faa74b35fdd211d 100644 (file)
@@ -7,7 +7,7 @@ Summary:        Creates an initial ramdisk image for preloading modules
 Summary(pl.UTF-8):     Narzędzie do tworzenia inicjalnego ramdysku używanego przy starcie systemu
 Name:          geninitrd
 Version:       12736
-Release:       3
+Release:       4
 License:       GPL
 Group:         Applications/System
 Source0:       %{name}-%{version}.tar.gz
This page took 0.427457 seconds and 4 git commands to generate.