]> git.pld-linux.org Git - packages/gegl.git/blob - gegl.spec
- updated to 0.4.30
[packages/gegl.git] / gegl.spec
1 # TODO: maxflow >= 3.0.4
2 #
3 # Conditional build:
4 %bcond_without  doc             # apidocs
5 %bcond_without  lua             # without lua support
6 %bcond_without  static_libs     # static library
7 %bcond_without  introspection   # API introspection
8 %bcond_without  vala            # Vala API
9
10 %if %{without introspection}
11 %undefine       with_vala
12 %endif
13
14 %ifarch x32
15 %undefine       with_lua
16 %endif
17
18 %define babl_ver        0.1.78
19 %define mrg_ver         0.1.4
20
21 Summary:        Generic image processing library
22 Summary(pl.UTF-8):      Ogólna biblioteka przetwarzania obrazu
23 Name:           gegl
24 Version:        0.4.30
25 Release:        1
26 License:        LGPL v3+/GPL v3+
27 Group:          Libraries
28 Source0:        https://download.gimp.org/pub/gegl/0.4/%{name}-%{version}.tar.xz
29 # Source0-md5:  6ae601b8c7cab8af5a36406df0b95ebf
30 Patch1:         %{name}-ruby1.9.patch
31 Patch2:         %{name}-build.patch
32 Patch3:         umfpack.patch
33 Patch4:         %{name}-link.patch
34 Patch5:         %{name}-no-lua.patch
35 URL:            https://www.gegl.org/
36 BuildRequires:  OpenEXR-devel >= 1.6.1
37 BuildRequires:  SDL2-devel >= 2.0.5
38 BuildRequires:  UMFPACK-devel
39 BuildRequires:  asciidoc
40 BuildRequires:  babl-devel >= %{babl_ver}
41 BuildRequires:  bash
42 BuildRequires:  cairo-devel >= 1.12.2
43 BuildRequires:  enscript
44 BuildRequires:  exiv2-devel >= 0.25
45 # libavcodec >= 55.69.100, libavformat >= 55.48.100, libavutil >= 55.92.100, libswscale >= 2.6.100
46 BuildRequires:  ffmpeg-devel >= 2.3
47 BuildRequires:  gdk-pixbuf2-devel >= 2.32.0
48 BuildRequires:  gettext-tools >= 0.19.8
49 BuildRequires:  gexiv2-devel
50 BuildRequires:  glib2-devel >= 1:2.44.0
51 %{?with_introspection:BuildRequires:    gobject-introspection-devel >= 1.32.0}
52 BuildRequires:  graphviz
53 BuildRequires:  gtk-doc >= 1.0
54 BuildRequires:  jasper-devel >= 1.900.1
55 BuildRequires:  json-glib-devel >= 1.2.6
56 BuildRequires:  lcms2-devel >= 2.8
57 BuildRequires:  lensfun-devel >= 0.2.5
58 BuildRequires:  libjpeg-devel >= 1.0.0
59 BuildRequires:  libnsgif-devel
60 BuildRequires:  libpng-devel >= 2:1.6.0
61 BuildRequires:  libraw-devel >= 0.15.4
62 BuildRequires:  librsvg-devel >= 1:2.40.6
63 BuildRequires:  libspiro-devel >= 0.5.0
64 BuildRequires:  libtiff-devel >= 4.0.0
65 BuildRequires:  libv4l-devel >= 1.0.1
66 BuildRequires:  libwebp-devel >= 0.5.0
67 %if %{with lua}
68 BuildRequires:  luajit-devel >= 2.0.4
69 BuildRequires:  lua51-devel >= 5.1.5-2
70 %endif
71 BuildRequires:  meson >= 0.50.0
72 BuildRequires:  mrg-devel >= %{mrg_ver}
73 BuildRequires:  ninja >= 1.5
74 BuildRequires:  pango-devel >= 1:1.38.0
75 BuildRequires:  perl-base >= 5
76 BuildRequires:  pkgconfig
77 BuildRequires:  poppler-glib-devel >= 0.71.0
78 BuildRequires:  python3 >= 1:3.2
79 %if %{with introspection}
80 # for tests only
81 #BuildRequires: python-pygobject3-devel >= 3.2.0
82 %endif
83 BuildRequires:  poly2tri-c-devel
84 BuildRequires:  rpmbuild(macros) >= 1.736
85 BuildRequires:  ruby >= 1.9
86 BuildRequires:  tar >= 1:1.22
87 %if %{with vala}
88 BuildRequires:  vala >= 2:0.20.0
89 BuildRequires:  vala-babl >= %{babl_ver}
90 %endif
91 BuildRequires:  xz
92 BuildRequires:  zlib-devel >= 1.2.0
93 Requires:       OpenEXR >= 1.6.1
94 Requires:       SDL2 >= 2.0.5
95 Requires:       babl >= %{babl_ver}
96 Requires:       cairo >= 1.12.2
97 Requires:       gdk-pixbuf2 >= 2.32.0
98 Requires:       glib2 >= 1:2.44.0
99 Requires:       jasper-libs >= 1.900.1
100 Requires:       json-glib >= 1.2.6
101 Requires:       lcms2 >= 2.8
102 Requires:       lensfun >= 0.2.5
103 Requires:       libraw >= 0.15.4
104 Requires:       librsvg >= 1:2.40.6
105 Requires:       libspiro >= 0.5.0
106 Requires:       libtiff >= 4.0.0
107 Requires:       libwebp >= 0.5.0
108 Requires:       mrg-libs >= %{mrg_ver}
109 Requires:       pango >= 1:1.38.0
110 Requires:       poppler-glib >= 0.71.0
111 Requires:       zlib >= 1.2.0
112 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
113
114 %description
115 GEGL (Generic Graphics Library) is a graph based image processing
116 framework.
117
118 GEGL's original design was made to scratch GIMP's itches for a new
119 compositing and processing core. This core is being designed to have
120 minimal dependencies and a simple well defined API.
121
122 %description -l pl.UTF-8
123 GEGL (Generic Graphics Library) to oparty na grafice szkielet do
124 przetwarzania obrazu.
125
126 Pierwotny projekt biblioteki GEGL powstał z myślą o nowym rdzeniu do
127 składania i przetwarzania obrazu w GIMP-ie. Rdzeń ten jest
128 projektowany tak, by miał minimalne zależności i proste, dobrze
129 zdefiniowane API.
130
131 %package devel
132 Summary:        Header files for gegl library
133 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki gegl
134 Group:          Development/Libraries
135 Requires:       %{name} = %{version}-%{release}
136 Requires:       babl-devel >= %{babl_ver}
137 Requires:       glib2-devel >= 1:2.44.0
138 Requires:       json-glib-devel >= 1.2.6
139 Requires:       poly2tri-c-devel
140
141 %description devel
142 Header files for gegl library.
143
144 %description devel -l pl.UTF-8
145 Pliki nagłówkowe biblioteki gegl.
146
147 %package static
148 Summary:        Static gegl library
149 Summary(pl.UTF-8):      Statyczna biblioteka gegl
150 Group:          Development/Libraries
151 Requires:       %{name}-devel = %{version}-%{release}
152
153 %description static
154 Static gegl library.
155
156 %description static -l pl.UTF-8
157 Statyczna biblioteka gegl.
158
159 %package apidocs
160 Summary:        gegl library API documentation
161 Summary(pl.UTF-8):      Dokumentacja API biblioteki gegl
162 Group:          Documentation
163 Requires:       gtk-doc-common
164 BuildArch:      noarch
165
166 %description apidocs
167 gegl library API documentation.
168
169 %description apidocs -l pl.UTF-8
170 Dokumentacja API biblioteki gegl.
171
172 %package -n vala-gegl
173 Summary:        Vala API for gegl library
174 Summary(pl.UTF-8):      API języka Vala dla biblioteki gegl
175 Group:          Development/Libraries
176 Requires:       %{name}-devel = %{version}-%{release}
177 BuildArch:      noarch
178
179 %description -n vala-gegl
180 Vala API for gegl library.
181
182 %description -n vala-gegl -l pl.UTF-8
183 API języka Vala dla biblioteki gegl.
184
185 %prep
186 %setup -q
187 %patch1 -p1
188 %patch2 -p1
189 %patch3 -p1
190 %patch4 -p1
191 %patch5 -p1
192
193 %build
194 CPPFLAGS="%{rpmcppflags} -I/usr/include/umfpack"
195 %meson build \
196         %{?with_doc:-Ddocs=true} \
197         %{!?with_introspection:-Dintrospection=false} \
198         %{!?with_lua:-Dlua=disabled} \
199         -Dworkshop=true
200
201 %ninja_build -C build
202
203 %if %{with doc}
204 rmdir build/docs/operations/RAM
205 # possible gegl-tester coredumps?
206 rm -f build/docs/operations/core*
207 %endif
208
209 %install
210 rm -rf $RPM_BUILD_ROOT
211
212 %ninja_install -C build
213
214 %find_lang %{name}-0.4
215
216 %clean
217 rm -rf $RPM_BUILD_ROOT
218
219 %post   -p /sbin/ldconfig
220 %postun -p /sbin/ldconfig
221
222 %files -f %{name}-0.4.lang
223 %defattr(644,root,root,755)
224 %doc AUTHORS MAINTAINERS
225 %attr(755,root,root) %{_bindir}/gegl
226 %attr(755,root,root) %{_bindir}/gegl-imgcmp
227 %attr(755,root,root) %{_libdir}/libgegl-0.4.so.*.*.*
228 %attr(755,root,root) %ghost %{_libdir}/libgegl-0.4.so.0
229 %attr(755,root,root) %{_libdir}/libgegl-npd-0.4.so
230 %attr(755,root,root) %{_libdir}/libgegl-sc-0.4.so
231 %{?with_introspection:%{_libdir}/girepository-1.0/Gegl-0.4.typelib}
232 %dir %{_libdir}/gegl-0.4
233 %attr(755,root,root) %{_libdir}/gegl-0.4/*.so
234 %{_libdir}/gegl-0.4/dropshadow2.json
235 %{_libdir}/gegl-0.4/grey2.json
236 %if %{with lua}
237 %dir %{_datadir}/gegl-0.4
238 %{_datadir}/gegl-0.4/lua
239 %endif
240
241 %files devel
242 %defattr(644,root,root,755)
243 %attr(755,root,root) %{_libdir}/libgegl-0.4.so
244 %{_includedir}/gegl-0.4
245 %{?with_introspection:%{_datadir}/gir-1.0/Gegl-0.4.gir}
246 %{_pkgconfigdir}/gegl-0.4.pc
247 %{_pkgconfigdir}/gegl-sc-0.4.pc
248
249 %if %{with static_libs}
250 %files static
251 %defattr(644,root,root,755)
252 %{_libdir}/libgegl-0.4.a
253 %{_libdir}/libgegl-npd-0.4.a
254 %{_libdir}/libgegl-sc-0.4.a
255 %endif
256
257 %if %{with doc}
258 %files apidocs
259 %defattr(644,root,root,755)
260 %doc build/docs/{operations,*.html,*.png}
261 %{_gtkdocdir}/gegl
262 %endif
263
264 %if %{with vala}
265 %files -n vala-gegl
266 %defattr(644,root,root,755)
267 %{_datadir}/vala/vapi/gegl-0.4.deps
268 %{_datadir}/vala/vapi/gegl-0.4.vapi
269 %endif
This page took 0.267048 seconds and 4 git commands to generate.