]> git.pld-linux.org Git - packages/gegl.git/blob - gegl.spec
3bff6f56969cf08e01d61090c72bf61dd5095a2e
[packages/gegl.git] / gegl.spec
1 #
2 # Conditional build:
3 %bcond_without  doc             # apidocs
4 %bcond_without  lua             # without lua support
5 %bcond_without  static_libs     # static library
6 %bcond_without  introspection   # API introspection
7 %bcond_without  vala            # Vala API
8
9 %if %{without introspection}
10 %undefine       with_vala
11 %endif
12
13 %ifarch x32
14 %undefine       with_lua
15 %endif
16
17 %define babl_ver        0.1.78
18 %define mrg_ver         0.1.4
19
20 Summary:        Generic image processing library
21 Summary(pl.UTF-8):      Ogólna biblioteka przetwarzania obrazu
22 Name:           gegl
23 Version:        0.4.30
24 Release:        1
25 License:        LGPL v3+/GPL v3+
26 Group:          Libraries
27 Source0:        https://download.gimp.org/pub/gegl/0.4/%{name}-%{version}.tar.xz
28 # Source0-md5:  6ae601b8c7cab8af5a36406df0b95ebf
29 Patch1:         %{name}-ruby1.9.patch
30 Patch2:         %{name}-build.patch
31 Patch3:         umfpack.patch
32 Patch4:         %{name}-link.patch
33 Patch5:         %{name}-no-lua.patch
34 URL:            https://www.gegl.org/
35 BuildRequires:  OpenEXR-devel >= 1.6.1
36 BuildRequires:  SDL2-devel >= 2.0.5
37 BuildRequires:  UMFPACK-devel
38 BuildRequires:  asciidoc
39 BuildRequires:  babl-devel >= %{babl_ver}
40 BuildRequires:  bash
41 BuildRequires:  cairo-devel >= 1.12.2
42 BuildRequires:  enscript
43 BuildRequires:  exiv2-devel >= 0.25
44 # libavcodec >= 55.69.100, libavformat >= 55.48.100, libavutil >= 55.92.100, libswscale >= 2.6.100
45 BuildRequires:  ffmpeg-devel >= 2.3
46 BuildRequires:  gdk-pixbuf2-devel >= 2.32.0
47 BuildRequires:  gettext-tools >= 0.19.8
48 BuildRequires:  gexiv2-devel
49 BuildRequires:  glib2-devel >= 1:2.44.0
50 %{?with_introspection:BuildRequires:    gobject-introspection-devel >= 1.32.0}
51 BuildRequires:  graphviz
52 BuildRequires:  gtk-doc >= 1.0
53 BuildRequires:  jasper-devel >= 1.900.1
54 BuildRequires:  json-glib-devel >= 1.2.6
55 BuildRequires:  lcms2-devel >= 2.8
56 BuildRequires:  lensfun-devel >= 0.2.5
57 BuildRequires:  libjpeg-devel >= 1.0.0
58 BuildRequires:  libnsgif-devel
59 BuildRequires:  libpng-devel >= 2:1.6.0
60 BuildRequires:  libraw-devel >= 0.15.4
61 BuildRequires:  librsvg-devel >= 1:2.40.6
62 BuildRequires:  libspiro-devel >= 0.5.0
63 BuildRequires:  libtiff-devel >= 4.0.0
64 BuildRequires:  libv4l-devel >= 1.0.1
65 BuildRequires:  libwebp-devel >= 0.5.0
66 %if %{with lua}
67 BuildRequires:  luajit-devel >= 2.0.4
68 BuildRequires:  lua51-devel >= 5.1.5-2
69 %endif
70 BuildRequires:  maxflow-devel >= 3.0.4
71 BuildRequires:  meson >= 0.50.0
72 BuildRequires:  mrg-devel >= %{mrg_ver}
73 BuildRequires:  ninja >= 1.5
74 BuildRequires:  pango-devel >= 1:1.38.0
75 BuildRequires:  perl-base >= 5
76 BuildRequires:  pkgconfig
77 BuildRequires:  poppler-glib-devel >= 0.71.0
78 BuildRequires:  python3 >= 1:3.2
79 %if %{with introspection}
80 # for tests only
81 #BuildRequires: python-pygobject3-devel >= 3.2.0
82 %endif
83 BuildRequires:  poly2tri-c-devel
84 BuildRequires:  rpmbuild(macros) >= 1.736
85 BuildRequires:  ruby >= 1.9
86 BuildRequires:  tar >= 1:1.22
87 %if %{with vala}
88 BuildRequires:  vala >= 2:0.20.0
89 BuildRequires:  vala-babl >= %{babl_ver}
90 %endif
91 BuildRequires:  xz
92 BuildRequires:  zlib-devel >= 1.2.0
93 Requires:       OpenEXR >= 1.6.1
94 Requires:       SDL2 >= 2.0.5
95 Requires:       babl >= %{babl_ver}
96 Requires:       cairo >= 1.12.2
97 Requires:       gdk-pixbuf2 >= 2.32.0
98 Requires:       glib2 >= 1:2.44.0
99 Requires:       jasper-libs >= 1.900.1
100 Requires:       json-glib >= 1.2.6
101 Requires:       lcms2 >= 2.8
102 Requires:       lensfun >= 0.2.5
103 Requires:       libraw >= 0.15.4
104 Requires:       librsvg >= 1:2.40.6
105 Requires:       libspiro >= 0.5.0
106 Requires:       libtiff >= 4.0.0
107 Requires:       libwebp >= 0.5.0
108 Requires:       maxflow >= 3.0.4
109 Requires:       mrg-libs >= %{mrg_ver}
110 Requires:       pango >= 1:1.38.0
111 Requires:       poppler-glib >= 0.71.0
112 Requires:       zlib >= 1.2.0
113 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
114
115 %description
116 GEGL (Generic Graphics Library) is a graph based image processing
117 framework.
118
119 GEGL's original design was made to scratch GIMP's itches for a new
120 compositing and processing core. This core is being designed to have
121 minimal dependencies and a simple well defined API.
122
123 %description -l pl.UTF-8
124 GEGL (Generic Graphics Library) to oparty na grafice szkielet do
125 przetwarzania obrazu.
126
127 Pierwotny projekt biblioteki GEGL powstał z myślą o nowym rdzeniu do
128 składania i przetwarzania obrazu w GIMP-ie. Rdzeń ten jest
129 projektowany tak, by miał minimalne zależności i proste, dobrze
130 zdefiniowane API.
131
132 %package devel
133 Summary:        Header files for gegl library
134 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki gegl
135 Group:          Development/Libraries
136 Requires:       %{name} = %{version}-%{release}
137 Requires:       babl-devel >= %{babl_ver}
138 Requires:       glib2-devel >= 1:2.44.0
139 Requires:       json-glib-devel >= 1.2.6
140 Requires:       poly2tri-c-devel
141
142 %description devel
143 Header files for gegl library.
144
145 %description devel -l pl.UTF-8
146 Pliki nagłówkowe biblioteki gegl.
147
148 %package static
149 Summary:        Static gegl library
150 Summary(pl.UTF-8):      Statyczna biblioteka gegl
151 Group:          Development/Libraries
152 Requires:       %{name}-devel = %{version}-%{release}
153
154 %description static
155 Static gegl library.
156
157 %description static -l pl.UTF-8
158 Statyczna biblioteka gegl.
159
160 %package apidocs
161 Summary:        gegl library API documentation
162 Summary(pl.UTF-8):      Dokumentacja API biblioteki gegl
163 Group:          Documentation
164 Requires:       gtk-doc-common
165 BuildArch:      noarch
166
167 %description apidocs
168 gegl library API documentation.
169
170 %description apidocs -l pl.UTF-8
171 Dokumentacja API biblioteki gegl.
172
173 %package -n vala-gegl
174 Summary:        Vala API for gegl library
175 Summary(pl.UTF-8):      API języka Vala dla biblioteki gegl
176 Group:          Development/Libraries
177 Requires:       %{name}-devel = %{version}-%{release}
178 BuildArch:      noarch
179
180 %description -n vala-gegl
181 Vala API for gegl library.
182
183 %description -n vala-gegl -l pl.UTF-8
184 API języka Vala dla biblioteki gegl.
185
186 %prep
187 %setup -q
188 %patch1 -p1
189 %patch2 -p1
190 %patch3 -p1
191 %patch4 -p1
192 %patch5 -p1
193
194 %build
195 CPPFLAGS="%{rpmcppflags} -I/usr/include/umfpack"
196 %meson build \
197         %{?with_doc:-Ddocs=true} \
198         %{!?with_introspection:-Dintrospection=false} \
199         %{!?with_lua:-Dlua=disabled} \
200         -Dworkshop=true
201
202 %ninja_build -C build
203
204 %if %{with doc}
205 rmdir build/docs/operations/RAM
206 # possible gegl-tester coredumps?
207 rm -f build/docs/operations/core*
208 %endif
209
210 %install
211 rm -rf $RPM_BUILD_ROOT
212
213 %ninja_install -C build
214
215 %find_lang %{name}-0.4
216
217 %clean
218 rm -rf $RPM_BUILD_ROOT
219
220 %post   -p /sbin/ldconfig
221 %postun -p /sbin/ldconfig
222
223 %files -f %{name}-0.4.lang
224 %defattr(644,root,root,755)
225 %doc AUTHORS MAINTAINERS
226 %attr(755,root,root) %{_bindir}/gegl
227 %attr(755,root,root) %{_bindir}/gegl-imgcmp
228 %attr(755,root,root) %{_libdir}/libgegl-0.4.so.*.*.*
229 %attr(755,root,root) %ghost %{_libdir}/libgegl-0.4.so.0
230 %attr(755,root,root) %{_libdir}/libgegl-npd-0.4.so
231 %attr(755,root,root) %{_libdir}/libgegl-sc-0.4.so
232 %{?with_introspection:%{_libdir}/girepository-1.0/Gegl-0.4.typelib}
233 %dir %{_libdir}/gegl-0.4
234 %attr(755,root,root) %{_libdir}/gegl-0.4/*.so
235 %{_libdir}/gegl-0.4/dropshadow2.json
236 %{_libdir}/gegl-0.4/grey2.json
237 %if %{with lua}
238 %dir %{_datadir}/gegl-0.4
239 %{_datadir}/gegl-0.4/lua
240 %endif
241
242 %files devel
243 %defattr(644,root,root,755)
244 %attr(755,root,root) %{_libdir}/libgegl-0.4.so
245 %{_includedir}/gegl-0.4
246 %{?with_introspection:%{_datadir}/gir-1.0/Gegl-0.4.gir}
247 %{_pkgconfigdir}/gegl-0.4.pc
248 %{_pkgconfigdir}/gegl-sc-0.4.pc
249
250 %if %{with static_libs}
251 %files static
252 %defattr(644,root,root,755)
253 %{_libdir}/libgegl-0.4.a
254 %{_libdir}/libgegl-npd-0.4.a
255 %{_libdir}/libgegl-sc-0.4.a
256 %endif
257
258 %if %{with doc}
259 %files apidocs
260 %defattr(644,root,root,755)
261 %doc build/docs/{operations,*.html,*.png}
262 %{_gtkdocdir}/gegl
263 %endif
264
265 %if %{with vala}
266 %files -n vala-gegl
267 %defattr(644,root,root,755)
268 %{_datadir}/vala/vapi/gegl-0.4.deps
269 %{_datadir}/vala/vapi/gegl-0.4.vapi
270 %endif
This page took 0.047201 seconds and 2 git commands to generate.