]> git.pld-linux.org Git - packages/gegl.git/blob - gegl.spec
- rediffed no-lua patch
[packages/gegl.git] / gegl.spec
1 #
2 # Conditional build:
3 %bcond_without  doc             # apidocs
4 %bcond_without  lua             # without lua support
5 %bcond_without  static_libs     # static library
6 %bcond_without  introspection   # API introspection
7 %bcond_without  vala            # Vala API
8
9 %if %{without introspection}
10 %undefine       with_vala
11 %endif
12
13 %ifarch x32
14 %undefine       with_lua
15 %endif
16
17 %define babl_ver        0.1.78
18 %define mrg_ver         0.1.4
19
20 Summary:        Generic image processing library
21 Summary(pl.UTF-8):      Ogólna biblioteka przetwarzania obrazu
22 Name:           gegl
23 Version:        0.4.30
24 Release:        1
25 License:        LGPL v3+/GPL v3+
26 Group:          Libraries
27 Source0:        https://download.gimp.org/pub/gegl/0.4/%{name}-%{version}.tar.xz
28 # Source0-md5:  6ae601b8c7cab8af5a36406df0b95ebf
29 Patch1:         %{name}-ruby1.9.patch
30 Patch2:         %{name}-build.patch
31 Patch3:         umfpack.patch
32 Patch4:         %{name}-link.patch
33 Patch5:         %{name}-no-lua.patch
34 URL:            https://www.gegl.org/
35 BuildRequires:  OpenEXR-devel >= 1.6.1
36 BuildRequires:  SDL2-devel >= 2.0.5
37 BuildRequires:  UMFPACK-devel
38 BuildRequires:  asciidoc
39 BuildRequires:  babl-devel >= %{babl_ver}
40 BuildRequires:  bash
41 BuildRequires:  cairo-devel >= 1.12.2
42 BuildRequires:  enscript
43 BuildRequires:  exiv2-devel >= 0.25
44 # libavcodec >= 55.69.100, libavformat >= 55.48.100, libavutil >= 55.92.100, libswscale >= 2.6.100
45 BuildRequires:  ffmpeg-devel >= 2.3
46 BuildRequires:  gcc >= 5:4.7
47 BuildRequires:  gdk-pixbuf2-devel >= 2.32.0
48 BuildRequires:  gettext-tools >= 0.19.8
49 BuildRequires:  gexiv2-devel
50 BuildRequires:  glib2-devel >= 1:2.44.0
51 %{?with_introspection:BuildRequires:    gobject-introspection-devel >= 1.32.0}
52 BuildRequires:  graphviz
53 BuildRequires:  gtk-doc >= 1.0
54 BuildRequires:  jasper-devel >= 1.900.1
55 BuildRequires:  json-glib-devel >= 1.2.6
56 BuildRequires:  lcms2-devel >= 2.8
57 BuildRequires:  lensfun-devel >= 0.2.5
58 BuildRequires:  libjpeg-devel >= 1.0.0
59 BuildRequires:  libnsgif-devel
60 BuildRequires:  libpng-devel >= 2:1.6.0
61 BuildRequires:  libraw-devel >= 0.15.4
62 BuildRequires:  librsvg-devel >= 1:2.40.6
63 BuildRequires:  libspiro-devel >= 0.5.0
64 BuildRequires:  libstdc++-devel >= 6:5
65 BuildRequires:  libtiff-devel >= 4.0.0
66 BuildRequires:  libv4l-devel >= 1.0.1
67 BuildRequires:  libwebp-devel >= 0.5.0
68 %if %{with lua}
69 BuildRequires:  luajit-devel >= 2.0.4
70 BuildRequires:  lua51-devel >= 5.1.5-2
71 %endif
72 BuildRequires:  maxflow-devel >= 3.0.4
73 BuildRequires:  meson >= 0.50.0
74 BuildRequires:  mrg-devel >= %{mrg_ver}
75 BuildRequires:  ninja >= 1.5
76 BuildRequires:  pango-devel >= 1:1.38.0
77 BuildRequires:  perl-base >= 5
78 BuildRequires:  pkgconfig
79 BuildRequires:  poppler-glib-devel >= 0.71.0
80 BuildRequires:  python3 >= 1:3.2
81 %if %{with introspection}
82 # for tests only
83 #BuildRequires: python-pygobject3-devel >= 3.2.0
84 %endif
85 BuildRequires:  poly2tri-c-devel
86 BuildRequires:  rpmbuild(macros) >= 1.736
87 BuildRequires:  ruby >= 1.9
88 BuildRequires:  tar >= 1:1.22
89 %if %{with vala}
90 BuildRequires:  vala >= 2:0.20.0
91 BuildRequires:  vala-babl >= %{babl_ver}
92 %endif
93 BuildRequires:  xz
94 BuildRequires:  zlib-devel >= 1.2.0
95 Requires:       OpenEXR >= 1.6.1
96 Requires:       SDL2 >= 2.0.5
97 Requires:       babl >= %{babl_ver}
98 Requires:       cairo >= 1.12.2
99 Requires:       gdk-pixbuf2 >= 2.32.0
100 Requires:       glib2 >= 1:2.44.0
101 Requires:       jasper-libs >= 1.900.1
102 Requires:       json-glib >= 1.2.6
103 Requires:       lcms2 >= 2.8
104 Requires:       lensfun >= 0.2.5
105 Requires:       libraw >= 0.15.4
106 Requires:       librsvg >= 1:2.40.6
107 Requires:       libspiro >= 0.5.0
108 Requires:       libtiff >= 4.0.0
109 Requires:       libwebp >= 0.5.0
110 Requires:       maxflow >= 3.0.4
111 Requires:       mrg-libs >= %{mrg_ver}
112 Requires:       pango >= 1:1.38.0
113 Requires:       poppler-glib >= 0.71.0
114 Requires:       zlib >= 1.2.0
115 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
116
117 %description
118 GEGL (Generic Graphics Library) is a graph based image processing
119 framework.
120
121 GEGL's original design was made to scratch GIMP's itches for a new
122 compositing and processing core. This core is being designed to have
123 minimal dependencies and a simple well defined API.
124
125 %description -l pl.UTF-8
126 GEGL (Generic Graphics Library) to oparty na grafice szkielet do
127 przetwarzania obrazu.
128
129 Pierwotny projekt biblioteki GEGL powstał z myślą o nowym rdzeniu do
130 składania i przetwarzania obrazu w GIMP-ie. Rdzeń ten jest
131 projektowany tak, by miał minimalne zależności i proste, dobrze
132 zdefiniowane API.
133
134 %package devel
135 Summary:        Header files for gegl library
136 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki gegl
137 Group:          Development/Libraries
138 Requires:       %{name} = %{version}-%{release}
139 Requires:       babl-devel >= %{babl_ver}
140 Requires:       glib2-devel >= 1:2.44.0
141 Requires:       json-glib-devel >= 1.2.6
142 Requires:       poly2tri-c-devel
143
144 %description devel
145 Header files for gegl library.
146
147 %description devel -l pl.UTF-8
148 Pliki nagłówkowe biblioteki gegl.
149
150 %package static
151 Summary:        Static gegl library
152 Summary(pl.UTF-8):      Statyczna biblioteka gegl
153 Group:          Development/Libraries
154 Requires:       %{name}-devel = %{version}-%{release}
155
156 %description static
157 Static gegl library.
158
159 %description static -l pl.UTF-8
160 Statyczna biblioteka gegl.
161
162 %package apidocs
163 Summary:        gegl library API documentation
164 Summary(pl.UTF-8):      Dokumentacja API biblioteki gegl
165 Group:          Documentation
166 Requires:       gtk-doc-common
167 BuildArch:      noarch
168
169 %description apidocs
170 gegl library API documentation.
171
172 %description apidocs -l pl.UTF-8
173 Dokumentacja API biblioteki gegl.
174
175 %package -n vala-gegl
176 Summary:        Vala API for gegl library
177 Summary(pl.UTF-8):      API języka Vala dla biblioteki gegl
178 Group:          Development/Libraries
179 Requires:       %{name}-devel = %{version}-%{release}
180 BuildArch:      noarch
181
182 %description -n vala-gegl
183 Vala API for gegl library.
184
185 %description -n vala-gegl -l pl.UTF-8
186 API języka Vala dla biblioteki gegl.
187
188 %prep
189 %setup -q
190 %patch1 -p1
191 %patch2 -p1
192 %patch3 -p1
193 %patch4 -p1
194 %patch5 -p1
195
196 %build
197 CPPFLAGS="%{rpmcppflags} -I/usr/include/umfpack"
198 %meson build \
199         %{?with_doc:-Ddocs=true} \
200         %{!?with_introspection:-Dintrospection=false} \
201         %{!?with_lua:-Dlua=disabled} \
202         -Dworkshop=true
203
204 %ninja_build -C build
205
206 %if %{with doc}
207 rmdir build/docs/operations/RAM
208 # possible gegl-tester coredumps?
209 rm -f build/docs/operations/core*
210 %endif
211
212 %install
213 rm -rf $RPM_BUILD_ROOT
214
215 %ninja_install -C build
216
217 %find_lang %{name}-0.4
218
219 %clean
220 rm -rf $RPM_BUILD_ROOT
221
222 %post   -p /sbin/ldconfig
223 %postun -p /sbin/ldconfig
224
225 %files -f %{name}-0.4.lang
226 %defattr(644,root,root,755)
227 %doc AUTHORS MAINTAINERS
228 %attr(755,root,root) %{_bindir}/gegl
229 %attr(755,root,root) %{_bindir}/gegl-imgcmp
230 %attr(755,root,root) %{_libdir}/libgegl-0.4.so.*.*.*
231 %attr(755,root,root) %ghost %{_libdir}/libgegl-0.4.so.0
232 %attr(755,root,root) %{_libdir}/libgegl-npd-0.4.so
233 %attr(755,root,root) %{_libdir}/libgegl-sc-0.4.so
234 %{?with_introspection:%{_libdir}/girepository-1.0/Gegl-0.4.typelib}
235 %dir %{_libdir}/gegl-0.4
236 %attr(755,root,root) %{_libdir}/gegl-0.4/*.so
237 %{_libdir}/gegl-0.4/dropshadow2.json
238 %{_libdir}/gegl-0.4/grey2.json
239 %if %{with lua}
240 %dir %{_datadir}/gegl-0.4
241 %{_datadir}/gegl-0.4/lua
242 %endif
243
244 %files devel
245 %defattr(644,root,root,755)
246 %attr(755,root,root) %{_libdir}/libgegl-0.4.so
247 %{_includedir}/gegl-0.4
248 %{?with_introspection:%{_datadir}/gir-1.0/Gegl-0.4.gir}
249 %{_pkgconfigdir}/gegl-0.4.pc
250 %{_pkgconfigdir}/gegl-sc-0.4.pc
251
252 %if %{with static_libs}
253 %files static
254 %defattr(644,root,root,755)
255 %{_libdir}/libgegl-0.4.a
256 %{_libdir}/libgegl-npd-0.4.a
257 %{_libdir}/libgegl-sc-0.4.a
258 %endif
259
260 %if %{with doc}
261 %files apidocs
262 %defattr(644,root,root,755)
263 %doc build/docs/{operations,*.html,*.png}
264 %{_gtkdocdir}/gegl
265 %endif
266
267 %if %{with vala}
268 %files -n vala-gegl
269 %defattr(644,root,root,755)
270 %{_datadir}/vala/vapi/gegl-0.4.deps
271 %{_datadir}/vala/vapi/gegl-0.4.vapi
272 %endif
This page took 0.252957 seconds and 3 git commands to generate.