]> git.pld-linux.org Git - packages/gegl.git/blob - gegl.spec
0d8bb1d711c30147669e3e7f339c98348b78fdc5
[packages/gegl.git] / gegl.spec
1 #
2 # TODO:
3 # - links against zstd (some of the BR: misses dep on zstd)
4 #
5 # Conditional build:
6 %bcond_with     mmx             # use MMX instructions
7 %bcond_with     sse             # use SSE instructions
8 %bcond_without  doc             # apidocs
9 %bcond_without  lua             # without lua support
10 %bcond_without  static_libs     # static library
11 %bcond_without  introspection   # API introspection
12 %bcond_without  vala            # Vala API
13
14 %ifarch %{x8664} athlon pentium3 pentium4
15 %define with_mmx        1
16 %endif
17 %ifarch %{x8664} pentium3 pentium4
18 %define with_sse        1
19 %endif
20 %if %{without introspection}
21 %undefine       with_vala
22 %endif
23
24 %ifarch x32
25 %undefine       with_lua
26 %endif
27
28 %define babl_version    0.1.62
29 %define mrg_version     0.1.2-1.20190322.1
30
31 Summary:        Generic image processing library
32 Summary(pl.UTF-8):      Ogólna biblioteka przetwarzania obrazu
33 Name:           gegl
34 Version:        0.4.16
35 Release:        2
36 License:        LGPL v3+
37 Group:          Libraries
38 Source0:        https://download.gimp.org/pub/gegl/0.4/%{name}-%{version}.tar.bz2
39 # Source0-md5:  cb17ac529a882f25f54c0115c63d4027
40 Patch1:         %{name}-ruby1.9.patch
41 Patch2:         %{name}-build.patch
42 Patch3:         umfpack.patch
43 URL:            http://www.gegl.org/
44 BuildRequires:  OpenEXR-devel >= 1.6.1
45 BuildRequires:  SDL-devel >= 1.2.0
46 BuildRequires:  UMFPACK-devel
47 BuildRequires:  asciidoc
48 BuildRequires:  autoconf >= 2.54
49 BuildRequires:  automake >= 1:1.11
50 BuildRequires:  babl-devel >= %{babl_version}
51 BuildRequires:  cairo-devel >= 1.12.2
52 BuildRequires:  enscript
53 BuildRequires:  exiv2-devel >= 0.25
54 # libavformat >= 55.48.100, libavcodec >= 55.69.100, libavutil >= 52.92.100, libswscale >= 2.6.100
55 BuildRequires:  ffmpeg-devel >= 2.3
56 BuildRequires:  gdk-pixbuf2-devel >= 2.32.0
57 BuildRequires:  gettext-tools >= 0.19.8
58 BuildRequires:  gexiv2-devel
59 BuildRequires:  glib2-devel >= 1:2.44.0
60 %{?with_introspection:BuildRequires:    gobject-introspection-devel >= 1.32.0}
61 BuildRequires:  graphviz
62 BuildRequires:  gtk-doc >= 1.0
63 BuildRequires:  jasper-devel >= 1.900.1
64 BuildRequires:  json-glib-devel
65 BuildRequires:  lcms2-devel >= 2.8
66 BuildRequires:  lensfun-devel >= 0.2.5
67 BuildRequires:  libjpeg-devel
68 BuildRequires:  libpng-devel >= 2:1.6.0
69 BuildRequires:  libraw-devel >= 0.15.4
70 BuildRequires:  librsvg-devel >= 1:2.40.6
71 BuildRequires:  libspiro-devel
72 BuildRequires:  libtiff-devel >= 4.0.0
73 BuildRequires:  libtool >= 2:2.2
74 # as of 0.4.16, internal copy of code is used
75 #BuildRequires: libv4l-devel >= 1.0.1
76 BuildRequires:  libwebp-devel >= 0.5.0
77 %if %{with lua}
78 BuildRequires:  luajit-devel >= 2.0.4
79 BuildRequires:  lua51-devel >= 5.1.5-2
80 %endif
81 BuildRequires:  mrg-devel >= %{mrg_version}
82 BuildRequires:  pango-devel >= 1:1.38.0
83 BuildRequires:  perl-base >= 5
84 BuildRequires:  pkgconfig
85 BuildRequires:  poppler-glib-devel >= 0.71.0
86 BuildRequires:  python >= 1:2.5.0
87 # either one?
88 #BuildRequires: python-pygobject-devel >= 2.26
89 BuildRequires:  python-pygobject3-devel >= 3.2
90 BuildRequires:  poly2tri-c-devel
91 BuildRequires:  ruby >= 1.9
92 %{?with_vala:BuildRequires:     vala >= 2:0.20.0}
93 BuildRequires:  zlib-devel >= 1.2.0
94 Requires:       babl >= %{babl_version}
95 Requires:       cairo >= 1.12.2
96 Requires:       gdk-pixbuf2 >= 2.32.0
97 Requires:       glib2 >= 1:2.44.0
98 Requires:       jasper-libs >= 1.900.1
99 Requires:       lcms2 >= 2.8
100 Requires:       lensfun >= 0.2.5
101 Requires:       libraw >= 0.15.4
102 Requires:       librsvg >= 1:2.40.6
103 Requires:       libtiff >= 4.0.0
104 Requires:       libwebp >= 0.5.0
105 Requires:       mrg-libs >= %{mrg_version}
106 Requires:       pango >= 1:1.38.0
107 Requires:       poppler-glib >= 0.71.0
108 Requires:       zlib >= 1.2.0
109 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
110
111 %description
112 GEGL (Generic Graphics Library) is a graph based image processing
113 framework.
114
115 GEGL's original design was made to scratch GIMP's itches for a new
116 compositing and processing core. This core is being designed to have
117 minimal dependencies and a simple well defined API.
118
119 %description -l pl.UTF-8
120 GEGL (Generic Graphics Library) to oparty na grafice szkielet do
121 przetwarzania obrazu.
122
123 Pierwotny projekt biblioteki GEGL powstał z myślą o nowym rdzeniu do
124 składania i przetwarzania obrazu w GIMP-ie. Rdzeń ten jest
125 projektowany tak, by miał minimalne zależności i proste, dobrze
126 zdefiniowane API.
127
128 %package devel
129 Summary:        Header files for gegl library
130 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki gegl
131 Group:          Development/Libraries
132 Requires:       %{name} = %{version}-%{release}
133 Requires:       babl-devel >= %{babl_version}
134 Requires:       glib2-devel >= 1:2.44.0
135 Requires:       json-glib-devel
136 Requires:       poly2tri-c-devel
137
138 %description devel
139 Header files for gegl library.
140
141 %description devel -l pl.UTF-8
142 Pliki nagłówkowe biblioteki gegl.
143
144 %package static
145 Summary:        Static gegl library
146 Summary(pl.UTF-8):      Statyczna biblioteka gegl
147 Group:          Development/Libraries
148 Requires:       %{name}-devel = %{version}-%{release}
149
150 %description static
151 Static gegl library.
152
153 %description static -l pl.UTF-8
154 Statyczna biblioteka gegl.
155
156 %package apidocs
157 Summary:        gegl library API documentation
158 Summary(pl.UTF-8):      Dokumentacja API biblioteki gegl
159 Group:          Documentation
160 Requires:       gtk-doc-common
161 %if "%{_rpmversion}" >= "5"
162 BuildArch:      noarch
163 %endif
164
165 %description apidocs
166 gegl library API documentation.
167
168 %description apidocs -l pl.UTF-8
169 Dokumentacja API biblioteki gegl.
170
171 %package -n vala-gegl
172 Summary:        Vala API for gegl library
173 Summary(pl.UTF-8):      API języka Vala dla biblioteki gegl
174 Group:          Development/Libraries
175 Requires:       %{name}-devel = %{version}-%{release}
176 %if "%{_rpmversion}" >= "5"
177 BuildArch:      noarch
178 %endif
179
180 %description -n vala-gegl
181 Vala API for gegl library.
182
183 %description -n vala-gegl -l pl.UTF-8
184 API języka Vala dla biblioteki gegl.
185
186 %prep
187 %setup -q
188 %patch1 -p1
189 %patch2 -p1
190 %patch3 -p1
191
192 %build
193 %{__libtoolize}
194 %{__aclocal} -I m4
195 %{__autoconf}
196 %{__autoheader}
197 %{__automake}
198 %configure \
199         CPPFLAGS="%{rpmcppflags} -I/usr/include/umfpack" \
200         --enable-docs%{!?with_doc:=no} \
201         %{?with_introspection:--enable-introspection} \
202         %{!?with_mmx:--disable-mmx} \
203         %{!?with_sse:--disable-sse} \
204         --disable-silent-rules \
205         %{?with_static_libs:--enable-static} \
206         --with-vala%{!?with_vala:=no} \
207         %{__with_without lua}
208 %{__make}
209
210 %install
211 rm -rf $RPM_BUILD_ROOT
212
213 %{__make} install \
214         DESTDIR=$RPM_BUILD_ROOT \
215         gtkdochtmldir=%{_gtkdocdir}/gegl
216
217 # obsoleted by pkg-config
218 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libgegl*-0.4.la
219 # dlopened modules
220 %{__rm} $RPM_BUILD_ROOT%{_libdir}/gegl-0.4/*.la
221 %if %{with static_libs}
222 %{__rm} $RPM_BUILD_ROOT%{_libdir}/gegl-0.4/*.a
223 %endif
224
225 %find_lang %{name}-0.4
226
227 %clean
228 rm -rf $RPM_BUILD_ROOT
229
230 %post   -p /sbin/ldconfig
231 %postun -p /sbin/ldconfig
232
233 %files -f %{name}-0.4.lang
234 %defattr(644,root,root,755)
235 %doc AUTHORS ChangeLog NEWS README
236 %attr(755,root,root) %{_bindir}/gcut
237 %attr(755,root,root) %{_bindir}/gegl
238 %attr(755,root,root) %{_bindir}/gegl-imgcmp
239 %attr(755,root,root) %{_libdir}/libgegl-0.4.so.*.*.*
240 %attr(755,root,root) %ghost %{_libdir}/libgegl-0.4.so.0
241 %attr(755,root,root) %{_libdir}/libgegl-npd-0.4.so
242 %attr(755,root,root) %{_libdir}/libgegl-sc-0.4.so
243 %{?with_introspection:%{_libdir}/girepository-1.0/Gegl-0.4.typelib}
244 %dir %{_libdir}/gegl-0.4
245 %attr(755,root,root) %{_libdir}/gegl-0.4/*.so
246 %{_libdir}/gegl-0.4/grey2.json
247
248 %files devel
249 %defattr(644,root,root,755)
250 %attr(755,root,root) %{_libdir}/libgegl-0.4.so
251 %{_includedir}/gegl-0.4
252 %{?with_introspection:%{_datadir}/gir-1.0/Gegl-0.4.gir}
253 %{_pkgconfigdir}/gegl-0.4.pc
254 %{_pkgconfigdir}/gegl-sc-0.4.pc
255
256 %if %{with static_libs}
257 %files static
258 %defattr(644,root,root,755)
259 %{_libdir}/libgegl-0.4.a
260 %{_libdir}/libgegl-npd-0.4.a
261 %{_libdir}/libgegl-sc-0.4.a
262 %endif
263
264 %if %{with doc}
265 %files apidocs
266 %defattr(644,root,root,755)
267 %{_gtkdocdir}/gegl
268 %endif
269
270 %if %{with vala}
271 %files -n vala-gegl
272 %defattr(644,root,root,755)
273 %{_datadir}/vala/vapi/gegl-0.4.deps
274 %{_datadir}/vala/vapi/gegl-0.4.vapi
275 %endif
This page took 0.03416 seconds and 2 git commands to generate.