]> git.pld-linux.org Git - packages/geeqie.git/commitdiff
- updated to 1.3 auto/th/geeqie-1.3-1
authorJakub Bogusz <qboosh@pld-linux.org>
Thu, 8 Sep 2016 13:32:27 +0000 (15:32 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Thu, 8 Sep 2016 13:32:27 +0000 (15:32 +0200)
- removed obsolete raws patch
- default to gtk3 with clutter and maps/champlain support

geeqie-raws.patch [deleted file]
geeqie.spec

diff --git a/geeqie-raws.patch b/geeqie-raws.patch
deleted file mode 100644 (file)
index 917b12c..0000000
+++ /dev/null
@@ -1,52 +0,0 @@
-Subject: Fix RAW photos display with new GCC
-From: David Kalnischkies <david@kalnischkies.de>
-
-diff --git a/src/exiv2.cc b/src/exiv2.cc
-index 455c8d3..98029cd 100644
---- a/src/exiv2.cc
-+++ b/src/exiv2.cc
-@@ -16,6 +16,7 @@
- #include <exiv2/image.hpp>
- #include <exiv2/exif.hpp>
- #include <iostream>
-+#include <string>
- // EXIV2_TEST_VERSION is defined in Exiv2 0.15 and newer.
- #ifndef EXIV2_TEST_VERSION
-@@ -1130,9 +1131,9 @@ guchar *exif_get_preview(ExifData *exif, guint *data_len, gint requested_width,
-       if (!exif->image()) return NULL;
-       
--      const char* path = exif->image()->io().path().c_str();
-+      std::string const path = exif->image()->io().path();
-       /* given image pathname, first do simple (and fast) file extension test */
--      gboolean is_raw = filter_file_class(path, FORMAT_CLASS_RAWIMAGE);
-+      gboolean is_raw = filter_file_class(path.c_str(), FORMAT_CLASS_RAWIMAGE);
-       
-       if (!is_raw && requested_width == 0) return NULL;
-@@ -1232,10 +1233,10 @@ extern "C" guchar *exif_get_preview(ExifData *exif, guint *data_len, gint reques
-       if (!exif) return NULL;
-       if (!exif->image()) return NULL;
--      const char* path = exif->image()->io().path().c_str();
-+      std::string const path = exif->image()->io().path();
-       /* given image pathname, first do simple (and fast) file extension test */
--      if (!filter_file_class(path, FORMAT_CLASS_RAWIMAGE)) return NULL;
-+      if (!filter_file_class(path.c_str(), FORMAT_CLASS_RAWIMAGE)) return NULL;
-       try {
-               struct stat st;
-@@ -1246,9 +1247,9 @@ extern "C" guchar *exif_get_preview(ExifData *exif, guint *data_len, gint reques
-               
-               RawFile rf(exif->image()->io());
-               offset = rf.preview_offset();
--              DEBUG_1("%s: offset %lu", path, offset);
-+              DEBUG_1("%s: offset %lu", path.c_str(), offset);
-               
--              fd = open(path, O_RDONLY);
-+              fd = open(path.c_str(), O_RDONLY);
-               if (fd == -1)
-                       {
-                       return NULL;
index 919fa0004c01424200a7d390764b8ca7048297db..7f1bcba980e983d24489141ad486273e974d6b79 100644 (file)
@@ -1,33 +1,56 @@
+#
+# Conditional build:
+%bcond_with    gtk2            # use GTK+ 2.x instead of 3.x
+%bcond_without champlain       # maps support via libchamplain [gtk+3 only]
+%bcond_without clutter         # GPU accelleration via clutter [gtk+3 only]
+#
+%if %{with gtk2}
+%undefine      with_champlain
+%undefine      with_clutter
+%endif
 Summary:       Graphics file browser utility
 Summary(hu.UTF-8):     Képfájl-böngésző eszköz
 Summary(pl.UTF-8):     Narzędzie do przeglądania plików graficznych
 Name:          geeqie
-Version:       1.2.3
-Release:       2
-License:       GPL v2
+Version:       1.3
+Release:       1
+License:       GPL v2+
 Group:         X11/Applications/Graphics
 Source0:       http://www.geeqie.org/%{name}-%{version}.tar.xz
-# Source0-md5: fab78be9fca02b68cd670e5359457b88
+# Source0-md5: 0339ad62946cae7009ec76ec21572065
 Patch0:                libdir-fix.patch
-Patch1:                %{name}-raws.patch
 URL:           http://www.geeqie.org/
-BuildRequires: autoconf
+BuildRequires: autoconf >= 2.57
 BuildRequires: automake
-BuildRequires: exiv2-devel
+BuildRequires: clutter-devel >= 1.0
+BuildRequires: clutter-gtk-devel >= 1.0
+BuildRequires: exiv2-devel >= 0.11
+BuildRequires: gdk-pixbuf2-devel >= 2
 BuildRequires: gettext-tools
-BuildRequires: gtk+2-devel >= 2:2.4.0
+BuildRequires: glib2-devel >= 1:2.24.0
+BuildRequires: gnome-doc-utils
+%{?with_gtk2:BuildRequires:    gtk+2-devel >= 2:2.20.0}
+%{!?with_gtk2:BuildRequires:   gtk+3-devel >= 3.0.0}
 BuildRequires: intltool >= 0.40.0
+BuildRequires: lcms2-devel >= 2.0
+BuildRequires: libchamplain-devel >= 0.12
+BuildRequires: libjpeg-devel
 BuildRequires: libpng-devel
-BuildRequires: libtool
+BuildRequires: libstdc++-devel
+BuildRequires: libtiff-devel
+BuildRequires: lirc-devel
+BuildRequires: lua51-devel >= 5.1.5-2
 BuildRequires: pkgconfig
 BuildRequires: rpmbuild(macros) >= 1.197
 BuildRequires: tar >= 1:1.22
 BuildRequires: xz
 Requires:      desktop-file-utils
+Requires:      glib2 >= 1:2.24.0
+%{?with_gtk2:Requires: gtk+2 >= 2:2.20.0}
+%{!?with_gtk2:Requires:        gtk+3 >= 3.0.0}
 Requires:      libjpeg-progs
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-
 %define                specflags_ia32          -fomit-frame-pointer
 
 %description
@@ -54,20 +77,24 @@ i opcje filtrowania, jak również wsparcie dla zewnętrznego edytora.
 %prep
 %setup -q
 %patch0 -p1
-%patch1 -p1
 
 %build
+install -d auxdir
 %{__intltoolize}
-%{__libtoolize}
 %{__aclocal}
 %{__autoconf}
 %{__autoheader}
 %{__automake}
-%configure
+%configure \
+       %{!?with_clutter:--disable-gpu-accel} \
+       --enable-gtk3%{?with_gtk2:=no} \
+       %{?with_champlain:--enable-map}
+
 %{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
+
 %{__make} install \
        GNOME_DOC_TOOL=/disable-install-hook \
        DESTDIR=$RPM_BUILD_ROOT
This page took 0.289386 seconds and 4 git commands to generate.