]> git.pld-linux.org Git - packages/gdb.git/commitdiff
attempt to fix x32 build auto/th/gdb-11.1-1
authorJan Palus <atler@pld-linux.org>
Sun, 21 Nov 2021 17:34:47 +0000 (18:34 +0100)
committerJan Palus <atler@pld-linux.org>
Sun, 21 Nov 2021 17:34:47 +0000 (18:34 +0100)
by effectively disabling following change on x32:

https://sourceware.org/git/?p=binutils-gdb.git;a=commitdiff;h=d3d7d1b

gdb.spec
x32.patch [new file with mode: 0644]

index 23ed5edea9aea17fc6b0b83d7100ac6022c08950..b0531fe1cbd8d5e6552124d854a6bcc9c771d81f 100644 (file)
--- a/gdb.spec
+++ b/gdb.spec
@@ -31,6 +31,7 @@ Source1:      http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-ma
 # Source1-md5: 2e8a48939ae282c12bbacdd54e398247
 Source3:       %{name}-gstack.man
 Patch0:                glibc2.34.patch
+Patch1:                x32.patch
 Patch100:      gdb-6.6-buildid-locate.patch
 Patch101:      gdb-6.6-buildid-locate-solib-missing-ids.patch
 Patch102:      gdb-6.6-buildid-locate-rpm.patch
@@ -192,6 +193,7 @@ GDB w postaci biblioteki statycznej.
 %{__rm} gdb/m2-exp.c gdb/p-exp.c
 
 %patch0 -p1
+%patch1 -p1
 %patch100 -p1
 %patch101 -p1
 %patch102 -p1
diff --git a/x32.patch b/x32.patch
new file mode 100644 (file)
index 0000000..a7753d0
--- /dev/null
+++ b/x32.patch
@@ -0,0 +1,18 @@
+--- gdb-11.1/gdb/nat/amd64-linux-siginfo.c.orig        2021-07-03 19:41:10.000000000 +0200
++++ gdb-11.1/gdb/nat/amd64-linux-siginfo.c     2021-11-21 18:32:29.634785279 +0100
+@@ -330,6 +330,7 @@
+       to->cpt_si_pid = from_ptrace.cpt_si_pid;
+       to->cpt_si_uid = from_ptrace.cpt_si_uid;
+     }
++#ifndef __ILP32__
+   else if (to->si_code == SEGV_BNDERR
+          && to->si_signo == SIGSEGV)
+     {
+@@ -337,6 +338,7 @@
+       to->cpt_si_lower = from_ptrace.cpt_si_lower;
+       to->cpt_si_upper = from_ptrace.cpt_si_upper;
+     }
++#endif
+   else if (to->si_code < 0)
+     {
+       to->cpt_si_pid = from_ptrace.cpt_si_pid;
This page took 0.423401 seconds and 4 git commands to generate.