]> git.pld-linux.org Git - packages/foobillard.git/blob - foobillard.spec
- with_nvidia BR,R: XFree86-driver-nvidia
[packages/foobillard.git] / foobillard.spec
1 #
2 # Conditional build:
3 %bcond_with     glut    # use glut instead of SDL
4 %bcond_with nvidia # enable NVidia specific extensions
5
6 Summary:        A free OpenGL game of playing billard
7 Summary(pl):    Wolnodostêpna gra w bilard oparta na OpenGL
8 Name:           foobillard
9 Version:        2.9
10 Release:        1
11 Vendor:         Florian Berger <florian.berger@aec.at>, <harpin_floh@yahoo.de>
12 License:        GPL
13 Group:          X11/Applications/Games
14 Source0:        http://foobillard.sunsite.dk/dnl/%{name}-%{version}.tar.gz
15 # Source0-md5:  b8b10d7d3ade07a9e0c497165beadbca
16 Source1:        %{name}.desktop
17 Source2:        %{name}.xpm
18 URL:            http://foobillard.sunsite.dk/
19 BuildRequires:  OpenGL-devel
20 %{!?with_glut:BuildRequires:    SDL-devel}
21 %{?with_nvidia:BuildRequires:   XFree86-driver-nvidia}
22 BuildRequires:  autoconf
23 BuildRequires:  automake
24 BuildRequires:  freetype-devel
25 %{?with_glut:BuildRequires:     glut-devel}
26 BuildRequires:  intltool
27 Requires:       OpenGL
28 %{?with_nvidia:Requires:        XFree86-driver-nvidia}
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
32
33 %description
34 FooBillard is an attempt to create a free OpenGL-billard for Linux.
35 Why foo? Well, actually I had this logo (F.B.-Florian Berger) and then
36 foo sounds a bit like pool (Somehow I wasn't quite attracted by the
37 name FoolBillard). Actually FooBillard is still under development but
38 the main physics is implemented. If you are a billard-pro and you're
39 missing some physics, please tell me. Cause I've implemented it like I
40 think it should work, which might differ from reality.
41
42 %description -l pl
43 FooBillard to próba stworzenia wolnodostêpnego bilarda OpenGL dla
44 Linuksa. Dlaczego foo? Bo autor mia³ ju¿ to logo (F.B. - Florian
45 Berger) i "foo" brzmi trochê jak "pool" (a nazwa "FoolBillard" nie
46 brzmia³a zbyt przyci±gaj±co). FooBillard jest nadal w stadium rozwoju,
47 ale g³ówna fizyka jest ju¿ zaimplementowana. Je¿eli w grze brakuje
48 jakiej¶ fizyki, dobrze jest zg³osiæ to autorowi, poniewa¿ on
49 zaimplementowa³ j± tak, jak my¶la³, ¿e powinna dzia³aæ, co mo¿e siê
50 nieco ró¿niæ od rzeczywisto¶ci.
51
52 %prep
53 %setup -q
54
55 %build
56 rm -f missing
57 X_LIBS='-I/usr/X11R6/include'; export X_LIBS
58 %{__libtoolize}
59 %{__aclocal}
60 %{__autoconf}
61 %{__automake}
62 %configure \
63         %{!?with_glut:--enable-SDL}%{?with_glut:--enable-glut} \
64         %{!?with_nvidia:--disable-nvidia}%{?with_nvidia:--enable-nvidia}
65
66 %{__make}
67
68 %install
69 rm -rf $RPM_BUILD_ROOT
70 install -d $RPM_BUILD_ROOT{%{_applnkdir}/Games,%{_pixmapsdir}}
71
72 %{__make} install \
73         DESTDIR=$RPM_BUILD_ROOT
74
75 install %{SOURCE1} $RPM_BUILD_ROOT%{_applnkdir}/Games
76 install %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}
77
78 %clean
79 rm -rf $RPM_BUILD_ROOT
80
81 %files
82 %defattr(644,root,root,755)
83 %doc AUTHORS NEWS README ChangeLog TODO README.FONTS foobillardrc.example
84 %attr(755,root,root) %{_bindir}/*
85 %{_datadir}/foobillard
86 %{_applnkdir}/Games/%{name}.desktop
87 %{_pixmapsdir}/*
This page took 0.033818 seconds and 4 git commands to generate.