]> git.pld-linux.org Git - packages/foobillard.git/blob - foobillard.spec
- BR: libpng-devel
[packages/foobillard.git] / foobillard.spec
1 #
2 # Conditional build:
3 %bcond_with     glut    # use glut instead of SDL
4 %bcond_with     nvidia  # enable NVidia specific extensions
5 #
6 Summary:        A free OpenGL game of playing billard
7 Summary(pl):    Wolnodostêpna gra w bilard oparta na OpenGL
8 Name:           foobillard
9 Version:        3.0a
10 Release:        1       
11 Vendor:         Florian Berger <florian.berger@aec.at>, <harpin_floh@yahoo.de>
12 License:        GPL
13 Group:          X11/Applications/Games
14 Source0:        http://foobillard.sunsite.dk/dnl/%{name}-%{version}.tar.gz
15 # Source0-md5:  c2d92edeaaf8bfb18aa26f1c79931b7d
16 Source1:        %{name}.desktop
17 Source2:        %{name}.xpm
18 URL:            http://foobillard.sunsite.dk/
19 BuildRequires:  OpenGL-devel
20 %{!?with_glut:BuildRequires:    SDL-devel}
21 %{?with_nvidia:BuildRequires:   X11-driver-nvidia-devel}
22 BuildRequires:  autoconf
23 BuildRequires:  automake
24 BuildRequires:  freetype-devel
25 %{?with_glut:BuildRequires:     glut-devel}
26 BuildRequires:  intltool
27 BuildRequires:  libpng-devel
28 BuildRequires:  libtool
29 Requires:       OpenGL
30 %{?with_nvidia:Requires:        X11-driver-nvidia}
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
34
35 %description
36 FooBillard is an attempt to create a free OpenGL-billard for Linux.
37 Why foo? Well, actually I had this logo (F.B.-Florian Berger) and then
38 foo sounds a bit like pool (Somehow I wasn't quite attracted by the
39 name FoolBillard). Actually FooBillard is still under development but
40 the main physics is implemented. If you are a billard-pro and you're
41 missing some physics, please tell me. Cause I've implemented it like I
42 think it should work, which might differ from reality.
43
44 %description -l pl
45 FooBillard to próba stworzenia wolnodostêpnego bilarda OpenGL dla
46 Linuksa. Dlaczego foo? Bo autor mia³ ju¿ to logo (F.B. - Florian
47 Berger) i "foo" brzmi trochê jak "pool" (a nazwa "FoolBillard" nie
48 brzmia³a zbyt przyci±gaj±co). FooBillard jest nadal w stadium rozwoju,
49 ale g³ówna fizyka jest ju¿ zaimplementowana. Je¿eli w grze brakuje
50 jakiej¶ fizyki, dobrze jest zg³osiæ to autorowi, poniewa¿ on
51 zaimplementowa³ j± tak, jak my¶la³, ¿e powinna dzia³aæ, co mo¿e siê
52 nieco ró¿niæ od rzeczywisto¶ci.
53
54 %prep
55 %setup -q
56
57 %build
58 rm -f missing
59 X_LIBS='-I/usr/X11R6/include'; export X_LIBS
60 %{__libtoolize}
61 %{__aclocal}
62 %{__autoconf}
63 %{__automake}
64 %configure \
65 %if %{with glut}
66         --enable-glut \
67         --disable-SDL \
68 %else
69         --disable-glut \
70         --enable-SDL \
71 %endif
72         --%{?with_nvidia:en}%{!?with_nvidia:dis}able-nvidia \
73         --enable-sound
74
75 %{__make}
76
77 %install
78 rm -rf $RPM_BUILD_ROOT
79 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
80
81 %{__make} install \
82         DESTDIR=$RPM_BUILD_ROOT
83
84 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
85 install %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}
86
87 %clean
88 rm -rf $RPM_BUILD_ROOT
89
90 %files
91 %defattr(644,root,root,755)
92 %doc AUTHORS NEWS README ChangeLog TODO README.FONTS foobillardrc.example
93 %attr(755,root,root) %{_bindir}/*
94 %{_datadir}/foobillard
95 %{_desktopdir}/%{name}.desktop
96 %{_pixmapsdir}/*
This page took 0.043526 seconds and 4 git commands to generate.