]> git.pld-linux.org Git - packages/foobillard.git/blob - foobillard.spec
- up to 3.0a
[packages/foobillard.git] / foobillard.spec
1 #
2 # Conditional build:
3 %bcond_with     glut    # use glut instead of SDL
4 %bcond_with     nvidia  # enable NVidia specific extensions
5 #
6 Summary:        A free OpenGL game of playing billard
7 Summary(pl):    Wolnodostêpna gra w bilard oparta na OpenGL
8 Name:           foobillard
9 Version:        3.0a
10 Release:        1       
11 Vendor:         Florian Berger <florian.berger@aec.at>, <harpin_floh@yahoo.de>
12 License:        GPL
13 Group:          X11/Applications/Games
14 Source0:        http://foobillard.sunsite.dk/dnl/%{name}-%{version}.tar.gz
15 # Source0-md5:  c2d92edeaaf8bfb18aa26f1c79931b7d
16 Source1:        %{name}.desktop
17 Source2:        %{name}.xpm
18 URL:            http://foobillard.sunsite.dk/
19 BuildRequires:  OpenGL-devel
20 %{!?with_glut:BuildRequires:    SDL-devel}
21 %{?with_nvidia:BuildRequires:   XFree86-driver-nvidia}
22 BuildRequires:  autoconf
23 BuildRequires:  automake
24 BuildRequires:  freetype-devel
25 %{?with_glut:BuildRequires:     glut-devel}
26 BuildRequires:  intltool
27 BuildRequires:  libtool
28 Requires:       OpenGL
29 %{?with_nvidia:Requires:        XFree86-driver-nvidia}
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
33
34 %description
35 FooBillard is an attempt to create a free OpenGL-billard for Linux.
36 Why foo? Well, actually I had this logo (F.B.-Florian Berger) and then
37 foo sounds a bit like pool (Somehow I wasn't quite attracted by the
38 name FoolBillard). Actually FooBillard is still under development but
39 the main physics is implemented. If you are a billard-pro and you're
40 missing some physics, please tell me. Cause I've implemented it like I
41 think it should work, which might differ from reality.
42
43 %description -l pl
44 FooBillard to próba stworzenia wolnodostêpnego bilarda OpenGL dla
45 Linuksa. Dlaczego foo? Bo autor mia³ ju¿ to logo (F.B. - Florian
46 Berger) i "foo" brzmi trochê jak "pool" (a nazwa "FoolBillard" nie
47 brzmia³a zbyt przyci±gaj±co). FooBillard jest nadal w stadium rozwoju,
48 ale g³ówna fizyka jest ju¿ zaimplementowana. Je¿eli w grze brakuje
49 jakiej¶ fizyki, dobrze jest zg³osiæ to autorowi, poniewa¿ on
50 zaimplementowa³ j± tak, jak my¶la³, ¿e powinna dzia³aæ, co mo¿e siê
51 nieco ró¿niæ od rzeczywisto¶ci.
52
53 %prep
54 %setup -q
55
56 %build
57 rm -f missing
58 X_LIBS='-I/usr/X11R6/include'; export X_LIBS
59 %{__libtoolize}
60 %{__aclocal}
61 %{__autoconf}
62 %{__automake}
63 %configure \
64         %{!?with_glut:--enable-SDL}%{?with_glut:--enable-glut} \
65         %{!?with_nvidia:--disable-nvidia}%{?with_nvidia:--enable-nvidia}
66
67 %{__make}
68
69 %install
70 rm -rf $RPM_BUILD_ROOT
71 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
72
73 %{__make} install \
74         DESTDIR=$RPM_BUILD_ROOT
75
76 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
77 install %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}
78
79 %clean
80 rm -rf $RPM_BUILD_ROOT
81
82 %files
83 %defattr(644,root,root,755)
84 %doc AUTHORS NEWS README ChangeLog TODO README.FONTS foobillardrc.example
85 %attr(755,root,root) %{_bindir}/*
86 %{_datadir}/foobillard
87 %{_desktopdir}/%{name}.desktop
88 %{_pixmapsdir}/*
This page took 0.028887 seconds and 4 git commands to generate.