]> git.pld-linux.org Git - packages/folks.git/blob - folks.spec
- updated to 0.15.7
[packages/folks.git] / folks.spec
1 #
2 # Conditional build:
3 %bcond_with     apidocs         # API documentation (broken install: HTML for devhelp part, sources+HTML for gtk-doc?)
4 %bcond_without  vala            # Vala API
5 %bcond_without  bluez           # Bluez backend
6 %bcond_without  evolution       # EDS (Evolution Data Server) backend
7 %bcond_without  ofono           # oFono backend
8 %bcond_with     sysprof         # sysprof based profiling
9 %bcond_without  telepathy       # Telepathy backend
10 %bcond_without  zeitgeist       # ` Zeitgeist support in Telepathy backend
11
12 %if %{without telepathy}
13 %undefine       with_zeitgeist
14 %endif
15 Summary:        GObject contact aggregation library
16 Summary(pl.UTF-8):      Biblioteka GObject do agregowania kontaktów
17 Name:           folks
18 Version:        0.15.7
19 Release:        1
20 License:        LGPL v2.1+
21 Group:          Libraries
22 Source0:        https://download.gnome.org/sources/folks/0.15/%{name}-%{version}.tar.xz
23 # Source0-md5:  cd036d74e37aa6e215308db7f08e0223
24 Patch0:         %{name}-meson.patch
25 URL:            https://wiki.gnome.org/Projects/Folks
26 BuildRequires:  dbus-devel
27 %{?with_telepathy:BuildRequires:        dbus-glib-devel}
28 %if %{with bluez} || %{with evolution} || %{with ofono}
29 # libebook for all; libebook-contacts, libedataserver, evolution-data-server for evolution
30 BuildRequires:  evolution-data-server-devel >= 3.38
31 %endif
32 BuildRequires:  gettext-tools
33 BuildRequires:  glib2-devel >= 1:2.58
34 BuildRequires:  gobject-introspection-devel >= 1.30.0
35 BuildRequires:  libgee-devel >= 0.8.4
36 BuildRequires:  libxml2-devel >= 2.0
37 BuildRequires:  meson >= 0.57
38 BuildRequires:  ncurses-devel
39 BuildRequires:  ninja >= 1.5
40 BuildRequires:  pkgconfig >= 1:0.21
41 BuildRequires:  python3 >= 1:3.2
42 %{?with_bluez:BuildRequires:    python3-dbusmock}
43 BuildRequires:  rpm-build >= 4.6
44 BuildRequires:  rpmbuild(macros) >= 1.736
45 BuildRequires:  readline-devel
46 %{?with_sysprof:BuildRequires:  sysprof-devel >= 3.38.0}
47 BuildRequires:  tar >= 1:1.22
48 %{?with_telepathy:BuildRequires:        telepathy-glib-devel >= 0.19.9}
49 %if %{with vala}
50 BuildRequires:  vala >= 2:0.22.1
51 %if %{with bluez} || %{with evolution} || %{with ofono}
52 BuildRequires:  vala-evolution-data-server >= 3.38
53 %endif
54 BuildRequires:  vala-libgee >= 0.8.4
55 %{?with_telepathy:BuildRequires:        vala-telepathy-glib >= 0.19.9}
56 %{?with_zeitgeist:BuildRequires:        vala-zeitgeist >= 0.9.14}
57 %endif
58 %{?with_apidocs:BuildRequires:  valadoc >= 0.3.1}
59 BuildRequires:  xz
60 %{?with_zeitgeist:BuildRequires:        zeitgeist-devel >= 0.9.14}
61 %if %{with bluez} || %{with evolution} || %{with ofono}
62 Requires:       evolution-data-server-libs >= 3.38
63 %endif
64 Requires:       glib2 >= 1:2.58
65 Requires:       libgee >= 0.8.4
66 %{?with_telepathy:Requires:     telepathy-glib >= 0.19.9}
67 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
68
69 %define         abiver  26
70
71 %description
72 libfolks is a library that aggregates people from multiple sources
73 (e.g. Telepathy connection managers and eventually evolution data
74 server, Facebook, etc.) to create meta-contacts.
75
76 %description -l pl.UTF-8
77 libfolks to biblioteka gromadząca osoby z wielu źródeł (np. zarządców
78 połączeń Telepathy, serwera danych Evolution, Facebooka itp.), aby
79 utworzyć metakontakty.
80
81 %package devel
82 Summary:        Development files for folks libraries
83 Summary(pl.UTF-8):      Pliki programistyczne bibliotek folks
84 Group:          Development/Libraries
85 Requires:       %{name} = %{version}-%{release}
86 %if %{with bluez} || %{with evolution} || %{with ofono}
87 Requires:       evolution-data-server-devel >= 3.38
88 %endif
89 Requires:       glib2-devel >= 1:2.58
90 Requires:       libgee-devel >= 0.8.4
91 %{?with_telepathy:Requires:     telepathy-glib-devel >= 0.19.9}
92
93 %description devel
94 Development files for folks libraries.
95
96 %description devel -l pl.UTF-8
97 Pliki programistyczne bibliotek folks.
98
99 %package -n vala-folks
100 Summary:        folks API for Vala language
101 Summary(pl.UTF-8):      API folks dla języka Vala
102 Group:          Development/Libraries
103 Requires:       %{name}-devel = %{version}-%{release}
104 Requires:       vala >= 2:0.22.1
105 %if %{with bluez} || %{with evolution} || %{with ofono}
106 Requires:       vala-evolution-data-server >= 3.38
107 %endif
108 Requires:       vala-libgee >= 0.8.4
109 %{?with_telepathy:Requires:     vala-telepathy-glib >= 0.19.9}
110 BuildArch:      noarch
111
112 %description -n vala-folks
113 folks API for Vala language.
114
115 %description -n vala-folks -l pl.UTF-8
116 API folks dla języka Vala.
117
118 %prep
119 %setup -q
120 %patch0 -p1
121
122 %build
123 %meson build \
124         %{!?with_bluez:-Dbluez_backend=false} \
125         %{?with_apidocs:-Ddocs=true} \
126         %{!?with_evolution:-Deds_backend=false} \
127         %{!?with_ofono:-Dofono_backend=false} \
128         %{?with_sysprof:-Dprofiling=true} \
129         %{!?with_telepathy:-Dtelepathy_backend=false} \
130         %{?with_zeitgeist:-Dzeitgeist=true}
131
132 %ninja_build -C build
133
134 %install
135 rm -rf $RPM_BUILD_ROOT
136
137 %ninja_install -C build
138
139 # not supported by glibc (as of 2.37)
140 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/ie
141
142 %find_lang %{name}
143
144 %clean
145 rm -rf $RPM_BUILD_ROOT
146
147 %post   -p /sbin/ldconfig
148 %postun -p /sbin/ldconfig
149
150 %files -f %{name}.lang
151 %defattr(644,root,root,755)
152 %doc AUTHORS NEWS README.md
153 %attr(755,root,root) %{_bindir}/folks-import
154 %attr(755,root,root) %{_bindir}/folks-inspect
155 %attr(755,root,root) %{_libdir}/libfolks.so.*.*.*
156 %attr(755,root,root) %ghost %{_libdir}/libfolks.so.26
157 %attr(755,root,root) %{_libdir}/libfolks-dummy.so.*.*.*
158 %attr(755,root,root) %ghost %{_libdir}/libfolks-dummy.so.26
159 %{_libdir}/girepository-1.0/Folks-0.7.typelib
160 %{_libdir}/girepository-1.0/FolksDummy-0.7.typelib
161 %dir %{_libdir}/folks
162 %dir %{_libdir}/folks/%{abiver}
163 %dir %{_libdir}/folks/%{abiver}/backends
164 %dir %{_libdir}/folks/%{abiver}/backends/dummy
165 %attr(755,root,root) %{_libdir}/folks/%{abiver}/backends/dummy/dummy.so
166 %dir %{_libdir}/folks/%{abiver}/backends/key-file
167 %attr(755,root,root) %{_libdir}/folks/%{abiver}/backends/key-file/key-file.so
168 %if %{with bluez}
169 %dir %{_libdir}/folks/%{abiver}/backends/bluez
170 %attr(755,root,root) %{_libdir}/folks/%{abiver}/backends/bluez/bluez.so
171 %endif
172 %if %{with ofono}
173 %dir %{_libdir}/folks/%{abiver}/backends/ofono
174 %attr(755,root,root) %{_libdir}/folks/%{abiver}/backends/ofono/ofono.so
175 %endif
176 %if %{with evolution}
177 %attr(755,root,root) %{_libdir}/libfolks-eds.so.*.*.*
178 %attr(755,root,root) %ghost %{_libdir}/libfolks-eds.so.26
179 %{_libdir}/girepository-1.0/FolksEds-0.7.typelib
180 %dir %{_libdir}/folks/%{abiver}/backends/eds
181 %attr(755,root,root) %{_libdir}/folks/%{abiver}/backends/eds/eds.so
182 %endif
183 %if %{with telepathy}
184 %attr(755,root,root) %{_libdir}/libfolks-telepathy.so.*.*.*
185 %attr(755,root,root) %ghost %{_libdir}/libfolks-telepathy.so.26
186 %{_libdir}/girepository-1.0/FolksTelepathy-0.7.typelib
187 %dir %{_libdir}/folks/%{abiver}/backends/telepathy
188 %attr(755,root,root) %{_libdir}/folks/%{abiver}/backends/telepathy/telepathy.so
189 %endif
190 %{_datadir}/GConf/gsettings/folks.convert
191 %{_datadir}/glib-2.0/schemas/org.freedesktop.folks.gschema.xml
192
193 %files devel
194 %defattr(644,root,root,755)
195 %attr(755,root,root) %{_libdir}/libfolks.so
196 %attr(755,root,root) %{_libdir}/libfolks-dummy.so
197 %{_datadir}/gir-1.0/Folks-0.7.gir
198 %{_datadir}/gir-1.0/FolksDummy-0.7.gir
199 %{_includedir}/folks
200 %{_pkgconfigdir}/folks.pc
201 %{_pkgconfigdir}/folks-dummy.pc
202 %if %{with evolution}
203 %attr(755,root,root) %{_libdir}/libfolks-eds.so
204 %{_datadir}/gir-1.0/FolksEds-0.7.gir
205 %{_pkgconfigdir}/folks-eds.pc
206 %endif
207 %if %{with telepathy}
208 %attr(755,root,root) %{_libdir}/libfolks-telepathy.so
209 %{_datadir}/gir-1.0/FolksTelepathy-0.7.gir
210 %{_pkgconfigdir}/folks-telepathy.pc
211 %endif
212
213 %if %{with vala}
214 %files -n vala-folks
215 %defattr(644,root,root,755)
216 %{_datadir}/vala/vapi/folks.deps
217 %{_datadir}/vala/vapi/folks.vapi
218 %{_datadir}/vala/vapi/folks-dummy.deps
219 %{_datadir}/vala/vapi/folks-dummy.vapi
220 %if %{with evolution}
221 %{_datadir}/vala/vapi/folks-eds.deps
222 %{_datadir}/vala/vapi/folks-eds.vapi
223 %endif
224 %if %{with telepathy}
225 %{_datadir}/vala/vapi/folks-telepathy.deps
226 %{_datadir}/vala/vapi/folks-telepathy.vapi
227 %endif
228 %endif
This page took 0.092166 seconds and 3 git commands to generate.