]> git.pld-linux.org Git - packages/fluidsynth.git/blob - fluidsynth.spec
- updated to 2.3.4
[packages/fluidsynth.git] / fluidsynth.spec
1 #
2 # Conditional build:
3 %bcond_without  lash            # LASH support (GPL)
4 %bcond_with     midishare       # MidiShare support
5 %bcond_without  pipewire        # pipewire support
6 %bcond_without  portaudio       # portaudio support
7 %bcond_without  readline        # readline line editing (GPL)
8 %bcond_without  systemd         # systemd notify support
9 #
10 Summary:        FluidSynth - a software, real-time synthesizer
11 Summary(pl.UTF-8):      FluidSynth - programowy syntezator działający w czasie rzeczywistym
12 Name:           fluidsynth
13 Version:        2.3.4
14 Release:        1
15 %if %{with lash} || %{with readline}
16 License:        GPL v2+ (enforced by lash/readline), LGPL v2+ (fluidsynth itself)
17 %else
18 License:        LGPL v2+
19 %endif
20 Group:          Applications/Sound
21 #Source0Download: https://github.com/FluidSynth/fluidsynth/releases
22 Source0:        https://github.com/FluidSynth/fluidsynth/archive/v%{version}/%{name}-%{version}.tar.gz
23 # Source0-md5:  9e6f11b3a0b9981273e4d1fdadcd9533
24 URL:            https://www.fluidsynth.org/
25 BuildRequires:  SDL2-devel >= 2
26 BuildRequires:  alsa-lib-devel >= 0.9.1
27 BuildRequires:  cmake >= 3.13
28 BuildRequires:  dbus-devel >= 1.0.0
29 BuildRequires:  gettext-tools
30 BuildRequires:  glib2-devel >= 1:2.26.0
31 BuildRequires:  jack-audio-connection-kit-devel
32 BuildRequires:  ladspa-devel
33 %{?with_lash:BuildRequires:     lash-devel >= 0.3}
34 # OpenMP 4.0
35 BuildRequires:  libgomp-devel >= 6:4.9
36 BuildRequires:  libinstpatch-devel >= 1.1.0
37 BuildRequires:  libsndfile-devel >= 1.0.18
38 %{?with_midishare:BuildRequires:        midishare-devel}
39 BuildRequires:  pkgconfig
40 %{?with_pipewire:BuildRequires: pipewire-devel >= 0.3}
41 %{?with_portaudio:BuildRequires:        portaudio-devel >= 19}
42 BuildRequires:  pulseaudio-devel >= 0.9.8
43 %{?with_readline:BuildRequires: readline-devel}
44 BuildRequires:  rpmbuild(macros) >= 1.213
45 %{?with_systemd:BuildRequires:  systemd-devel >= 1:209}
46 Requires:       alsa-lib >= 0.9.1
47 Requires:       glib2 >= 1:2.26.0
48 Requires:       libsndfile >= 1.0.18
49 Suggests:       soundfont-fluid
50 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
51
52 %description
53 Fluid Synth is a software, real-time synthesizer based on the
54 Soundfont 2 specifications.
55
56 %description -l pl.UTF-8
57 Fluid Synth to programowy, działający w czasie rzeczywistym syntezator
58 oparty na specyfikacji Soundfont 2.
59
60 %package devel
61 Summary:        Development files for the FluidSynth
62 Summary(pl.UTF-8):      Pliki nagłówkowe dla FluidSynth
63 Group:          Development/Libraries
64 Requires:       %{name} = %{version}-%{release}
65 Requires:       alsa-lib-devel >= 0.9.1
66 Requires:       dbus-devel >= 1.0.0
67 Requires:       glib2-devel >= 1:2.26.0
68 Requires:       jack-audio-connection-kit-devel
69 %{?with_lash:Requires:  lash-devel >= 0.3}
70 Requires:       libsndfile-devel >= 1.0.18
71 %{?with_midishare:Requires: midishare-devel}
72 %{?with_pipewire:Requires:      pipewire-devel >= 0.3}
73 %{?with_portaudio:Requires:     portaudio-devel >= 19}
74 Requires:       pulseaudio-devel >= 0.9.8
75 %{?with_readline:Requires: readline-devel}
76 Obsoletes:      fluidsynth-static < 2
77
78 %description devel
79 This package contains the header files necessary to develop
80 applications using FluidSynth.
81
82 %description devel -l pl.UTF-8
83 Pakiet ten zawiera pliki nagłówkowe potrzebne do tworzenia i
84 kompilacji aplikacji korzystających z bibliotek FluidSynth.
85
86 %prep
87 %setup -q
88
89 %build
90 %cmake -B build \
91         -Denable-midishare=%{with midishare} \
92         -Denable-lash=%{with lash} \
93         %{!?with_pipewire:-Denable-pipewire=OFF} \
94         -Denable-portaudio=%{with portaudio} \
95         -Denable-readline=%{with readline} \
96         %{!?with_systemd:-Denable-systemd=OFF}
97
98 %{__make} -C build
99
100 %install
101 rm -rf $RPM_BUILD_ROOT
102
103 %{__make} -C build install \
104         DESTDIR=$RPM_BUILD_ROOT
105
106 %clean
107 rm -rf $RPM_BUILD_ROOT
108
109 %post   -p /sbin/ldconfig
110 %postun -p /sbin/ldconfig
111
112 %files
113 %defattr(644,root,root,755)
114 %doc AUTHORS README.md THANKS TODO
115 %attr(755,root,root) %{_bindir}/fluidsynth
116 %attr(755,root,root) %{_libdir}/libfluidsynth.so.*.*.*
117 %attr(755,root,root) %ghost %{_libdir}/libfluidsynth.so.3
118 %{_mandir}/man1/fluidsynth.1*
119
120 %files devel
121 %defattr(644,root,root,755)
122 %attr(755,root,root) %{_libdir}/libfluidsynth.so
123 %{_includedir}/fluidsynth.h
124 %{_includedir}/fluidsynth
125 %{_pkgconfigdir}/fluidsynth.pc
126 %{_libdir}/cmake/fluidsynth
This page took 0.267631 seconds and 3 git commands to generate.