]> git.pld-linux.org Git - packages/flac.git/blob - flac.spec
- package CHANGELOG.md
[packages/flac.git] / flac.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4
5 Summary:        Free Lossless Audio Codec
6 Summary(pl.UTF-8):      Free Lossless Audio Codec - Wolnodostępny bezstratny kodek audio
7 Name:           flac
8 Version:        1.4.2
9 Release:        1
10 License:        BSD (libFLAC/libFLAC++), GPL v2+ (programs and plugins)
11 Group:          Libraries
12 Source0:        https://downloads.xiph.org/releases/flac/%{name}-%{version}.tar.xz
13 # Source0-md5:  ca9140f37b286d2571e37d66aae50f92
14 URL:            https://xiph.org/flac/
15 BuildRequires:  autoconf >= 2.60
16 BuildRequires:  automake >= 1:1.11
17 BuildRequires:  doxygen
18 # for AM_ICONV
19 BuildRequires:  gettext-tools
20 BuildRequires:  libogg-devel >= 2:1.0
21 BuildRequires:  libstdc++-devel
22 BuildRequires:  libtool >= 2:2
23 BuildRequires:  tar >= 1:1.22
24 BuildRequires:  xz
25 Obsoletes:      xmms-input-flac < 1.4.2
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 FLAC is an Open Source lossless audio codec developed by Josh Coalson.
30
31 %description -l pl.UTF-8
32 FLAC jest bezstratnym kodekiem audio z otwartymi źródłami, rozwijanym
33 przez Josha Coalsona.
34
35 %package devel
36 Summary:        FLAC - development files
37 Summary(pl.UTF-8):      FLAC - pliki nagłówkowe
38 License:        BSD
39 Group:          Development/Libraries
40 Requires:       %{name} = %{version}-%{release}
41 Requires:       libogg-devel >= 2:1.0
42
43 %description devel
44 The package contains the development header files for FLAC libraries.
45
46 %description devel -l pl.UTF-8
47 Ten pakiet zawiera pliki nagłówkowe bibliotek FLAC.
48
49 %package static
50 Summary:        FLAC - static libraries
51 Summary(pl.UTF-8):      FLAC - biblioteki statyczne
52 License:        BSD
53 Group:          Development/Libraries
54 Requires:       %{name}-devel = %{version}-%{release}
55
56 %description static
57 The package contains FLAC static libraries.
58
59 %description static -l pl.UTF-8
60 Ten pakiet zawiera biblioteki statyczne FLAC.
61
62 %package c++
63 Summary:        FLAC++ - C++ API for FLAC codec
64 Summary(pl.UTF-8):      FLAC++ - API C++ do kodeka FLAC
65 Group:          Libraries
66 Requires:       %{name} = %{version}-%{release}
67
68 %description c++
69 FLAC++ - C++ API for FLAC codec.
70
71 %description c++ -l pl.UTF-8
72 FLAC++ - API C++ do kodeka FLAC.
73
74 %package c++-devel
75 Summary:        Header files for FLAC++ library
76 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki FLAC++
77 Group:          Development/Libraries
78 Requires:       %{name}-c++ = %{version}-%{release}
79 Requires:       %{name}-devel = %{version}-%{release}
80 Requires:       libstdc++-devel
81
82 %description c++-devel
83 Header files for FLAC++ library.
84
85 %description c++-devel -l pl.UTF-8
86 Pliki nagłówkowe biblioteki FLAC++.
87
88 %package c++-static
89 Summary:        Static FLAC++ library
90 Summary(pl.UTF-8):      Statyczna biblioteka FLAC++
91 Group:          Development/Libraries
92 Requires:       %{name}-c++-devel = %{version}-%{release}
93
94 %description c++-static
95 Static FLAC++ library.
96
97 %description c++-static -l pl.UTF-8
98 Statyczna biblioteka FLAC++.
99
100 %prep
101 %setup -q
102
103 %{__rm} m4/ogg.m4
104
105 %build
106 %{__libtoolize}
107 %{__aclocal} -I m4
108 %{__autoconf}
109 %{__autoheader}
110 %{__automake}
111 %configure \
112         --disable-silent-rules \
113         %{?with_static_libs:--enable-static}
114
115 %{__make}
116
117 %install
118 rm -rf $RPM_BUILD_ROOT
119
120 %{__make} install \
121         DESTDIR=$RPM_BUILD_ROOT
122
123 # packaged as %doc in -devel
124 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}
125
126 %clean
127 rm -rf $RPM_BUILD_ROOT
128
129 %post   -p /sbin/ldconfig
130 %postun -p /sbin/ldconfig
131
132 %post   c++ -p /sbin/ldconfig
133 %postun c++ -p /sbin/ldconfig
134
135 %files
136 %defattr(644,root,root,755)
137 %doc AUTHORS CHANGELOG.md COPYING.Xiph README.md
138 %attr(755,root,root) %{_bindir}/flac
139 %attr(755,root,root) %{_bindir}/metaflac
140 %attr(755,root,root) %{_libdir}/libFLAC.so.*.*.*
141 %attr(755,root,root) %ghost %{_libdir}/libFLAC.so.12
142 %{_mandir}/man1/flac.1*
143 %{_mandir}/man1/metaflac.1*
144
145 %files devel
146 %defattr(644,root,root,755)
147 %doc doc/api/*.{html,png} doc/images/logo*.{gif,svg}
148 %attr(755,root,root) %{_libdir}/libFLAC.so
149 %{_libdir}/libFLAC.la
150 %{_includedir}/FLAC
151 %{_pkgconfigdir}/flac.pc
152 %{_aclocaldir}/libFLAC.m4
153
154 %if %{with static_libs}
155 %files static
156 %defattr(644,root,root,755)
157 %{_libdir}/libFLAC.a
158 %endif
159
160 %files c++
161 %defattr(644,root,root,755)
162 %attr(755,root,root) %{_libdir}/libFLAC++.so.*.*.*
163 %attr(755,root,root) %ghost %{_libdir}/libFLAC++.so.10
164
165 %files c++-devel
166 %defattr(644,root,root,755)
167 %attr(755,root,root) %{_libdir}/libFLAC++.so
168 %{_libdir}/libFLAC++.la
169 %{_includedir}/FLAC++
170 %{_pkgconfigdir}/flac++.pc
171 %{_aclocaldir}/libFLAC++.m4
172
173 %if %{with static_libs}
174 %files c++-static
175 %defattr(644,root,root,755)
176 %{_libdir}/libFLAC++.a
177 %endif
This page took 0.032485 seconds and 3 git commands to generate.