]> git.pld-linux.org Git - packages/firefox.git/blob - mozilla-firefox.spec
- missing defattr; still broken
[packages/firefox.git] / mozilla-firefox.spec
1 Summary:        Mozilla Firefox web browser
2 Summary(pl):    Mozilla Firefox - przegl±darka WWW
3 Name:           mozilla-firefox
4 Version:        0.8
5 Release:        1.1
6 License:        MPL/LGPL
7 Group:          X11/Applications/Networking
8 Source0:        http://ftp.mozilla.org/pub/mozilla.org/firefox/releases/%{version}/firefox-source-%{version}.tar.bz2
9 # Source0-md5:  cdc85152f4219bf3e3f1a8dc46e04654
10 Source1:        %{name}.desktop
11 Patch0:         %{name}-alpha-gcc3.patch
12 URL:            http://www.mozilla.org/projects/firefox/
13 BuildRequires:  gtk+2-devel >= 2.0.0
14 BuildRequires:  libIDL-devel >= 0.8.0
15 BuildRequires:  libjpeg-devel >= 6b
16 BuildRequires:  libpng-devel >= 1.2.0
17 BuildRequires:  libstdc++-devel
18 BuildRequires:  pango-devel >= 1.1.0
19 BuildRequires:  zip
20 Obsoletes:      mozilla-firebird
21 Requires:       %{name}-lang-resources
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %define _firefoxdir     %{_libdir}/%{name}
25
26 %description
27 Mozilla Firefox is an open-source web browser, designed for standards
28 compliance, performance and portability.
29
30 %description -l pl
31 Mozilla Firefox jest open sourcow± przegl±dark± sieci www, stworzon± z
32 my¶l± o zgodno¶ci ze standartami, wydajno¶ci± i przeno¶no¶ci±.
33
34 %package lang-en
35 Summary:        English resources for Mozilla-firefox
36 Summary(pl):    Anglojêzyczne zasoby dla Mozilla-FireFox
37 Group:  X11/Applications/Networking
38 Requires(post,postun):  mozilla-firefox >= %{version}-1.1
39 Requires(post,postun):  textutils
40 Requires:       mozilla-firefox >= %{version}-1.1
41 Provides:       %{name}-lang-resources
42 Obsoletes:      %{name}-lang-resources
43
44 %description lang-en
45 English resources for Mozilla-firefox
46
47 %description lang-en -l pl
48 Anglojêzyczne zasoby dla Mozilla-FireFox
49
50 %prep
51 %setup -q -n mozilla
52 %patch0 -p1
53
54 ### FIXME: Shouldn't the default firefox config be part of original source ?
55 cat <<EOF >.mozconfig
56 export MOZ_PHOENIX="1"
57 mk_add_options MOZ_PHOENIX="1"
58 ac_add_options --with-system-jpeg
59 ac_add_options --with-system-zlib
60 ac_add_options --with-system-png
61 ac_add_options --with-system-mng
62 ac_add_options --with-pthreads
63 ac_add_options --disable-tests
64 ac_add_options --disable-debug
65 ac_add_options --disable-debug-modules
66 ac_add_options --disable-xprint
67 ac_add_options --disable-mailnews
68 ac_add_options --disable-composer
69 ac_add_options --disable-ldap
70 ac_add_options --disable-jsd
71 ac_add_options --disable-dtd-debug
72 ac_add_options --disable-gtktest
73 ac_add_options --disable-freetypetest
74 ac_add_options --disable-installer
75 ac_add_options --enable-plaintext-editor-only
76 ac_add_options --enable-optimize="%{optflags}"
77 ac_add_options --enable-crypto
78 ac_add_options --enable-strip
79 ac_add_options --enable-strip-libs
80 ac_add_options --enable-reorder
81 ac_add_options --enable-mathml
82 ac_add_options --enable-xinerama
83 ac_add_options --enable-extensions="pref,cookie,wallet"
84 ac_add_options --enable-freetype2
85 ac_add_options --enable-xft
86 ac_add_options --enable-default-toolkit="gtk2"
87 EOF
88
89 %build
90 #export MOZ_PHOENIX="1"
91 #configure
92 #{__make} %{?_smp_mflags}
93
94 export CFLAGS="%{optflags}"
95 export CXXFLAGS="%{optflags}"
96 export MOZ_PHOENIX="1"
97
98 %{__make} -f client.mk build
99
100 %install
101 rm -rf $RPM_BUILD_ROOT
102 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir},%{_pixmapsdir},%{_desktopdir}}
103
104 %{__make} -C xpinstall/packager \
105         MOZ_PKG_APPNAME="mozilla-firefox" \
106         MOZILLA_BIN="\$(DIST)/bin/firefox-bin"
107
108 #install -m0755 %{name}.sh $RPM_BUILD_ROOT%{_bindir}/mozilla-firefox
109 ln -sf %{_firefoxdir}/firefox $RPM_BUILD_ROOT%{_bindir}/mozilla-firefox
110
111 tar -xvz -C $RPM_BUILD_ROOT%{_libdir} -f dist/mozilla-firefox-*-linux-gnu.tar.gz
112
113 install browser/base/skin/Throbber.png $RPM_BUILD_ROOT%{_pixmapsdir}/mozilla-firefox.png
114 #install -m0644 bookmarks.html $RPM_BUILD_ROOT%{_firefoxdir}/defaults/profile/
115 #install -m0644 bookmarks.html $RPM_BUILD_ROOT%{_firefoxdir}/defaults/profile/US/
116
117 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
118
119 grep locale $RPM_BUILD_ROOT%{_firefoxdir}/chrome/installed-chrome.txt > $RPM_BUILD_ROOT%{_firefoxdir}/chrome/%{name}-en-US-installed-chrome.txt
120 grep -v locale $RPM_BUILD_ROOT%{_firefoxdir}/chrome/installed-chrome.txt > $RPM_BUILD_ROOT%{_firefoxdir}/chrome/%{name}-misc-installed-chrome.txt
121
122 rm -rf US classic comm embed-sample en-{US,mac,unix,win} modern pipnss pippki toolkit
123 rm -f en-win.jar en-mac.jar embed-sample.jar modern.jar
124
125 %clean
126 rm -rf $RPM_BUILD_ROOT
127
128 %post lang-en
129 umask 022
130 cd %{_firefoxdir}/chrome
131 cat *-installed-chrome.txt >installed-chrome.txt
132
133 %postun lang-en
134 umask 022
135 cd %{_firefoxdir}/chrome
136 cat *-installed-chrome.txt >installed-chrome.txt
137
138 %files
139 %defattr(644,root,root,755)
140 %attr(755,root,root) %{_bindir}/*
141 %dir %{_firefoxdir}
142 %{_firefoxdir}/res
143 %{_firefoxdir}/components
144 %{_firefoxdir}/plugins
145 %{_firefoxdir}/searchplugins
146 %{_firefoxdir}/icons
147 %{_firefoxdir}/defaults
148 %{_firefoxdir}/ipc
149 %attr(755,root,root) %{_firefoxdir}/*.so
150 %attr(755,root,root) %{_firefoxdir}/*.sh
151 %attr(755,root,root) %{_firefoxdir}/m*
152 %attr(755,root,root) %{_firefoxdir}/f*
153 %attr(755,root,root) %{_firefoxdir}/reg*
154 %attr(755,root,root) %{_firefoxdir}/x*
155 %attr(755,root,root) %{_firefoxdir}/T*
156 %ifarch %{ix86}
157 %attr(755,root,root) %{_firefoxdir}/elf-dynstr-gc
158 %endif
159 %attr(755,root,root) %{_firefoxdir}/libsoftokn3.chk
160 %attr(755,root,root) %{_firefoxdir}/shlibsign
161 %{_firefoxdir}/bloaturls.txt
162 %{_pixmapsdir}/*
163 %{_desktopdir}/*
164
165 %dir %{_firefoxdir}/chrome
166 %{_firefoxdir}/chrome/browser.jar
167 %{_firefoxdir}/chrome/classic.jar
168 %{_firefoxdir}/chrome/comm.jar
169 %{_firefoxdir}/chrome/pip*.jar
170 %{_firefoxdir}/chrome/toolkit.jar
171 %{_firefoxdir}/chrome/mozilla-firefox-misc-installed-chrome.txt
172
173 %files lang-en
174 %defattr(644,root,root,755)
175 %{_firefoxdir}/chrome/en-US.jar
176 %{_firefoxdir}/chrome/en-unix.jar
177 %{_firefoxdir}/chrome/US.jar
178 %{_firefoxdir}/chrome/mozilla-firefox-en-US-installed-chrome.txt
This page took 0.062634 seconds and 4 git commands to generate.