]> git.pld-linux.org Git - packages/findutils.git/blob - findutils.spec
rebuild with separate debuginfo build-ids
[packages/findutils.git] / findutils.spec
1 #
2 # Conditional build:
3 %bcond_without  selinux         # SELinux support
4 %bcond_without  tests           # unit tests
5 #
6 Summary:        GNU Find Utilities (find, xargs)
7 Summary(de.UTF-8):      GNU-Suchprogramme (find, xargs)
8 Summary(es.UTF-8):      Utilitarios de búsqueda de la GNU
9 Summary(fr.UTF-8):      Utilitaires de recherche de GNU (find, xargs)
10 Summary(pl.UTF-8):      Narzędzia GNU do odnajdywania plików (find, xargs)
11 Summary(pt_BR.UTF-8):   Utilitários de procura da GNU
12 Summary(tr.UTF-8):      GNU dosya arama araçları
13 Name:           findutils
14 Version:        4.8.0
15 Release:        2
16 Epoch:          1
17 License:        GPL v3+
18 Group:          Applications/File
19 # development versions at ftp://alpha.gnu.org/gnu/findutils/
20 Source0:        https://ftp.gnu.org/gnu/findutils/%{name}-%{version}.tar.xz
21 # Source0-md5:  eeefe2e6380931a77dfa6d9350b43186
22 #Source1:       http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
23 Source1:        %{name}-non-english-man-pages.tar.bz2
24 # Source1-md5:  e76388b0c3218eec3557d05ccd6d6515
25 Patch0:         %{name}-man-selinux.patch
26 Patch1:         %{name}-info.patch
27 # (will be again after tp update) http://translationproject.org/latest/findutils/pl.po
28 Patch2:         %{name}-pl.po-update.patch
29 URL:            http://www.gnu.org/software/findutils/
30 BuildRequires:  autoconf >= 2.69
31 BuildRequires:  automake >= 1:1.11
32 BuildRequires:  gettext-tools >= 0.19.3
33 %{?with_selinux:BuildRequires:  libselinux-devel}
34 BuildRequires:  tar >= 1:1.22
35 BuildRequires:  texinfo
36 BuildRequires:  xz
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 %description
40 The findutils package contains programs which will help you locate
41 files on your system. The find utility searches through a hierarchy of
42 directories looking for files which match a certain set of criteria
43 (such as a filename pattern). The locate utility searches a database
44 (create by updatedb) to quickly find a file matching a given pattern.
45 The xargs utility builds and executes command lines from standard
46 input arguments (usually lists of file names generated by the find
47 command).
48
49 %description -l de.UTF-8
50 Das findutils-Paket enthält Programme, die dabei helfen, Dateien auf
51 Ihrem System zu finden. Das Find-Utility durchsucht die
52 Verzeichnishierarchie nach Dateien, die zu bestimmten Kriterien (z.B.
53 Dateiname) passen. Das locate-Utility durchsucht eine Datenbank
54 (erzeugt durch updatedb), um die Dateien schneller finden zu können.
55 xargs konstruiert Kommandozeilen von der Standardeingabe (z.B.
56 Dateilisten, die von find erzeugt werden), und führt sie aus.
57
58 %description -l es.UTF-8
59 Este paquete contiene programas para ayúdalo a localizar archivos en
60 tu sistema. El programa find puede pesquisar, a través de una
61 jerarquía de directorios, buscando por archivos que obedezcan a un
62 cierto conjunto de criterios (como nombre de archivo modelo).
63
64 %description -l fr.UTF-8
65 Ce package contient des programmes pour vous aider à localiser des
66 fichiers sur votre système. Le programme find peut rechercher à
67 travers une hiérarchie de répertoires des fichiers conformes à
68 certains critères (comme un type de nom).
69
70 %description -l pl.UTF-8
71 W pakiecie znajdują się narzędzia pozwalające na poszukiwanie
72 określonych plików. Program find służy do poszukiwania w drzewie
73 katalogów plików o określonych parametrach, jak nazwa, uprawnienia,
74 typ czy data ostatniej modyfikacji.
75
76 %description -l pt_BR.UTF-8
77 Esse pacote contém programas para ajudá-lo a localizar arquivos em seu
78 sistema. O programa find pode procurar através de uma hierarquia de
79 diretórios procurando por arquivos que obedeçam um certo conjunto de
80 critérios (como nome de arquivo modelo).
81
82 %description -l tr.UTF-8
83 Bu pakette yer alan yazılımlar sisteminizde yer alan dosyaları
84 bulabilmeniz için hazırlanmışlardır. find programı ile belirli
85 özellikleri olan bir yazılımı bir dizin hiyerarşisi altında
86 arayabilirsiniz.
87
88 %prep
89 %setup -q
90 # patch0 is applied in install stage
91 %patch1 -p1
92 %patch2 -p1
93
94 %{__rm} po/stamp-po
95
96 %build
97 %{__aclocal} -I gl/m4 -I m4
98 %{__autoconf}
99 %{__autoheader}
100 %{__automake}
101 %configure \
102         --disable-silent-rules \
103         %{__with_without selinux}
104
105 %{__make}
106
107 %if %{with tests}
108 # tests use bashish $'\n' substitution
109 %{__make} check \
110         SHELL=/bin/bash
111 %endif
112
113 %install
114 rm -rf $RPM_BUILD_ROOT
115
116 %{__make} install \
117         DESTDIR=$RPM_BUILD_ROOT
118
119 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
120 %{?with_selinux:patch -p0 -d $RPM_BUILD_ROOT%{_mandir} < %{PATCH0}}
121
122 # xargs is wanted in /bin
123 install -d $RPM_BUILD_ROOT/bin
124 %{__mv} $RPM_BUILD_ROOT%{_bindir}/xargs $RPM_BUILD_ROOT/bin
125
126 # useless in binary package
127 %{__rm} $RPM_BUILD_ROOT%{_infodir}/find-maint.info*
128
129 # unpackaged locate
130 %{__rm} $RPM_BUILD_ROOT%{_bindir}/{locate,updatedb} \
131         $RPM_BUILD_ROOT%{_libexecdir}/frcode \
132         $RPM_BUILD_ROOT%{_mandir}/{,*/}man?/{locate.1,updatedb.1,locatedb.5}*
133
134 %{__rm} $RPM_BUILD_ROOT%{_mandir}/README.findutils-non-english-man-pages
135 rm -f $RPM_BUILD_ROOT%{_infodir}/dir
136
137 %find_lang %{name}
138
139 %clean
140 rm -rf $RPM_BUILD_ROOT
141
142 %post   -p /sbin/postshell
143 -/usr/sbin/fix-info-dir -c %{_infodir}
144
145 %postun -p /sbin/postshell
146 -/usr/sbin/fix-info-dir -c %{_infodir}
147
148 %files -f %{name}.lang
149 %defattr(644,root,root,755)
150 %doc NEWS README TODO ChangeLog
151 %attr(755,root,root) %{_bindir}/find
152 %attr(755,root,root) /bin/xargs
153 %{_mandir}/man1/find.1*
154 %{_mandir}/man1/xargs.1*
155 %lang(de) %{_mandir}/de/man1/[fx]*
156 %lang(es) %{_mandir}/es/man1/[fx]*
157 %lang(fi) %{_mandir}/fi/man1/[fx]*
158 %lang(fr) %{_mandir}/fr/man1/[fx]*
159 %lang(hu) %{_mandir}/hu/man1/[fx]*
160 %lang(it) %{_mandir}/it/man1/[fx]*
161 %lang(ja) %{_mandir}/ja/man1/[fx]*
162 %lang(nl) %{_mandir}/nl/man1/[fx]*
163 %lang(pl) %{_mandir}/pl/man1/[fx]*
164 %lang(zh_CN) %{_mandir}/zh_CN/man1/[fx]*
165 %{_infodir}/find.info*
This page took 0.310497 seconds and 4 git commands to generate.