]> git.pld-linux.org Git - packages/feh.git/blob - feh.spec
install bash completion file to %{bash_compdir}
[packages/feh.git] / feh.spec
1 Summary:        Fast image viewer/indexer/montager
2 Summary(hu.UTF-8):      Gyors képnézegető/indexelő/montázsoló
3 Summary(pl.UTF-8):      Szybki program do przeglądania/indeksowania/montowania obrazów
4 Name:           feh
5 Version:        3.10.1
6 Release:        1
7 License:        BSD
8 Group:          X11/Applications/Graphics
9 Source0:        https://feh.finalrewind.org/%{name}-%{version}.tar.bz2
10 # Source0-md5:  08446a75833a0bcb09a36e9a4c7e64df
11 URL:            https://feh.finalrewind.org/
12 # Bash completion by https://github.com/scop/bash-completion/blob/master/completions/feh
13 Source1:        %{name}-bash-completion
14 # zsh completion by https://git.finalrewind.org/zsh/plain/etc/completions/_feh
15 Source2:        %{name}-zsh-completion
16 BuildRequires:  curl-devel
17 BuildRequires:  imlib2-devel >= 1.0.0
18 BuildRequires:  libexif-devel
19 BuildRequires:  libjpeg-devel
20 BuildRequires:  libmagic-devel
21 BuildRequires:  libpng-devel
22 BuildRequires:  sed >= 4.0
23 BuildRequires:  xorg-lib-libX11-devel
24 BuildRequires:  xorg-lib-libXinerama-devel
25 BuildRequires:  xorg-lib-libXt-devel
26 Requires:       ImageMagick
27 Requires:       imlib2_loaders
28 Provides:       WallpaperChanger
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 feh is a fast, lightweight image viewer which uses imlib2. It is
33 commandline-driven and supports multiple images through slideshows,
34 thumbnail browsing or multiple windows, and montages or index prints
35 (using truetype fonts to display file info). Advanced features include
36 fast dynamic zooming, progressive loading, loading via HTTP (with
37 reload support for watching webcams), recursive file opening
38 (slideshow of a directory hierarchy), and mousewheel/keyboard control.
39
40 %description -l hu.UTF-8
41 feh egy gyors, könnyűsúlyú képnézegető, amely az imlib2-t használja.
42 Parancssor-orientált és lehetséges több képet is nézni vetítés,
43 bélyegkép böngészés vagy több ablakban. További lehetőségek (többek
44 között): gyors dinamikus zoom, progresszív betöltés, HTTP protokoll
45 (webcam), rekurzív fájl megnyitás (könyvtár-szerkezetben diavetítés)
46 és egér-götgetés/billentyűzettel irányítás.
47
48 %description -l pl.UTF-8
49 feh jest szybką, lekką przeglądarką obrazów która wykorzystuje
50 bibliotekę imlib2. Jest kierowana z linii poleceń i obsługuje wiele
51 obrazów naraz przez "pokazy slajdów", przeglądanie miniatur lub wiele
52 okienek na raz, oraz montowanie obrazów lub tworzenie indeksów
53 (wykorzystując fonty TrueType do wyświetlania informacji o plikach).
54 Zaawansowane opcje zawierają szybie powiększanie, ładowanie stopniowe,
55 ładowanie przez HTTP (z opcją przeładowania do oglądania webcamów),
56 rekursywne otwieranie plików (pokaz slajdów z hierarchii katalogów),
57 oraz sterowanie z klawiatury/myszki (też z kółkiem).
58
59 %package -n bash-completion-feh
60 Summary:        Bash completion for feh
61 Summary(pl.UTF-8):      Dopełnianie parametrów feh dla powłoki Bash
62 Group:          Applications/Shells
63 Requires:       bash-completion >= 1:2.0
64 Requires:       %{name} = %{version}-%{release}
65 Obsoletes:      feh-bash-completion
66 BuildArch:      noarch
67
68 %description -n bash-completion-feh
69 Bash completion for feh.
70
71 %description -n bash-completion-feh -l pl.UTF-8
72 Dopełnianie parametrów feh dla powłoki Bash.
73
74 %package -n zsh-completion-feh
75 Summary:        ZSH completion for feh
76 Summary(pl.UTF-8):      Dopełnianie parametrów feh dla powłoki ZSH
77 Group:          Applications/Shells
78 Requires:       %{name} = %{version}-%{release}
79 BuildArch:      noarch
80
81 %description -n zsh-completion-feh
82 ZSH completion for feh.
83
84 %description -n zsh-completion-feh -l pl.UTF-8
85 Dopełnianie parametrów feh dla powłoki ZSH.
86
87 %prep
88 %setup -q
89
90 %build
91 CFLAGS="%{rpmcflags} %{rpmcppflags}" \
92 LDFLAGS="%{rpmldflags}" \
93 %{__make} \
94         CC="%{__cc}" \
95         PREFIX=%{_prefix} \
96         exif=1 \
97         help=1 \
98         inotify=1 \
99         magic=1
100
101 %install
102 rm -rf $RPM_BUILD_ROOT
103 install -d $RPM_BUILD_ROOT{%{bash_compdir},%{zsh_compdir}}
104
105 %{__make} install \
106         DESTDIR=$RPM_BUILD_ROOT \
107         PREFIX=%{_prefix}
108
109 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{bash_compdir}/%{name}
110 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{zsh_compdir}/_%{name}
111
112 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}
113
114 %clean
115 rm -rf $RPM_BUILD_ROOT
116
117 %post
118 %update_icon_cache hicolor
119 %update_desktop_database
120
121 %postun
122 %update_icon_cache hicolor
123 %update_desktop_database
124
125 %files
126 %defattr(644,root,root,755)
127 %doc AUTHORS COPYING ChangeLog examples README.md TODO
128 %attr(755,root,root) %{_bindir}/*
129 %{_datadir}/feh
130 %{_mandir}/man1/*.1*
131 %{_desktopdir}/feh.desktop
132 %{_iconsdir}/hicolor/48x48/apps/feh.png
133 %{_iconsdir}/hicolor/scalable/apps/feh.svg
134
135 %files -n bash-completion-feh
136 %defattr(644,root,root,755)
137 %{bash_compdir}/%{name}
138
139 %files -n zsh-completion-feh
140 %defattr(644,root,root,755)
141 %{zsh_compdir}/_%{name}
This page took 0.07963 seconds and 3 git commands to generate.