]> git.pld-linux.org Git - packages/fbv.git/commitdiff
- update to 1.0b by Kamil Kosiński <paladine@palanthas.homelinux.org>
authorundefine <undefine@pld-linux.org>
Mon, 20 Sep 2004 15:08:38 +0000 (15:08 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    fbv-nocenter.patch -> 1.2
    fbv.spec -> 1.9

fbv-nocenter.patch
fbv.spec

index 77c67248ad2c2d77fb653cbb4e7ac86d11cec3ba..ec84e7f3ebc612aeb55118d7a1df285129c29a3f 100644 (file)
@@ -1,81 +1,90 @@
-diff -ruN fbv-0.99.orig/ChangeLog fbv-0.99/ChangeLog
---- fbv-0.99.orig/ChangeLog    Sun Aug 24 22:25:56 2003
-+++ fbv-0.99/ChangeLog Sun Oct 19 16:39:46 2003
+diff -u fbv-1.0b.oryg/ChangeLog fbv-1.0b/ChangeLog
+--- fbv-1.0b.oryg/ChangeLog    2004-09-20 15:55:18.256629728 +0200
++++ fbv-1.0b/ChangeLog 2004-09-20 16:32:28.095642672 +0200
 @@ -1,3 +1,6 @@
 +      2003-10-19      Pawe³ ¯urowski  pzurowski@post.pl
-+      * added --nocenter option: image won't be in center of the sceen. Usefull with -c and -i options. Based on contributed patch from fbgetty.
-+
++      * added --nocenter option: image won't be in center of the screen. Usefull with -c and -i options. Based on contributed patch from fbgetty
++      
  0.99    2003-08-24      Mateusz Golicz mtg@elsat.net.pl
        * fixes in transparent and interlaced GIF & PNG support
        * support for using the alpha channel
-Binary files fbv-0.99.orig/fbv and fbv-0.99/fbv differ
-diff -ruN fbv-0.99.orig/fbv.1 fbv-0.99/fbv.1
---- fbv-0.99.orig/fbv.1        Sun Aug 24 22:21:07 2003
-+++ fbv-0.99/fbv.1     Sun Oct 19 16:39:46 2003
-@@ -34,6 +34,9 @@
- .BR \fB--noinfo\fP , \fB-i\fP
- Do not show image information
+diff -u fbv-1.0b.oryg/fbv.1 fbv-1.0b/fbv.1
+--- fbv-1.0b.oryg/fbv.1        2004-09-20 15:55:18.255629880 +0200
++++ fbv-1.0b/fbv.1     2004-09-20 16:27:58.418639808 +0200
+@@ -28,6 +28,9 @@
+ .BR \fB--noclear\fP , \fB-c\fP        
+ Do not clear the screen before/after displaying image
  .TP
-+.BR \fB--nocenter\fP , \fB-i\fP
++.BR \fB--nocenter\fP , \fB-z\fP
 +Do not center image on the screen
 +.TP
- .BR \fB--stretch\fP , \fB-f\fP
- Strech (using simple resize) the image to fit onto screen if necessary
+ .BR \fB--unhide\fP , \fB-u\fP
+ Do not hide/show cursor before/after displaying image
  .TP
-diff -ruN fbv-0.99.orig/main.c fbv-0.99/main.c
---- fbv-0.99.orig/main.c       Sun Aug 24 22:26:57 2003
-+++ fbv-0.99/main.c    Sun Oct 19 16:43:24 2003
-@@ -38,7 +38,7 @@
- extern unsigned char * color_average_resize(unsigned char * orgin,int ox,int oy,int dx,int dy);
+diff -u fbv-1.0b.oryg/main.c fbv-1.0b/main.c
+--- fbv-1.0b.oryg/main.c       2004-09-20 15:55:18.257629576 +0200
++++ fbv-1.0b/main.c    2004-09-20 16:47:53.286992208 +0200
+@@ -38,7 +38,8 @@
+          opt_stretch = 0,
+          opt_delay = 0,
+          opt_enlarge = 0,
+-         opt_ignore_aspect = 0;
++         opt_ignore_aspect = 0,
++         opt_nocenter = 1;
  
  
--int clear=1,delay=0,hide=1,dispinfo=1,allowstrech=0,opt_alpha = 0;
-+int clear=1,delay=0,hide=1,dispinfo=1,cancenter=1,allowstrech=0,opt_alpha = 0;
  
- struct formathandler *fh_root=NULL;
-@@ -167,8 +167,8 @@
-               x=imx; y=imy;
-           }
-           
--          if(x<xs) xpos=(xs-x)/2; else xpos=0;
--          if(y<ys) ypos=(ys-y)/2; else ypos=0;
-+          if((x<xs) && cancenter) xpos=(xs-x)/2; else xpos=0;
-+          if((y<ys) && cancenter) ypos=(ys-y)/2; else ypos=0;
-           xdelta=0; ydelta=0;
-           xstep=min(max(x/20,1),xs);
-@@ -242,6 +242,7 @@
-              " --noclear      | -c : Do not clear the screen before/after displaying image\n"
-              " --unhide       | -u : Do not hide/show the cursor before/after displaying image\n"
-              " --noinfo       | -i : Supress image information\n"
-+             " --nocenter     | -e : Do not center image on the screen (usefull with -c and -i)\n"
-              " --stretch      | -f : Strech (using a simple resizing routine) the image to fit onto screen if necessary\n"
-              " --colorstretch | -k : Strech (using a 'color average' resizing routine) the image to fit onto screen if necessary\n"
-            " --delay  | -s <delay> slideshow, wait 'delay' tenths of a second before displaying each image\n\n"
-@@ -263,6 +264,7 @@
-     {"alpha",         no_argument,    0, 'a'},
-       {"unhide",      no_argument,    0, 'h'},
-       {"noinfo",      no_argument,    0, 'i'},
-+      {"nocenter",    no_argument,    0, 'e'},
-       {"stretch",     no_argument,    0, 'f'},
-       {"colorstrech", no_argument,    0, 'k'},
-       {"delay",       required_argument, 0, 's'},
-@@ -277,7 +279,7 @@
-     {
-       for(;;)
+@@ -308,12 +309,12 @@
+               }
+               if(refresh)
+               {
+-                      if(i.width < screen_width)
++                      if((i.width < screen_width) && opt_nocenter)
+                               x_offs = (screen_width - i.width) / 2;
+                       else
+                               x_offs = 0;
+                       
+-                      if(i.height < screen_height)
++                      if((i.height < screen_height) && opt_nocenter)
+                               y_offs = (screen_height - i.height) / 2;
+                       else
+                               y_offs = 0;
+@@ -443,8 +444,9 @@
+                  "Available options:\n"
+                  " --help        | -h : Show this help\n"
+                  " --alpha       | -a : Use the alpha channel (if applicable)\n"
+-                 " --dontclear   | -c : Do not clear the screen before and after displaying the image\n"
+-                 " --donthide    | -u : Do not hide the cursor before and after displaying the image\n"
++                 " --noclear     | -c : Do not clear the screen before and after displaying the image\n"
++                 " --unhide      | -u : Do not hide the cursor before and after displaying the image\n"
++                 " --nocenter    | -z : Do not center image on the screen (usefull with  -c and -i)\n"
+                  " --noinfo      | -i : Supress image information\n"
+                  " --stretch     | -f : Strech (using a simple resizing routine) the image to fit onto screen if necessary\n"
+                  " --colorstretch| -k : Strech (using a 'color average' resizing routine) the image to fit onto screen if necessary\n"
+@@ -484,6 +486,7 @@
+               {"noclear",     no_argument,    0, 'c'},
+               {"alpha",       no_argument,    0, 'a'},
+               {"unhide",      no_argument,    0, 'u'},
++              {"nocenter",    no_argument,    0, 'z'},
+               {"noinfo",      no_argument,    0, 'i'},
+               {"stretch",     no_argument,    0, 'f'},
+               {"colorstrech", no_argument,    0, 'k'},
+@@ -501,7 +504,7 @@
+               return(1);
+       }
+       
+-      while((c = getopt_long_only(argc, argv, "hcauifks:er", long_options, NULL)) != EOF)
++      while((c = getopt_long_only(argc, argv, "hcauifks:erz", long_options, NULL)) != EOF)
        {
--          opt=getopt_long_only(argc,argv,"achukfis:",long_options,NULL);
-+          opt=getopt_long_only(argc,argv,"achukfies:",long_options,NULL);
-           if(opt==EOF) break;
-           switch(opt)
-           {
-@@ -287,6 +289,7 @@
-               case 'u': hide=0; break;
-               case 'h': help(argv[0]); break;
-               case 'i': dispinfo=0; break;
-+              case 'e': cancenter=0; break;
-               case 'f': allowstrech=1; break;
-               case 'k': allowstrech=2; break;
-           }
-Binary files fbv-0.99.orig/main.o and fbv-0.99/main.o differ
+               switch(c)
+               {
+@@ -535,6 +538,9 @@
+                       case 'r':
+                               opt_ignore_aspect = 1;
+                               break;
++                      case 'z':
++                              opt_nocenter = 0;
++                              break;
+               }
+       }
+       
index 56e97f7ab35422220301e404f2a6c6db7db3acda..47ca992f5c55adbe8445025c3ea2011d6c4e4e61 100644 (file)
--- a/fbv.spec
+++ b/fbv.spec
@@ -1,14 +1,13 @@
 Summary:       FrameBuffer Viewer
 Summary(pl):   Przegl±darka obrazków dla framebuffera
 Name:          fbv
-Version:       0.99
-Release:       3
+Version:       1.0b
+Release:       1
 License:       GPL
 Group:         Applications/Graphics
 Source0:       http://s-tech.elsat.net.pl/fbv/%{name}-%{version}.tar.gz
-# Source0-md5: fd237cb79ab26d30a7f8bb526a78bd0a
-Patch0:                %{name}-libs.patch
-Patch1:                %{name}-nocenter.patch
+# Source0-md5: 3e466375b930ec22be44f1041e77b55d
+Patch0:                %{name}-nocenter.patch
 URL:           http://s-tech.elsat.net.pl/
 BuildRequires: libjpeg-devel
 BuildRequires: libpng-devel
@@ -26,7 +25,6 @@ Obs
 %prep
 %setup -q
 %patch0 -p1
-%patch1 -p1
 
 %build
 # it's not autoconf script
This page took 0.065995 seconds and 4 git commands to generate.