]> git.pld-linux.org Git - packages/evolution.git/blob - evolution.spec
- don't include sys/debugreg.h - it isn't neccessary and it breaks builing
[packages/evolution.git] / evolution.spec
1 #
2 # todo:
3 # - splitting mail, addressbook and calendar:
4 #   - etspec?
5 #   - ui?
6 #   - dependencies, i.e.: mail should require addressbook?
7 #
8 # Conditionals:
9 %bcond_without ldap     # build without ldap support
10
11 %define         mver            1.5
12 %define         subver  6
13
14 Summary:        The GNOME2 Email/Calendar/Addressbook Suite
15 Summary(pl):    Klient poczty dla GNOME2/Kalendarz/Ksi±¿ka Adresowa
16 Summary(pt_BR): Cliente de email integrado com calendário e catálogo de endereços
17 Summary(zh_CN): Evolution - GNOME2¸öÈ˺͹¤×÷×éÐÅÏ¢¹ÜÀí¹¤¾ß(°üÀ¨µç×ÓÓʼþ£¬ÈÕÀúºÍµØÖ·±¡)
18 Name:           evolution
19 Version:        %{mver}.%{subver}
20 Release:        2
21 License:        GPL
22 Group:          Applications/Mail
23 Source0:        http://ftp.gnome.org/pub/gnome/sources/%{name}/%{mver}/%{name}-%{version}.tar.bz2
24 # Source0-md5:  59bbcb9c9e90e3c2f978b94664498d73
25 Patch0:         %{name}-locale-names.patch
26 Patch1:         %{name}-nolibs.patch
27 Patch2:         %{name}-debugreg.patch
28 URL:            http://www.ximian.com/products/ximian_evolution/
29 BuildRequires:  GConf2-devel >= 2.6.0
30 BuildRequires:  ORBit2-devel >= 1:2.10.0
31 BuildRequires:  autoconf
32 BuildRequires:  automake
33 BuildRequires:  bison
34 BuildRequires:  evolution-data-server-devel >= 0.0.91
35 BuildRequires:  flex
36 BuildRequires:  freetype-devel >= 2.0.5
37 BuildRequires:  gal-devel >= 1:2.1.7
38 BuildRequires:  gettext-devel
39 BuildRequires:  gnome-common
40 BuildRequires:  gnome-pilot-devel >= 2.0.0
41 BuildRequires:  gnome-vfs2-devel >= 2.6.0
42 BuildRequires:  gtk-doc >= 1.1
43 BuildRequires:  gtkhtml-devel >= 3.1.11
44 BuildRequires:  intltool >= 0.30
45 BuildRequires:  libglade2-devel >= 1:2.3.6
46 BuildRequires:  libgnomeprintui-devel >= 2.6.0
47 BuildRequires:  libgnomeui-devel >= 2.6.0
48 BuildRequires:  libsoup-devel >= 2.1.9
49 BuildRequires:  libtool
50 BuildRequires:  libxml2
51 BuildRequires:  nspr-devel
52 BuildRequires:  nss-devel
53 %{?with_ldap:BuildRequires:     openldap-devel >= 2.0.0}
54 #BuildRequires: openssl-devel >= 0.9.7d
55 BuildRequires:  pilot-link-devel >= 0.11.4
56 BuildRequires:  pkgconfig
57 BuildRequires:  psmisc
58 BuildRequires:  python
59 BuildRequires:  scrollkeeper >= 0.1.4
60 BuildRequires:  which
61 Requires(post,postun):  /sbin/ldconfig
62 Requires(post,postun):  /usr/bin/scrollkeeper-update
63 Requires(post):         GConf2
64 Requires:       GConf2 >= 2.6.0
65 Requires:       bonobo-activation
66 Requires:       evolution-data-server >= 0.0.91
67 Requires:       gal >= 1:2.1.7
68 Requires:       gtkhtml >= 3.1.11
69 Requires:       libglade2 >= 1:2.3.6
70 Requires:       psmisc
71 Requires:       scrollkeeper >= 0.1.4
72 Obsoletes:      evolution2
73 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
74
75 %description
76 Evolution is the GNOME2 mailer, calendar, contact manager and
77 communications tool. The tools which make up Evolution will be tightly
78 integrated with one another and act as a seamless personal
79 information-management tool.
80
81 %description -l pl
82 Evolution to program pocztowy GNOME2, kalendarz, ksi±¿ka adresowa i
83 narzêdzie komunikacyjne.
84
85 %description -l pt_BR
86 Evolution é um cliente de email para o GNOME2 com calendário e outras
87 ferramentas interessantes.
88
89 %package devel
90 Summary:        Header files for evolution
91 Summary(pl):    Pliki nag³ówkowe i dokumentacja
92 Summary(pt_BR): Bibliotecas e arquivos de inclusão para desenvolvimento
93 Summary(zh_CN): Evolution×é¼þ¿ª·¢¿â
94 Group:          Development/Libraries
95 Requires:       %{name} = %{version}-%{release}
96 Requires:       cyrus-sasl-devel
97 Requires:       freetype-devel
98 Requires:       gal-devel >= 1:2.1.7
99 Requires:       gnome-vfs2-devel >= 2.6.0
100 Requires:       gtkhtml-devel >= 3.1.11
101 Requires:       libglade2-devel >= 1:2.3.6
102 Requires:       libgnomeprintui-devel >= 2.6.0
103 Requires:       libgnomeui-devel >= 2.6.0
104 Requires:       libsoup-devel >= 2.1.9
105 Requires:       nspr-devel
106 Requires:       nss-devel
107 %{?with_ldap:Requires:  openldap-devel >= 2.0.0}
108 #Requires:      openssl-devel >= 0.9.7c
109 Obsoletes:      evolution2-devel
110
111 %description devel
112 This package contains the files necessary to develop applications
113 using Evolution's libraries.
114
115 %description devel -l pl
116 Pakiet zawiera pliki potrzebne do rozwoju aplikacji u¿ywaj±cych
117 bibliotek programu Evolution.
118
119 %description devel -l pt_BR
120 Este pacote contém os arquivos necessários para desenvolvimento de
121 aplicações utilizando as bibliotecas do Evolution.
122
123 %package static
124 Summary:        Static libraries for evolution
125 Summary(pl):    Biblioteki statyczne dla evolution
126 Summary(pt_BR): Bibliotecas estáticas para desenvolvimento
127 Group:          Development/Libraries
128 Requires:       %{name}-devel = %{version}-%{release}
129 Obsoletes:      evolution2-static
130
131 %description static
132 This package contains static libraries for Evolution.
133
134 %description static -l pl
135 Pakiet zawiera statyczne biblioteki Evolution.
136
137 %description static -l pt_BR
138 Este pacote contém as bibliotecas estáticas para desenvolvimento de
139 aplicações.
140
141 %package mail
142 Summary:        Evolution mail component
143 Summary(pl):    Modu³ pocztowy Evolution
144 Group:          X11/Applications
145 # mail composer requires addressbook component
146 Requires:       %{name}-addressbook = %{version}-%{release}
147 Requires(post,postun):  /sbin/ldconfig
148 Requires(post):         GConf2
149
150 %description mail
151 Evolution mail.
152
153 %description mail -l pl
154 Modu³ pocztowy Evolution.
155
156 %package addressbook
157 Summary:        Evolution addressbook component
158 Summary(pl):    Modu³ ksi±¿ki adresowej Evolution
159 Group:          X11/Applications
160 Requires:       %{name} = %{version}-%{release}
161 Requires(post): /sbin/ldconfig
162 Requires(post):         GConf2
163
164 %description addressbook
165 Evolution addressbook.
166
167 %description addressbook -l pl
168 Ksi±¿ka adresowa Evolution.
169
170 %package calendar
171 Summary:        Evolution calendar and todo component
172 Summary(pl):    Modu³ kalendarza i listy zadañ Evolution
173 Group:          X11/Applications
174 Requires:       %{name} = %{version}-%{release}
175 Requires(post): /sbin/ldconfig
176 Requires(post):         GConf2
177
178 %description calendar
179 Evolution calendar and todo component.
180
181 %description calendar -l pl
182 Kalendarz i lista zadañ Evolution.
183
184 %package pilot
185 Summary:        Evolution conduits for gnome-pilot
186 Summary(pl):    Dodatki do wymiany danych z gnome-pilot
187 Group:          X11/Applications
188 Requires:       %{name} = %{version}-%{release}
189 Obsoletes:      evolution2-pilot
190
191 %description pilot
192 This package contains conduits needed by gnome-pilot to synchronize
193 your Palm with Evolution.
194
195 %description pilot -l pl
196 Ten pakiet zawiera dodatki do synchronizacji danych Evolution z
197 Palmem.
198
199 %prep
200 %setup -q
201 %patch0 -p1
202 %patch1 -p1
203 %patch2 -p1
204
205 mv po/{no,nb}.po
206
207 %build
208 glib-gettextize --copy --force
209 intltoolize --copy --force
210 %{__libtoolize}
211 %{__aclocal} -I %{_aclocaldir}/gnome2-macros
212 %{__autoheader}
213 %{__autoconf}
214 %{__automake}
215 %configure \
216         --enable-gtk-doc \
217         --enable-pilot-conduits=yes \
218         %{?with_ldap:--with-openldap=yes} \
219         %{!?with_ldap:--with-openldap=no} \
220         --without-static-ldap \
221         --enable-nntp=yes \
222         --enable-file-locking=fcntl \
223         --enable-dot-locking=no \
224         --with-nspr-includes="%{_includedir}/nspr" \
225         --with-nss-includes="%{_includedir}/nss" \
226         --with-nspr-libs="%{_libdir}" \
227         --with-nss-libs="%{_libdir}" \
228         --enable-ipv6=yes \
229         --with-html-dir=%{_gtkdocdir} \
230         --with-kde-applnk-path=no \
231         --disable-schemas-install \
232         --enable-static
233
234 # hack to rebuild *.c and *.h from *.idl (check if needed with new versions)
235 # (required if you use ORBit2-devel 2.7.2)
236 find -name \*.idl -exec touch {} \;
237
238 %{__make} \
239         GTKHTML_DATADIR=%{_datadir}/idl
240
241 %install
242 rm -rf $RPM_BUILD_ROOT
243
244 %{__make} install \
245         DESTDIR=$RPM_BUILD_ROOT \
246         KDE_APPLNK_DIR=%{_applnkdir}/Network/Mail \
247         omf_dest_dir=%{_omf_dest_dir}/%{name} \
248         GTKHTML_DATADIR=%{_datadir}/idl \
249         GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
250
251 # strip doesn't pass these files and they aren't necessary, so remove them
252 # probably this should be done differently, but I have no idea
253 rm -f $RPM_BUILD_ROOT%{_libdir}/evolution/%{mver}/*/*.a
254 rm -f $RPM_BUILD_ROOT%{_libdir}/evolution/%{mver}/libemiscwidgets.a
255 rm -f $RPM_BUILD_ROOT%{_libdir}/gnome-pilot/*/*.{a,la}
256
257 %find_lang %{name} --all-name --with-gnome
258
259 %clean
260 rm -rf $RPM_BUILD_ROOT
261
262 %post
263 /sbin/ldconfig
264 /usr/bin/scrollkeeper-update
265 %gconf_schema_install
266
267 %postun
268 /sbin/ldconfig
269 /usr/bin/scrollkeeper-update
270
271 %post mail
272 /sbin/ldconfig
273 %gconf_schema_install
274
275 %postun mail
276 /sbin/ldconfig
277
278 %post addressbook
279 /sbin/ldconfig
280 %gconf_schema_install
281
282 %postun addressbook -p /sbin/ldconfig
283
284 %post calendar
285 /sbin/ldconfig
286 %gconf_schema_install
287
288 %postun calendar -p /sbin/ldconfig
289
290 %files -f evolution.lang
291 %defattr(644,root,root,755)
292 %doc AUTHORS ChangeLog NEWS* README
293 %attr(755,root,root) %{_bindir}/*
294 %attr(755,root,root) %{_libdir}/evolution/%{mver}/libeconduit.so.*
295 %attr(755,root,root) %{_libdir}/evolution/%{mver}/libemiscwidgets.so.*
296 %attr(755,root,root) %{_libdir}/evolution/%{mver}/libeselectnames.so.*
297 %attr(755,root,root) %{_libdir}/evolution/%{mver}/libeshell.so.*
298 %attr(755,root,root) %{_libdir}/evolution/%{mver}/libeutil.so.*
299 %attr(755,root,root) %{_libdir}/evolution/%{mver}/libevolution-a11y.so.*
300 %attr(755,root,root) %{_libdir}/evolution/%{mver}/libevolution-importer.so.*
301 %attr(755,root,root) %{_libdir}/evolution/%{mver}/libevolution-widgets-a11y.so.*
302 %attr(755,root,root) %{_libdir}/evolution/%{mver}/evolution-alarm-notify
303 %attr(755,root,root) %{_libdir}/evolution/%{mver}/killev
304 # addressbook requires it:
305 %attr(755,root,root) %{_libdir}/evolution/%{mver}/libcamel*.so.*
306 %dir %{_libdir}/evolution
307 %dir %{_libdir}/evolution/%{mver}
308 %dir %{_libdir}/evolution/%{mver}/components
309 %{_libdir}/bonobo/servers/GNOME_Evolution_Shell_1.5.server
310 %dir %{_datadir}/idl/evolution-%{mver}
311 %dir %{_datadir}/evolution
312 %dir %{_datadir}/evolution/%{mver}
313 %dir %{_datadir}/evolution/%{mver}/views
314 %{_datadir}/evolution/%{mver}/*.xml
315 %dir %{_datadir}/evolution/%{mver}/default
316 %dir %{_datadir}/evolution/%{mver}/default/C
317 %{_datadir}/evolution/%{mver}/etspec
318 %{_datadir}/evolution/%{mver}/glade
319 %{_datadir}/evolution/%{mver}/help
320 %{_datadir}/evolution/%{mver}/images
321 %{_datadir}/evolution/%{mver}/ui
322 %{_datadir}/mime-info/*
323 %{_datadir}/idl/evolution-%{mver}/Evolution-Component.idl
324 %{_datadir}/idl/evolution-%{mver}/Evolution-ConfigControl.idl
325 %{_datadir}/idl/evolution-%{mver}/Evolution-Offline.idl
326 %{_datadir}/idl/evolution-%{mver}/Evolution-Shell.idl
327 %{_datadir}/idl/evolution-%{mver}/Evolution-Wizard.idl
328 %{_datadir}/idl/evolution-%{mver}/Evolution-common.idl
329 %{_datadir}/idl/evolution-%{mver}/Evolution.idl
330 %{_datadir}/idl/evolution-%{mver}/GNOME_Evolution_Importer.idl
331 %{_desktopdir}/*
332 %{_pixmapsdir}/*
333 %{_sysconfdir}/gconf/schemas/apps_evolution_shell-1.5.schemas
334 %{_omf_dest_dir}/%{name}
335
336 %files devel
337 %defattr(644,root,root,755)
338 %attr(755,root,root) %{_libdir}/evolution/%{mver}/*.so
339 %{_libdir}/evolution/%{mver}/*.la
340 %{_libdir}/evolution/*/*/*.la
341 %{_includedir}/*
342 %{_pkgconfigdir}/*
343
344 %files static
345 %defattr(644,root,root,755)
346 %{_libdir}/evolution/%{mver}/*.a
347
348 %files mail
349 %defattr(644,root,root,755)
350 %dir %{_libdir}/evolution/%{mver}/camel*
351 %dir %{_libdir}/evolution/%{mver}/evolution-calendar-importers
352 %attr(755,root,root) %{_libdir}/evolution/%{mver}/libevolution-mail-importers.so*
353 %attr(755,root,root) %{_libdir}/evolution/%{mver}/camel/*
354 %attr(755,root,root) %{_libdir}/evolution/%{mver}/components/libevolution-mail.so
355 %attr(755,root,root) %{_libdir}/evolution/%{mver}/camel-providers/*.so
356 %attr(755,root,root) %{_libdir}/evolution/%{mver}/evolution-calendar-importers/*.so
357 %{_libdir}/bonobo/servers/GNOME_Evolution_Mail_1.5.server
358 %{_libdir}/bonobo/servers/GNOME_Evolution_Mail_Importers_1.5.server
359 %{_libdir}/evolution/%{mver}/camel-providers/*.urls
360 %{_datadir}/evolution/%{mver}/views/mail*
361 %{_datadir}/evolution/%{mver}/default/C/mail
362 %{_datadir}/idl/evolution-%{mver}/Composer.idl
363 %{_datadir}/idl/evolution-%{mver}/Evolution-Composer.idl
364 %{_sysconfdir}/gconf/schemas/evolution-mail-1.5.schemas
365
366 %files addressbook
367 %defattr(644,root,root,755)
368 %dir %{_libdir}/evolution/%{mver}/evolution-addressbook-importers
369 %attr(755,root,root) %{_libdir}/evolution/%{mver}/components/libevolution-addressbook.so
370 %attr(755,root,root) %{_libdir}/evolution/%{mver}/libevolution-addressbook-a11y.so.*
371 %attr(755,root,root) %{_libdir}/evolution/%{mver}/evolution-addressbook-importers/lib*.so
372 %{_libdir}/bonobo/servers/GNOME_Evolution_Addressbook*
373 %{_datadir}/evolution/%{mver}/views/addressbook*
374 %{_datadir}/evolution/%{mver}/ecps
375 %{_datadir}/idl/evolution-%{mver}/Evolution-Addressbook-SelectNames.idl
376 %{_sysconfdir}/gconf/schemas/apps_evolution_addressbook-1.5.schemas
377
378 %files calendar
379 %defattr(644,root,root,755)
380 %attr(755,root,root) %{_libdir}/evolution/%{mver}/components/libevolution-calendar.so
381 %attr(755,root,root) %{_libdir}/evolution/%{mver}/libevolution-calendar-a11y.so.*
382 %{_libdir}/bonobo/servers/GNOME_Evolution_Calendar*
383 %{_datadir}/evolution/%{mver}/views/calendar*
384 %{_datadir}/evolution/%{mver}/views/tasks*
385 %{_datadir}/idl/evolution-%{mver}/evolution-calendar.idl
386 %{_sysconfdir}/gconf/schemas/apps_evolution_calendar-1.5.schemas
387
388 %files pilot
389 %defattr(644,root,root,755)
390 %attr(755,root,root) %{_libdir}/evolution/%{mver}/conduits/*
391 %{_datadir}/gnome-pilot/conduits/*
This page took 0.069542 seconds and 3 git commands to generate.