]> git.pld-linux.org Git - packages/evolution-data-server.git/blob - evolution-data-server.spec
- convert no_build_with_as_needed 1 to filterout_ld -Wl,--as-needed
[packages/evolution-data-server.git] / evolution-data-server.spec
1 #
2 # todo:
3 # - system libical
4 #
5 # Conditional build:
6 %bcond_without  kerberos5       # build without kerberos5 support
7 %bcond_without  ldap            # build without ldap support
8 #
9 %define         basever         1.8
10 %define         apiver          1.2
11 Summary:        Evolution data server
12 Summary(pl):    Serwer danych Evolution
13 Name:           evolution-data-server
14 Version:        1.7.90.1
15 Release:        1
16 License:        GPL
17 Group:          Libraries
18 Source0:        http://ftp.gnome.org/pub/gnome/sources/evolution-data-server/1.7/%{name}-%{version}.tar.bz2
19 # Source0-md5:  07fa3db5725d41093b22d4e90c2ced87
20 Patch0:         %{name}-workaround-cal-backend-leak.patch
21 Patch1:         %{name}-gcc4.patch
22 URL:            http://www.ximian.com/products/ximian_evolution/
23 BuildRequires:  ORBit2-devel >= 1:2.14.2
24 BuildRequires:  autoconf >= 2.52
25 BuildRequires:  automake
26 BuildRequires:  bison
27 BuildRequires:  db-devel
28 BuildRequires:  gnome-common >= 2.12.0
29 BuildRequires:  gnome-keyring-devel >= 0.5.1
30 %{?with_kerberos5:BuildRequires:        heimdal-devel >= 0.7}
31 BuildRequires:  intltool
32 BuildRequires:  libglade2-devel >= 1:2.6.0
33 BuildRequires:  libgnomeui-devel >= 2.15.90
34 BuildRequires:  libsoup-devel >= 2.2.96
35 BuildRequires:  libstdc++-devel
36 BuildRequires:  libtool
37 BuildRequires:  nspr-devel
38 BuildRequires:  nss-devel
39 %{?with_ldap:BuildRequires:     openldap-devel >= 2.3.0}
40 BuildRequires:  pkgconfig
41 BuildRequires:  rpmbuild(macros) >= 1.304
42 Requires(post,postun):  scrollkeeper
43 Requires:       %{name}-libs = %{version}-%{release}
44 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
45
46 %define         filterout_ld    (-Wl,)?--as-needed
47 %define         schemadir       /usr/share/openldap/schema
48
49 %description
50 The Evolution data server for the calendar and addressbook.
51
52 %description -l pl
53 Serwer danych Evolution dla kalendarza i ksi±¿ki adresowej.
54
55 %package -n openldap-schema-evolutionperson
56 Summary:        evolutionperson LDAP schema
57 Summary(pl):    Schemat LDAP evolutionperson
58 Group:          Networking/Daemons
59 Requires(post,postun):  sed >= 4.0
60 Requires:       openldap-servers
61
62 %description -n openldap-schema-evolutionperson
63 This package contains evolutionperson.schema for openldap server.
64
65 %description -n openldap-schema-evolutionperson -l pl
66 Ten pakiet zawiera evolutionperson.schema dla serwera openldap.
67
68 %package libs
69 Summary:        Evolution Data Server library
70 Summary(pl):    Biblioteka Evolution Data Server
71 Group:          Libraries
72 Requires:       libgnomeui >= 2.15.90
73 Requires:       libsoup >= 2.2.96
74
75 %description libs
76 This package contains Evolution Data Server library.
77
78 %description libs -l pl
79 Ten pakiet zawiera bibliotekê Evolution Data Server.
80
81 %package devel
82 Summary:        Evolution data server development files
83 Summary(pl):    Pliki programistyczne serwera danych evolution
84 Group:          Development/Libraries
85 Requires:       %{name}-libs = %{version}-%{release}
86 %{?with_kerberos5:Requires:     heimdal-devel >= 0.7}
87 # for all but libegroupwise
88 Requires:       GConf2-devel >= 2.14.0
89 Requires:       ORBit2-devel >= 1:2.14.2
90 Requires:       glib2-devel >= 1:2.12.1
91 Requires:       libgnomeui-devel >= 2.15.90
92 Requires:       libxml2-devel >= 1:2.6.26
93 # for libegroupwise
94 Requires:       libsoup-devel >= 2.2.96
95
96 %description devel
97 This package contains the files necessary to develop applications
98 using Evolution's data server libraries.
99
100 %description devel -l pl
101 Ten pakiet zawiera pliki potrzebne do tworzenia aplikacji
102 korzystaj±cych z bibliotek serwera danych Evolution.
103
104 %package static
105 Summary:        Evolution data server static libraries
106 Summary(pl):    Statyczne biblioteki serwera danych Evolution
107 Group:          Development/Libraries
108 Requires:       %{name}-devel = %{version}-%{release}
109
110 %description static
111 Evolution data server static libraries.
112
113 %description static -l pl
114 Statyczne biblioteki serwera danych Evolution.
115
116 %prep
117 %setup -q
118 %patch0 -p1
119 %patch1 -p1
120
121 %build
122 %{__glib_gettextize}
123 %{__intltoolize}
124 %{__libtoolize}
125 %{__aclocal}
126 %{__autoheader}
127 %{__autoconf}
128 %{__automake}
129
130 cd calendar/libical
131 %{__libtoolize}
132 %{__aclocal}
133 %{__autoheader}
134 %{__autoconf}
135 %{__automake}
136 cd ../..
137 %configure \
138         %{?with_kerberos5:--with-krb5=%{_prefix}} \
139         %{!?with_kerberos5:--with-krb5=no} \
140         %{?with_ldap:--with-openldap=yes} \
141         %{!?with_ldap:--with-openldap=no} \
142         --enable-gnome-keyring=yes \
143         --enable-gtk-doc \
144         --enable-static \
145         --with-nspr-includes=%{_includedir}/nspr \
146         --with-nspr-libs=%{_libdir} \
147         --with-nss-includes=%{_includedir}/nss \
148         --with-nss-libs=%{_libdir} \
149         --with-libdb=%{_libdir}
150         
151 %{__make} \
152         HTML_DIR=%{_gtkdocdir} \
153         GTKHTML_DATADIR=%{_datadir}/idl
154
155 %install
156 rm -rf $RPM_BUILD_ROOT
157
158 %{__make} install \
159         DESTDIR=$RPM_BUILD_ROOT \
160         GTKHTML_DATADIR=%{_datadir}/idl \
161         HTML_DIR=%{_gtkdocdir} \
162         pkgconfigdir=%{_pkgconfigdir}
163
164 rm $RPM_BUILD_ROOT%{_libdir}/%{name}-%{apiver}/{camel-providers,extensions}/*.{la,a}
165
166 install -d $RPM_BUILD_ROOT%{schemadir}
167 install addressbook/backends/ldap/evolutionperson.schema $RPM_BUILD_ROOT%{schemadir}
168
169 %find_lang %{name} --all-name
170
171 %clean
172 rm -rf $RPM_BUILD_ROOT
173
174 %post
175 %scrollkeeper_update_post
176
177 %postun
178 %scrollkeeper_update_postun
179
180 %post   libs -p /sbin/ldconfig
181 %postun libs -p /sbin/ldconfig
182
183 %post -n openldap-schema-evolutionperson
184 %openldap_schema_register %{schemadir}/evolutionperson.schema
185 %service -q ldap restart
186
187 %postun -n openldap-schema-evolutionperson
188 if [ "$1" = "0" ]; then
189         %openldap_schema_unregister %{schemadir}/evolutionperson.schema
190         %service -q ldap restart
191 fi
192
193 %files -f %{name}.lang
194 %defattr(644,root,root,755)
195 %doc AUTHORS ChangeLog NEWS* README
196 %attr(755,root,root) %{_libdir}/camel-index-control-%{apiver}
197 %attr(755,root,root) %{_libdir}/camel-lock-helper-%{apiver}
198 %dir %{_libdir}/%{name}-%{apiver}
199 %dir %{_libdir}/%{name}-%{apiver}/camel-providers
200 %attr(755,root,root) %{_libdir}/evolution-data-server-%{basever}
201 %attr(755,root,root) %{_libdir}/%{name}-%{apiver}/camel-providers/*.so
202 %{_libdir}/%{name}-%{apiver}/camel-providers/*.urls
203 %dir %{_libdir}/%{name}-%{apiver}/extensions
204 %attr(755,root,root) %{_libdir}/%{name}-%{apiver}/extensions/*.so
205 %{_libdir}/bonobo/servers/*
206
207 %if %{with ldap}
208 %{_datadir}/%{name}-%{basever}/*.schema
209 %endif
210
211 %dir %{_datadir}/%{name}-%{basever}
212 %{_datadir}/%{name}-%{basever}/glade
213 %{_datadir}/%{name}-%{basever}/weather
214 %{_datadir}/%{name}-%{basever}/zoneinfo
215 %{_pixmapsdir}/%{name}-%{basever}
216
217 %files -n openldap-schema-evolutionperson
218 %defattr(644,root,root,755)
219 %{schemadir}/*.schema
220
221 %files libs
222 %defattr(644,root,root,755)
223 %attr(755,root,root) %{_libdir}/*.so.*.*
224 %{_datadir}/idl/%{name}-%{apiver}
225
226 %files devel
227 %defattr(644,root,root,755)
228 %attr(755,root,root) %{_libdir}/*.so
229 %{_libdir}/*.la
230 %{_includedir}/*
231 %{_pkgconfigdir}/*
232 %{_gtkdocdir}/*
233
234 %files static
235 %defattr(644,root,root,755)
236 %{_libdir}/*.a
This page took 0.051695 seconds and 4 git commands to generate.