]> git.pld-linux.org Git - packages/evolution-data-server.git/blob - evolution-data-server.spec
- fix w/o ldap
[packages/evolution-data-server.git] / evolution-data-server.spec
1 #
2 # todo:
3 # - system libical
4 #
5 # Conditional build:
6 %bcond_without  kerberos5       # build without kerberos5 support
7 %bcond_without  ldap            # build without ldap support
8 #
9 %define         mver            1.2
10 Summary:        Evolution data server
11 Summary(pl):    Serwer danych Evolution
12 Name:           evolution-data-server
13 Version:        1.2.3
14 Release:        3
15 License:        GPL
16 Group:          Libraries
17 Source0:        http://ftp.gnome.org/pub/gnome/sources/evolution-data-server/1.2/%{name}-%{version}.tar.bz2
18 # Source0-md5:  067d808957d4b3ac60159f8c8c1358fb
19 Patch0:         %{name}-system_db.patch
20 Patch1:         %{name}-GG-IM.patch
21 Patch2:         %{name}-workaround-cal-backend-leak.patch
22 Patch3:         %{name}-bonobo.patch
23 Patch4:         %{name}-gcc4.patch
24 URL:            http://www.ximian.com/products/ximian_evolution/
25 BuildRequires:  ORBit2-devel >= 1:2.12.1
26 BuildRequires:  autoconf >= 2.52
27 BuildRequires:  automake
28 BuildRequires:  db-devel
29 BuildRequires:  gnome-common >= 2.8.0
30 BuildRequires:  howl-devel >= 0.9.10
31 BuildRequires:  intltool
32 BuildRequires:  libglade2-devel >= 1:2.5.1
33 BuildRequires:  libgnomeui-devel >= 2.10.0-2
34 BuildRequires:  libsoup-devel >= 2.2.3
35 BuildRequires:  libstdc++-devel
36 BuildRequires:  libtool
37 BuildRequires:  nspr-devel
38 BuildRequires:  nss-devel
39 BuildRequires:  pkgconfig
40 BuildRequires:  rpmbuild(macros) >= 1.197
41 %{?with_kerberos5:BuildRequires:        heimdal-devel >= 0.7}
42 %{?with_ldap:BuildRequires:     openldap-devel >= 2.0.0}
43 Requires(post,postun):  /sbin/ldconfig
44 Requires(post,postun):  scrollkeeper
45 Requires:       libsoup >= 2.2.3
46 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
47
48 %description
49 The Evolution data server for the calendar and addressbook.
50
51 %description -l pl
52 Serwer danych Evolution dla kalendarza i ksi±¿ki adresowej.
53
54 %package devel
55 Summary:        Evolution data server development files
56 Summary(pl):    Pliki programistyczne serwera danych evolution
57 Group:          Development/Libraries
58 Requires:       %{name} = %{version}-%{release}
59 # for all but libegroupwise
60 Requires:       GConf2-devel >= 2.10.0
61 Requires:       ORBit2-devel >= 1:2.12.1
62 Requires:       glib2-devel >= 1:2.6.4
63 Requires:       libbonobo-devel >= 2.8.1
64 Requires:       libgnome-devel >= 2.10.0-2
65 Requires:       libxml2-devel
66 # for libegroupwise
67 Requires:       libsoup-devel >= 2.2.3
68
69 %description devel
70 This package contains the files necessary to develop applications
71 using Evolution's data server libraries.
72
73 %description devel -l pl
74 Ten pakiet zawiera pliki potrzebne do tworzenia aplikacji
75 korzystaj±cych z bibliotek serwera danych Evolution.
76
77 %package static
78 Summary:        Evolution data server static libraries
79 Summary(pl):    Statyczne biblioteki serwera danych Evolution
80 Group:          Development/Libraries
81 Requires:       %{name}-devel = %{version}-%{release}
82
83 %description static
84 Evolution data server static libraries.
85
86 %description static -l pl
87 Statyczne biblioteki serwera danych Evolution.
88
89 %prep
90 %setup -q 
91 %patch0 -p1
92 %patch1 -p1
93 %patch2 -p1
94 %patch3 -p1
95 %patch4 -p1
96
97 rm -rf libdb
98
99 %build
100 %{__glib_gettextize}
101 %{__intltoolize}
102 %{__libtoolize}
103 %{__aclocal}
104 %{__autoheader}
105 %{__autoconf}
106 %{__automake}
107
108 cd calendar/libical
109 %{__libtoolize}
110 %{__aclocal}
111 %{__autoheader}
112 %{__autoconf}
113 %{__automake}
114 cd ../..
115
116 %configure \
117         %{?with_kerberos5:--with-krb5=%{_prefix}} \
118         %{!?with_kerberos5:--with-krb5=no} \
119         %{?with_ldap:--with-openldap=yes} \
120         %{!?with_ldap:--with-openldap=no} \
121         --enable-gtk-doc \
122         --enable-static \
123         --with-nspr-includes=%{_includedir}/nspr \
124         --with-nspr-libs=%{_libdir} \
125         --with-nss-includes=%{_includedir}/nss \
126         --with-nss-libs=%{_libdir}
127 %{__make} \
128         HTML_DIR=%{_gtkdocdir} \
129         GTKHTML_DATADIR=%{_datadir}/idl 
130
131 %install
132 rm -rf $RPM_BUILD_ROOT
133
134 %{__make} install \
135         DESTDIR=$RPM_BUILD_ROOT \
136         GTKHTML_DATADIR=%{_datadir}/idl \
137         HTML_DIR=%{_gtkdocdir} \
138         pkgconfigdir=%{_pkgconfigdir}
139
140 rm $RPM_BUILD_ROOT%{_libdir}/%{name}-%{mver}/{camel-providers,extensions}/*.{la,a}
141
142 rm -r $RPM_BUILD_ROOT%{_datadir}/locale/no
143
144 %find_lang %{name} --all-name
145
146 %clean
147 rm -rf $RPM_BUILD_ROOT
148
149 %post
150 /sbin/ldconfig
151 %scrollkeeper_update_post
152
153 %postun
154 /sbin/ldconfig
155 %scrollkeeper_update_postun
156
157 %files -f %{name}.lang
158 %defattr(644,root,root,755)
159 %doc AUTHORS ChangeLog NEWS* README
160 %attr(755,root,root) %{_libdir}/camel-index-control-%{mver}
161 %attr(755,root,root) %{_libdir}/camel-lock-helper-%{mver}
162 %attr(755,root,root) %{_libdir}/*.so.*.*
163 %dir %{_libdir}/%{name}-%{mver}
164 %attr(755,root,root) %{_libdir}/%{name}-%{mver}/%{name}
165 %dir %{_libdir}/%{name}-%{mver}/camel-providers
166 %attr(755,root,root) %{_libdir}/%{name}-%{mver}/camel-providers/*.so
167 %{_libdir}/%{name}-%{mver}/camel-providers/*.urls
168 %dir %{_libdir}/%{name}-%{mver}/extensions
169 %attr(755,root,root) %{_libdir}/%{name}-%{mver}/extensions/*.so
170 %{_libdir}/bonobo/servers/*
171 %{_datadir}/idl/*
172 %dir %{_datadir}/%{name}-%{mver}
173 %{_datadir}/%{name}-%{mver}/glade
174 %{_datadir}/%{name}-%{mver}/weather
175 %{_datadir}/%{name}-%{mver}/zoneinfo
176 %if %{with ldap}
177 %{_datadir}/%{name}-%{mver}/*.schema
178 %endif
179 %{_pixmapsdir}/%{name}-%{mver}
180
181 %files devel
182 %defattr(644,root,root,755)
183 %attr(755,root,root) %{_libdir}/*.so
184 %{_libdir}/*.la
185 %{_includedir}/*
186 %{_pkgconfigdir}/*
187 %{_gtkdocdir}/*
188
189 %files static
190 %defattr(644,root,root,755)
191 %{_libdir}/*.a
This page took 0.060224 seconds and 4 git commands to generate.