]> git.pld-linux.org Git - packages/evolution-data-server.git/blob - evolution-data-server.spec
- fix instead of disabling --as-needed
[packages/evolution-data-server.git] / evolution-data-server.spec
1 #
2 # todo:
3 # - system libical
4 #
5 # Conditional build:
6 %bcond_without  kerberos5       # build without kerberos5 support
7 %bcond_without  ldap            # build without ldap support
8 #
9 %define         basever         1.8
10 %define         apiver          1.2
11 Summary:        Evolution data server
12 Summary(pl):    Serwer danych Evolution
13 Name:           evolution-data-server
14 Version:        1.7.90.1
15 Release:        2
16 License:        GPL
17 Group:          Libraries
18 Source0:        http://ftp.gnome.org/pub/gnome/sources/evolution-data-server/1.7/%{name}-%{version}.tar.bz2
19 # Source0-md5:  07fa3db5725d41093b22d4e90c2ced87
20 Patch0:         %{name}-workaround-cal-backend-leak.patch
21 Patch1:         %{name}-gcc4.patch
22 Patch2:         %{name}-as_needed-fix.patch
23 URL:            http://www.ximian.com/products/ximian_evolution/
24 BuildRequires:  ORBit2-devel >= 1:2.14.2
25 BuildRequires:  autoconf >= 2.52
26 BuildRequires:  automake
27 BuildRequires:  bison
28 BuildRequires:  db-devel
29 BuildRequires:  gnome-common >= 2.12.0
30 BuildRequires:  gnome-keyring-devel >= 0.5.1
31 %{?with_kerberos5:BuildRequires:        heimdal-devel >= 0.7}
32 BuildRequires:  intltool
33 BuildRequires:  libglade2-devel >= 1:2.6.0
34 BuildRequires:  libgnomeui-devel >= 2.15.90
35 BuildRequires:  libsoup-devel >= 2.2.96
36 BuildRequires:  libstdc++-devel
37 BuildRequires:  libtool
38 BuildRequires:  nspr-devel
39 BuildRequires:  nss-devel
40 %{?with_ldap:BuildRequires:     openldap-devel >= 2.3.0}
41 BuildRequires:  pkgconfig
42 BuildRequires:  rpmbuild(macros) >= 1.304
43 Requires(post,postun):  scrollkeeper
44 Requires:       %{name}-libs = %{version}-%{release}
45 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
46
47 %define         schemadir       /usr/share/openldap/schema
48
49 %description
50 The Evolution data server for the calendar and addressbook.
51
52 %description -l pl
53 Serwer danych Evolution dla kalendarza i ksi±¿ki adresowej.
54
55 %package -n openldap-schema-evolutionperson
56 Summary:        evolutionperson LDAP schema
57 Summary(pl):    Schemat LDAP evolutionperson
58 Group:          Networking/Daemons
59 Requires(post,postun):  sed >= 4.0
60 Requires:       openldap-servers
61
62 %description -n openldap-schema-evolutionperson
63 This package contains evolutionperson.schema for openldap server.
64
65 %description -n openldap-schema-evolutionperson -l pl
66 Ten pakiet zawiera evolutionperson.schema dla serwera openldap.
67
68 %package libs
69 Summary:        Evolution Data Server library
70 Summary(pl):    Biblioteka Evolution Data Server
71 Group:          Libraries
72 Requires:       libgnomeui >= 2.15.90
73 Requires:       libsoup >= 2.2.96
74
75 %description libs
76 This package contains Evolution Data Server library.
77
78 %description libs -l pl
79 Ten pakiet zawiera bibliotekê Evolution Data Server.
80
81 %package devel
82 Summary:        Evolution data server development files
83 Summary(pl):    Pliki programistyczne serwera danych evolution
84 Group:          Development/Libraries
85 Requires:       %{name}-libs = %{version}-%{release}
86 %{?with_kerberos5:Requires:     heimdal-devel >= 0.7}
87 # for all but libegroupwise
88 Requires:       GConf2-devel >= 2.14.0
89 Requires:       ORBit2-devel >= 1:2.14.2
90 Requires:       glib2-devel >= 1:2.12.1
91 Requires:       libgnomeui-devel >= 2.15.90
92 Requires:       libxml2-devel >= 1:2.6.26
93 # for libegroupwise
94 Requires:       libsoup-devel >= 2.2.96
95
96 %description devel
97 This package contains the files necessary to develop applications
98 using Evolution's data server libraries.
99
100 %description devel -l pl
101 Ten pakiet zawiera pliki potrzebne do tworzenia aplikacji
102 korzystaj±cych z bibliotek serwera danych Evolution.
103
104 %package static
105 Summary:        Evolution data server static libraries
106 Summary(pl):    Statyczne biblioteki serwera danych Evolution
107 Group:          Development/Libraries
108 Requires:       %{name}-devel = %{version}-%{release}
109
110 %description static
111 Evolution data server static libraries.
112
113 %description static -l pl
114 Statyczne biblioteki serwera danych Evolution.
115
116 %prep
117 %setup -q
118 %patch0 -p1
119 %patch1 -p1
120 %patch2 -p1
121
122 %build
123 %{__glib_gettextize}
124 %{__intltoolize}
125 %{__libtoolize}
126 %{__aclocal}
127 %{__autoheader}
128 %{__autoconf}
129 %{__automake}
130
131 cd calendar/libical
132 %{__libtoolize}
133 %{__aclocal}
134 %{__autoheader}
135 %{__autoconf}
136 %{__automake}
137 cd ../..
138 %configure \
139         %{?with_kerberos5:--with-krb5=%{_prefix}} \
140         %{!?with_kerberos5:--with-krb5=no} \
141         %{?with_ldap:--with-openldap=yes} \
142         %{!?with_ldap:--with-openldap=no} \
143         --enable-gnome-keyring=yes \
144         --enable-gtk-doc \
145         --enable-static \
146         --with-nspr-includes=%{_includedir}/nspr \
147         --with-nspr-libs=%{_libdir} \
148         --with-nss-includes=%{_includedir}/nss \
149         --with-nss-libs=%{_libdir} \
150         --with-libdb=%{_libdir}
151         
152 %{__make} \
153         HTML_DIR=%{_gtkdocdir} \
154         GTKHTML_DATADIR=%{_datadir}/idl
155
156 %install
157 rm -rf $RPM_BUILD_ROOT
158
159 %{__make} install \
160         DESTDIR=$RPM_BUILD_ROOT \
161         GTKHTML_DATADIR=%{_datadir}/idl \
162         HTML_DIR=%{_gtkdocdir} \
163         pkgconfigdir=%{_pkgconfigdir}
164
165 rm $RPM_BUILD_ROOT%{_libdir}/%{name}-%{apiver}/{camel-providers,extensions}/*.{la,a}
166
167 install -d $RPM_BUILD_ROOT%{schemadir}
168 install addressbook/backends/ldap/evolutionperson.schema $RPM_BUILD_ROOT%{schemadir}
169
170 %find_lang %{name} --all-name
171
172 %clean
173 rm -rf $RPM_BUILD_ROOT
174
175 %post
176 %scrollkeeper_update_post
177
178 %postun
179 %scrollkeeper_update_postun
180
181 %post   libs -p /sbin/ldconfig
182 %postun libs -p /sbin/ldconfig
183
184 %post -n openldap-schema-evolutionperson
185 %openldap_schema_register %{schemadir}/evolutionperson.schema
186 %service -q ldap restart
187
188 %postun -n openldap-schema-evolutionperson
189 if [ "$1" = "0" ]; then
190         %openldap_schema_unregister %{schemadir}/evolutionperson.schema
191         %service -q ldap restart
192 fi
193
194 %files -f %{name}.lang
195 %defattr(644,root,root,755)
196 %doc AUTHORS ChangeLog NEWS* README
197 %attr(755,root,root) %{_libdir}/camel-index-control-%{apiver}
198 %attr(755,root,root) %{_libdir}/camel-lock-helper-%{apiver}
199 %dir %{_libdir}/%{name}-%{apiver}
200 %dir %{_libdir}/%{name}-%{apiver}/camel-providers
201 %attr(755,root,root) %{_libdir}/evolution-data-server-%{basever}
202 %attr(755,root,root) %{_libdir}/%{name}-%{apiver}/camel-providers/*.so
203 %{_libdir}/%{name}-%{apiver}/camel-providers/*.urls
204 %dir %{_libdir}/%{name}-%{apiver}/extensions
205 %attr(755,root,root) %{_libdir}/%{name}-%{apiver}/extensions/*.so
206 %{_libdir}/bonobo/servers/*
207
208 %if %{with ldap}
209 %{_datadir}/%{name}-%{basever}/*.schema
210 %endif
211
212 %dir %{_datadir}/%{name}-%{basever}
213 %{_datadir}/%{name}-%{basever}/glade
214 %{_datadir}/%{name}-%{basever}/weather
215 %{_datadir}/%{name}-%{basever}/zoneinfo
216 %{_pixmapsdir}/%{name}-%{basever}
217
218 %files -n openldap-schema-evolutionperson
219 %defattr(644,root,root,755)
220 %{schemadir}/*.schema
221
222 %files libs
223 %defattr(644,root,root,755)
224 %attr(755,root,root) %{_libdir}/*.so.*.*
225 %{_datadir}/idl/%{name}-%{apiver}
226
227 %files devel
228 %defattr(644,root,root,755)
229 %attr(755,root,root) %{_libdir}/*.so
230 %{_libdir}/*.la
231 %{_includedir}/*
232 %{_pkgconfigdir}/*
233 %{_gtkdocdir}/*
234
235 %files static
236 %defattr(644,root,root,755)
237 %{_libdir}/*.a
This page took 0.050575 seconds and 4 git commands to generate.