]> git.pld-linux.org Git - packages/evolution-data-server.git/blob - evolution-data-server.spec
- 1.7.2, GNOME 2.15.x deps, removed obsolete system_db patch
[packages/evolution-data-server.git] / evolution-data-server.spec
1 #
2 # todo:
3 # - system libical
4 #
5 # Conditional build:
6 %bcond_without  kerberos5       # build without kerberos5 support
7 %bcond_without  ldap            # build without ldap support
8 #
9 %define         basever         1.8
10 %define         apiver          1.2
11 Summary:        Evolution data server
12 Summary(pl):    Serwer danych Evolution
13 Name:           evolution-data-server
14 Version:        1.7.2
15 Release:        1
16 License:        GPL
17 Group:          Libraries
18 Source0:        http://ftp.gnome.org/pub/gnome/sources/evolution-data-server/1.7/%{name}-%{version}.tar.bz2
19 # Source0-md5:  ccd8cd291cdea417b4d3ae19363cc4c5
20 Patch0:         %{name}-GG-IM.patch
21 Patch1:         %{name}-workaround-cal-backend-leak.patch
22 Patch2:         %{name}-gcc4.patch
23 URL:            http://www.ximian.com/products/ximian_evolution/
24 BuildRequires:  ORBit2-devel >= 1:2.14.0
25 BuildRequires:  autoconf >= 2.52
26 BuildRequires:  automake
27 BuildRequires:  bison
28 BuildRequires:  db-devel
29 BuildRequires:  gnome-common >= 2.8.0
30 BuildRequires:  gnome-keyring-devel >= 0.4.9-2
31 %{?with_kerberos5:BuildRequires:        heimdal-devel >= 0.7}
32 BuildRequires:  intltool
33 BuildRequires:  libglade2-devel >= 1:2.5.1
34 BuildRequires:  libgnomeui-devel >= 2.14.1
35 BuildRequires:  libsoup-devel >= 2.2.93
36 BuildRequires:  libstdc++-devel
37 BuildRequires:  libtool
38 BuildRequires:  nspr-devel
39 BuildRequires:  nss-devel
40 %{?with_ldap:BuildRequires:     openldap-devel >= 2.3.0}
41 BuildRequires:  pkgconfig
42 BuildRequires:  rpmbuild(macros) >= 1.304
43 Requires(post,postun):  scrollkeeper
44 Requires:       %{name}-libs = %{version}-%{release}
45 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
46
47 %define         schemadir       /usr/share/openldap/schema
48
49 %description
50 The Evolution data server for the calendar and addressbook.
51
52 %description -l pl
53 Serwer danych Evolution dla kalendarza i ksi±¿ki adresowej.
54
55 %package -n openldap-schema-evolutionperson
56 Summary:        evolutionperson LDAP schema
57 Summary(pl):    Schemat LDAP evolutionperson
58 Group:          Networking/Daemons
59 Requires(post,postun):  sed >= 4.0
60 Requires:       openldap-servers
61
62 %description -n openldap-schema-evolutionperson
63 This package contains evolutionperson.schema for openldap server.
64
65 %description -n openldap-schema-evolutionperson -l pl
66 Ten pakiet zawiera evolutionperson.schema dla serwera openldap.
67
68 %package libs
69 Summary:        Evolution Data Server library
70 Summary(pl):    Biblioteka Evolution Data Server
71 Group:          Libraries
72 Requires:       libgnomeui >= 2.14.1
73 Requires:       libsoup >= 2.2.93
74
75 %description libs
76 This package contains Evolution Data Server library.
77
78 %description libs -l pl
79 Ten pakiet zawiera bibliotekê Evolution Data Server.
80
81 %package devel
82 Summary:        Evolution data server development files
83 Summary(pl):    Pliki programistyczne serwera danych evolution
84 Group:          Development/Libraries
85 Requires:       %{name}-libs = %{version}-%{release}
86 %{?with_kerberos5:Requires:     heimdal-devel >= 0.7}
87 # for all but libegroupwise
88 Requires:       GConf2-devel >= 2.14.0
89 Requires:       ORBit2-devel >= 1:2.14.0
90 Requires:       glib2-devel >= 1:2.11.1
91 Requires:       libbonobo-devel >= 2.14.0
92 Requires:       libgnomeui-devel >= 2.14.1
93 Requires:       libxml2-devel
94 # for libegroupwise
95 Requires:       libsoup-devel >= 2.2.93
96
97 %description devel
98 This package contains the files necessary to develop applications
99 using Evolution's data server libraries.
100
101 %description devel -l pl
102 Ten pakiet zawiera pliki potrzebne do tworzenia aplikacji
103 korzystaj±cych z bibliotek serwera danych Evolution.
104
105 %package static
106 Summary:        Evolution data server static libraries
107 Summary(pl):    Statyczne biblioteki serwera danych Evolution
108 Group:          Development/Libraries
109 Requires:       %{name}-devel = %{version}-%{release}
110
111 %description static
112 Evolution data server static libraries.
113
114 %description static -l pl
115 Statyczne biblioteki serwera danych Evolution.
116
117 %prep
118 %setup -q
119 %patch0 -p1
120 %patch1 -p1
121 %patch2 -p1
122
123 %build
124 %{__glib_gettextize}
125 %{__intltoolize}
126 %{__libtoolize}
127 %{__aclocal}
128 %{__autoheader}
129 %{__autoconf}
130 %{__automake}
131
132 cd calendar/libical
133 %{__libtoolize}
134 %{__aclocal}
135 %{__autoheader}
136 %{__autoconf}
137 %{__automake}
138 cd ../..
139
140 %configure \
141         %{?with_kerberos5:--with-krb5=%{_prefix}} \
142         %{!?with_kerberos5:--with-krb5=no} \
143         %{?with_ldap:--with-openldap=yes} \
144         %{!?with_ldap:--with-openldap=no} \
145         --enable-gnome-keyring=yes \
146         --enable-gtk-doc \
147         --enable-static \
148         --with-nspr-includes=%{_includedir}/nspr \
149         --with-nspr-libs=%{_libdir} \
150         --with-nss-includes=%{_includedir}/nss \
151         --with-nss-libs=%{_libdir} \
152         --with-libdb=%{_libdir}
153         
154 %{__make} \
155         HTML_DIR=%{_gtkdocdir} \
156         GTKHTML_DATADIR=%{_datadir}/idl
157
158 %install
159 rm -rf $RPM_BUILD_ROOT
160
161 %{__make} install \
162         DESTDIR=$RPM_BUILD_ROOT \
163         GTKHTML_DATADIR=%{_datadir}/idl \
164         HTML_DIR=%{_gtkdocdir} \
165         pkgconfigdir=%{_pkgconfigdir}
166
167 rm $RPM_BUILD_ROOT%{_libdir}/%{name}-%{apiver}/{camel-providers,extensions}/*.{la,a}
168
169 install -d $RPM_BUILD_ROOT%{schemadir}
170 install addressbook/backends/ldap/evolutionperson.schema $RPM_BUILD_ROOT%{schemadir}
171
172 %find_lang %{name} --all-name
173
174 %clean
175 rm -rf $RPM_BUILD_ROOT
176
177 %post
178 %scrollkeeper_update_post
179
180 %postun
181 %scrollkeeper_update_postun
182
183 %post   libs -p /sbin/ldconfig
184 %postun libs -p /sbin/ldconfig
185
186 %post -n openldap-schema-evolutionperson
187 %openldap_schema_register %{schemadir}/evolutionperson.schema
188 %service -q ldap restart
189
190 %postun -n openldap-schema-evolutionperson
191 if [ "$1" = "0" ]; then
192         %openldap_schema_unregister %{schemadir}/evolutionperson.schema
193         %service -q ldap restart
194 fi
195
196 %files -f %{name}.lang
197 %defattr(644,root,root,755)
198 %doc AUTHORS ChangeLog NEWS* README
199 %attr(755,root,root) %{_libdir}/camel-index-control-%{apiver}
200 %attr(755,root,root) %{_libdir}/camel-lock-helper-%{apiver}
201 %dir %{_libdir}/%{name}-%{apiver}
202 %dir %{_libdir}/%{name}-%{apiver}/camel-providers
203 %attr(755,root,root) %{_libdir}/evolution-data-server-%{basever}
204 %attr(755,root,root) %{_libdir}/%{name}-%{apiver}/camel-providers/*.so
205 %{_libdir}/%{name}-%{apiver}/camel-providers/*.urls
206 %dir %{_libdir}/%{name}-%{apiver}/extensions
207 %attr(755,root,root) %{_libdir}/%{name}-%{apiver}/extensions/*.so
208 %{_libdir}/bonobo/servers/*
209
210 %if %{with ldap}
211 %{_datadir}/%{name}-%{basever}/*.schema
212 %endif
213
214 %dir %{_datadir}/%{name}-%{basever}
215 %{_datadir}/%{name}-%{basever}/glade
216 %{_datadir}/%{name}-%{basever}/weather
217 %{_datadir}/%{name}-%{basever}/zoneinfo
218 %{_pixmapsdir}/%{name}-%{basever}
219
220 %files -n openldap-schema-evolutionperson
221 %defattr(644,root,root,755)
222 %{schemadir}/*.schema
223
224 %files libs
225 %defattr(644,root,root,755)
226 %attr(755,root,root) %{_libdir}/*.so.*.*
227 %{_datadir}/idl/%{name}-%{apiver}
228
229 %files devel
230 %defattr(644,root,root,755)
231 %attr(755,root,root) %{_libdir}/*.so
232 %{_libdir}/*.la
233 %{_includedir}/*
234 %{_pkgconfigdir}/*
235 %{_gtkdocdir}/*
236
237 %files static
238 %defattr(644,root,root,755)
239 %{_libdir}/*.a
This page took 0.074779 seconds and 4 git commands to generate.