]> git.pld-linux.org Git - packages/evolution-data-server.git/blob - evolution-data-server.spec
- rel 4
[packages/evolution-data-server.git] / evolution-data-server.spec
1 #
2 # todo:
3 # - system libical
4 #
5 # Conditional build:
6 %bcond_without  kerberos5       # build without kerberos5 support
7 %bcond_without  ldap            # build without ldap support
8 #
9 %define         basever         1.12
10 %define         apiver          1.2
11 Summary:        Evolution data server
12 Summary(pl.UTF-8):      Serwer danych Evolution
13 Name:           evolution-data-server
14 Version:        1.12.1
15 Release:        4
16 License:        GPL
17 Group:          Libraries
18 Source0:        http://ftp.gnome.org/pub/GNOME/sources/evolution-data-server/1.12/%{name}-%{version}.tar.bz2
19 # Source0-md5:  5b4d855ed1ceaaab7db14b50133b5252
20 Patch0:         %{name}-ntlm-ldap.patch
21 URL:            http://www.gnome.org/projects/evolution/
22 BuildRequires:  ORBit2-devel >= 1:2.14.8
23 BuildRequires:  autoconf >= 2.52
24 BuildRequires:  automake
25 BuildRequires:  bison
26 BuildRequires:  db-devel
27 BuildRequires:  gnome-common >= 2.20.0
28 BuildRequires:  gnome-keyring-devel >= 2.20.0
29 BuildRequires:  gtk-doc >= 1.8
30 %{?with_kerberos5:BuildRequires:        krb5-devel}
31 BuildRequires:  intltool >= 0.36.1
32 BuildRequires:  libglade2-devel >= 1:2.6.2
33 BuildRequires:  libgnomeui-devel >= 2.20.0
34 BuildRequires:  libsoup-devel >= 2.2.100
35 BuildRequires:  libstdc++-devel
36 BuildRequires:  libtool
37 BuildRequires:  nspr-devel
38 BuildRequires:  nss-devel
39 %{?with_ldap:BuildRequires:     openldap-evolution-devel >= 2.4.6}
40 BuildRequires:  pkgconfig
41 BuildRequires:  rpmbuild(macros) >= 1.304
42 Requires(post,postun):  scrollkeeper
43 Requires:       %{name}-libs = %{version}-%{release}
44 # sr@Latn vs. sr@latin
45 Conflicts:      glibc-misc < 6:2.7
46 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
47
48 %define         schemadir       /usr/share/openldap/schema
49
50 %description
51 The Evolution data server for the calendar and addressbook.
52
53 %description -l pl.UTF-8
54 Serwer danych Evolution dla kalendarza i książki adresowej.
55
56 %package -n openldap-schema-evolutionperson
57 Summary:        evolutionperson LDAP schema
58 Summary(pl.UTF-8):      Schemat LDAP evolutionperson
59 Group:          Networking/Daemons
60 Requires(post,postun):  sed >= 4.0
61 Requires:       openldap-servers
62
63 %description -n openldap-schema-evolutionperson
64 This package contains evolutionperson.schema for openldap server.
65
66 %description -n openldap-schema-evolutionperson -l pl.UTF-8
67 Ten pakiet zawiera evolutionperson.schema dla serwera openldap.
68
69 %package libs
70 Summary:        Evolution Data Server library
71 Summary(pl.UTF-8):      Biblioteka Evolution Data Server
72 Group:          Libraries
73 Requires:       libgnomeui >= 2.20.0
74 Requires:       libsoup >= 2.2.100
75
76 %description libs
77 This package contains Evolution Data Server library.
78
79 %description libs -l pl.UTF-8
80 Ten pakiet zawiera bibliotekę Evolution Data Server.
81
82 %package devel
83 Summary:        Evolution data server development files
84 Summary(pl.UTF-8):      Pliki programistyczne serwera danych evolution
85 Group:          Development/Libraries
86 Requires:       %{name}-libs = %{version}-%{release}
87 %{?with_kerberos5:Requires:     krb5-devel}
88 # for all but libegroupwise
89 Requires:       GConf2-devel >= 2.20.0
90 Requires:       ORBit2-devel >= 1:2.14.8
91 Requires:       glib2-devel >= 1:2.14.1
92 Requires:       libgnomeui-devel >= 2.20.0
93 Requires:       libxml2-devel >= 1:2.6.29
94 # for libegroupwise
95 Requires:       libsoup-devel >= 2.2.100
96
97 %description devel
98 This package contains the files necessary to develop applications
99 using Evolution's data server libraries.
100
101 %description devel -l pl.UTF-8
102 Ten pakiet zawiera pliki potrzebne do tworzenia aplikacji
103 korzystających z bibliotek serwera danych Evolution.
104
105 %package static
106 Summary:        Evolution data server static libraries
107 Summary(pl.UTF-8):      Statyczne biblioteki serwera danych Evolution
108 Group:          Development/Libraries
109 Requires:       %{name}-devel = %{version}-%{release}
110
111 %description static
112 Evolution data server static libraries.
113
114 %description static -l pl.UTF-8
115 Statyczne biblioteki serwera danych Evolution.
116
117 %package apidocs
118 Summary:        e-d-s API documentation
119 Summary(pl.UTF-8):      Dokumentacja API e-d-s
120 Group:          Documentation
121 Requires:       gtk-doc-common
122
123 %description apidocs
124 e-d-s API documentation.
125
126 %description apidocs -l pl.UTF-8
127 Dokumentacja API e-d-s.
128
129 %prep
130 %setup -q
131 %patch0 -p1
132
133 %build
134 %{__glib_gettextize}
135 %{__intltoolize}
136 %{__libtoolize}
137 %{__aclocal}
138 %{__autoheader}
139 %{__autoconf}
140 %{__automake}
141
142 cd calendar/libical
143 %{__libtoolize}
144 %{__aclocal}
145 %{__autoheader}
146 %{__autoconf}
147 %{__automake}
148 cd ../..
149
150 # Set LIBS so that configure will be able to link with static LDAP libraries,
151 # which depend on Cyrus SASL and OpenSSL.
152 if pkg-config openssl ; then
153         LIBS="-lsasl2 `pkg-config --libs openssl`"
154 else
155         LIBS="-lsasl2 -lssl -lcrypto"
156 fi
157 export LIBS
158
159 %configure \
160         %{?with_kerberos5:--with-krb5=%{_prefix}} \
161         %{!?with_kerberos5:--with-krb5=no} \
162         %{?with_ldap:--with-openldap=%{_libdir}/evolution-openldap} \
163         %{?with_ldap:--with-static-ldap=yes} \
164         %{!?with_ldap:--with-openldap=no} \
165         --enable-gnome-keyring=yes \
166         --enable-gtk-doc \
167         --enable-static \
168         --with-nspr-includes=%{_includedir}/nspr \
169         --with-nspr-libs=%{_libdir} \
170         --with-nss-includes=%{_includedir}/nss \
171         --with-nss-libs=%{_libdir} \
172         --with-libdb=%{_libdir}
173
174 %{__make} \
175         HTML_DIR=%{_gtkdocdir} \
176         GTKHTML_DATADIR=%{_datadir}/idl
177
178 %install
179 rm -rf $RPM_BUILD_ROOT
180
181 %{__make} install \
182         DESTDIR=$RPM_BUILD_ROOT \
183         GTKHTML_DATADIR=%{_datadir}/idl \
184         HTML_DIR=%{_gtkdocdir} \
185         pkgconfigdir=%{_pkgconfigdir}
186
187 rm $RPM_BUILD_ROOT%{_libdir}/%{name}-%{apiver}/{camel-providers,extensions}/*.{la,a}
188
189 install -d $RPM_BUILD_ROOT%{schemadir}
190 install addressbook/backends/ldap/evolutionperson.schema $RPM_BUILD_ROOT%{schemadir}
191
192 [ -d $RPM_BUILD_ROOT%{_datadir}/locale/sr@latin ] || \
193         mv -f $RPM_BUILD_ROOT%{_datadir}/locale/sr@{Latn,latin}
194 %find_lang %{name} --all-name
195
196 %clean
197 rm -rf $RPM_BUILD_ROOT
198
199 %post
200 %scrollkeeper_update_post
201
202 %postun
203 %scrollkeeper_update_postun
204
205 %post   libs -p /sbin/ldconfig
206 %postun libs -p /sbin/ldconfig
207
208 %post -n openldap-schema-evolutionperson
209 %openldap_schema_register %{schemadir}/evolutionperson.schema
210 %service -q ldap restart
211
212 %postun -n openldap-schema-evolutionperson
213 if [ "$1" = "0" ]; then
214         %openldap_schema_unregister %{schemadir}/evolutionperson.schema
215         %service -q ldap restart
216 fi
217
218 %files -f %{name}.lang
219 %defattr(644,root,root,755)
220 %doc AUTHORS ChangeLog NEWS* README
221 %attr(755,root,root) %{_libdir}/camel-index-control-%{apiver}
222 %attr(755,root,root) %{_libdir}/camel-lock-helper-%{apiver}
223 %dir %{_libdir}/%{name}-%{apiver}
224 %dir %{_libdir}/%{name}-%{apiver}/camel-providers
225 %attr(755,root,root) %{_libdir}/evolution-data-server-%{basever}
226 %attr(755,root,root) %{_libdir}/%{name}-%{apiver}/camel-providers/*.so
227 %{_libdir}/%{name}-%{apiver}/camel-providers/*.urls
228 %dir %{_libdir}/%{name}-%{apiver}/extensions
229 %attr(755,root,root) %{_libdir}/%{name}-%{apiver}/extensions/*.so
230 %{_libdir}/bonobo/servers/*
231
232 %if %{with ldap}
233 %{_datadir}/%{name}-%{basever}/*.schema
234 %endif
235
236 %dir %{_datadir}/%{name}-%{basever}
237 %{_datadir}/%{name}-%{basever}/glade
238 %{_datadir}/%{name}-%{basever}/weather
239 %{_pixmapsdir}/%{name}
240
241 %files -n openldap-schema-evolutionperson
242 %defattr(644,root,root,755)
243 %{schemadir}/*.schema
244
245 %files libs
246 %defattr(644,root,root,755)
247 %attr(755,root,root) %{_libdir}/*.so.*.*
248 %{_datadir}/idl/%{name}-%{apiver}
249
250 %files devel
251 %defattr(644,root,root,755)
252 %attr(755,root,root) %{_libdir}/*.so
253 %{_libdir}/*.la
254 %{_includedir}/*
255 %{_pkgconfigdir}/*
256
257 %files static
258 %defattr(644,root,root,755)
259 %{_libdir}/*.a
260
261 %files apidocs
262 %defattr(644,root,root,755)
263 %{_gtkdocdir}/*
This page took 0.060374 seconds and 4 git commands to generate.