]> git.pld-linux.org Git - packages/evolution-data-server.git/blob - evolution-data-server.spec
- BR openssl-devel, cyrus-sasl-devel
[packages/evolution-data-server.git] / evolution-data-server.spec
1 #
2 # todo:
3 # - system libical
4 #
5 # Conditional build:
6 %bcond_without  kerberos5       # build without kerberos5 support
7 %bcond_without  ldap            # build without ldap support
8 #
9 %define         basever         1.12
10 %define         apiver          1.2
11 Summary:        Evolution data server
12 Summary(pl.UTF-8):      Serwer danych Evolution
13 Name:           evolution-data-server
14 Version:        1.12.1
15 Release:        4
16 License:        GPL
17 Group:          Libraries
18 Source0:        http://ftp.gnome.org/pub/GNOME/sources/evolution-data-server/1.12/%{name}-%{version}.tar.bz2
19 # Source0-md5:  5b4d855ed1ceaaab7db14b50133b5252
20 Patch0:         %{name}-ntlm-ldap.patch
21 URL:            http://www.gnome.org/projects/evolution/
22 BuildRequires:  ORBit2-devel >= 1:2.14.8
23 BuildRequires:  autoconf >= 2.52
24 BuildRequires:  automake
25 BuildRequires:  bison
26 BuildRequires:  cyrus-sasl-devel
27 BuildRequires:  db-devel
28 BuildRequires:  gnome-common >= 2.20.0
29 BuildRequires:  gnome-keyring-devel >= 2.20.0
30 BuildRequires:  gtk-doc >= 1.8
31 %{?with_kerberos5:BuildRequires:        krb5-devel}
32 BuildRequires:  intltool >= 0.36.1
33 BuildRequires:  libglade2-devel >= 1:2.6.2
34 BuildRequires:  libgnomeui-devel >= 2.20.0
35 BuildRequires:  libsoup-devel >= 2.2.100
36 BuildRequires:  libstdc++-devel
37 BuildRequires:  libtool
38 BuildRequires:  nspr-devel
39 BuildRequires:  nss-devel
40 %{?with_ldap:BuildRequires:     openldap-evolution-devel >= 2.4.6}
41 BuildRequires:  openssl-devel
42 BuildRequires:  pkgconfig
43 BuildRequires:  rpmbuild(macros) >= 1.304
44 Requires(post,postun):  scrollkeeper
45 Requires:       %{name}-libs = %{version}-%{release}
46 # sr@Latn vs. sr@latin
47 Conflicts:      glibc-misc < 6:2.7
48 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
49
50 %define         schemadir       /usr/share/openldap/schema
51
52 %description
53 The Evolution data server for the calendar and addressbook.
54
55 %description -l pl.UTF-8
56 Serwer danych Evolution dla kalendarza i książki adresowej.
57
58 %package -n openldap-schema-evolutionperson
59 Summary:        evolutionperson LDAP schema
60 Summary(pl.UTF-8):      Schemat LDAP evolutionperson
61 Group:          Networking/Daemons
62 Requires(post,postun):  sed >= 4.0
63 Requires:       openldap-servers
64
65 %description -n openldap-schema-evolutionperson
66 This package contains evolutionperson.schema for openldap server.
67
68 %description -n openldap-schema-evolutionperson -l pl.UTF-8
69 Ten pakiet zawiera evolutionperson.schema dla serwera openldap.
70
71 %package libs
72 Summary:        Evolution Data Server library
73 Summary(pl.UTF-8):      Biblioteka Evolution Data Server
74 Group:          Libraries
75 Requires:       libgnomeui >= 2.20.0
76 Requires:       libsoup >= 2.2.100
77
78 %description libs
79 This package contains Evolution Data Server library.
80
81 %description libs -l pl.UTF-8
82 Ten pakiet zawiera bibliotekę Evolution Data Server.
83
84 %package devel
85 Summary:        Evolution data server development files
86 Summary(pl.UTF-8):      Pliki programistyczne serwera danych evolution
87 Group:          Development/Libraries
88 Requires:       %{name}-libs = %{version}-%{release}
89 %{?with_kerberos5:Requires:     krb5-devel}
90 # for all but libegroupwise
91 Requires:       GConf2-devel >= 2.20.0
92 Requires:       ORBit2-devel >= 1:2.14.8
93 Requires:       glib2-devel >= 1:2.14.1
94 Requires:       libgnomeui-devel >= 2.20.0
95 Requires:       libxml2-devel >= 1:2.6.29
96 # for libegroupwise
97 Requires:       libsoup-devel >= 2.2.100
98
99 %description devel
100 This package contains the files necessary to develop applications
101 using Evolution's data server libraries.
102
103 %description devel -l pl.UTF-8
104 Ten pakiet zawiera pliki potrzebne do tworzenia aplikacji
105 korzystających z bibliotek serwera danych Evolution.
106
107 %package static
108 Summary:        Evolution data server static libraries
109 Summary(pl.UTF-8):      Statyczne biblioteki serwera danych Evolution
110 Group:          Development/Libraries
111 Requires:       %{name}-devel = %{version}-%{release}
112
113 %description static
114 Evolution data server static libraries.
115
116 %description static -l pl.UTF-8
117 Statyczne biblioteki serwera danych Evolution.
118
119 %package apidocs
120 Summary:        e-d-s API documentation
121 Summary(pl.UTF-8):      Dokumentacja API e-d-s
122 Group:          Documentation
123 Requires:       gtk-doc-common
124
125 %description apidocs
126 e-d-s API documentation.
127
128 %description apidocs -l pl.UTF-8
129 Dokumentacja API e-d-s.
130
131 %prep
132 %setup -q
133 %patch0 -p1
134
135 %build
136 %{__glib_gettextize}
137 %{__intltoolize}
138 %{__libtoolize}
139 %{__aclocal}
140 %{__autoheader}
141 %{__autoconf}
142 %{__automake}
143
144 cd calendar/libical
145 %{__libtoolize}
146 %{__aclocal}
147 %{__autoheader}
148 %{__autoconf}
149 %{__automake}
150 cd ../..
151
152 # Set LIBS so that configure will be able to link with static LDAP libraries,
153 # which depend on Cyrus SASL and OpenSSL.
154 if pkg-config openssl ; then
155         LIBS="-lsasl2 `pkg-config --libs openssl`"
156 else
157         LIBS="-lsasl2 -lssl -lcrypto"
158 fi
159 export LIBS
160
161 %configure \
162         %{?with_kerberos5:--with-krb5=%{_prefix}} \
163         %{!?with_kerberos5:--with-krb5=no} \
164         %{?with_ldap:--with-openldap=%{_libdir}/evolution-openldap} \
165         %{?with_ldap:--with-static-ldap=yes} \
166         %{!?with_ldap:--with-openldap=no} \
167         --enable-gnome-keyring=yes \
168         --enable-gtk-doc \
169         --enable-static \
170         --with-nspr-includes=%{_includedir}/nspr \
171         --with-nspr-libs=%{_libdir} \
172         --with-nss-includes=%{_includedir}/nss \
173         --with-nss-libs=%{_libdir} \
174         --with-libdb=%{_libdir}
175
176 %{__make} \
177         HTML_DIR=%{_gtkdocdir} \
178         GTKHTML_DATADIR=%{_datadir}/idl
179
180 %install
181 rm -rf $RPM_BUILD_ROOT
182
183 %{__make} install \
184         DESTDIR=$RPM_BUILD_ROOT \
185         GTKHTML_DATADIR=%{_datadir}/idl \
186         HTML_DIR=%{_gtkdocdir} \
187         pkgconfigdir=%{_pkgconfigdir}
188
189 rm $RPM_BUILD_ROOT%{_libdir}/%{name}-%{apiver}/{camel-providers,extensions}/*.{la,a}
190
191 install -d $RPM_BUILD_ROOT%{schemadir}
192 install addressbook/backends/ldap/evolutionperson.schema $RPM_BUILD_ROOT%{schemadir}
193
194 [ -d $RPM_BUILD_ROOT%{_datadir}/locale/sr@latin ] || \
195         mv -f $RPM_BUILD_ROOT%{_datadir}/locale/sr@{Latn,latin}
196 %find_lang %{name} --all-name
197
198 %clean
199 rm -rf $RPM_BUILD_ROOT
200
201 %post
202 %scrollkeeper_update_post
203
204 %postun
205 %scrollkeeper_update_postun
206
207 %post   libs -p /sbin/ldconfig
208 %postun libs -p /sbin/ldconfig
209
210 %post -n openldap-schema-evolutionperson
211 %openldap_schema_register %{schemadir}/evolutionperson.schema
212 %service -q ldap restart
213
214 %postun -n openldap-schema-evolutionperson
215 if [ "$1" = "0" ]; then
216         %openldap_schema_unregister %{schemadir}/evolutionperson.schema
217         %service -q ldap restart
218 fi
219
220 %files -f %{name}.lang
221 %defattr(644,root,root,755)
222 %doc AUTHORS ChangeLog NEWS* README
223 %attr(755,root,root) %{_libdir}/camel-index-control-%{apiver}
224 %attr(755,root,root) %{_libdir}/camel-lock-helper-%{apiver}
225 %dir %{_libdir}/%{name}-%{apiver}
226 %dir %{_libdir}/%{name}-%{apiver}/camel-providers
227 %attr(755,root,root) %{_libdir}/evolution-data-server-%{basever}
228 %attr(755,root,root) %{_libdir}/%{name}-%{apiver}/camel-providers/*.so
229 %{_libdir}/%{name}-%{apiver}/camel-providers/*.urls
230 %dir %{_libdir}/%{name}-%{apiver}/extensions
231 %attr(755,root,root) %{_libdir}/%{name}-%{apiver}/extensions/*.so
232 %{_libdir}/bonobo/servers/*
233
234 %if %{with ldap}
235 %{_datadir}/%{name}-%{basever}/*.schema
236 %endif
237
238 %dir %{_datadir}/%{name}-%{basever}
239 %{_datadir}/%{name}-%{basever}/glade
240 %{_datadir}/%{name}-%{basever}/weather
241 %{_pixmapsdir}/%{name}
242
243 %files -n openldap-schema-evolutionperson
244 %defattr(644,root,root,755)
245 %{schemadir}/*.schema
246
247 %files libs
248 %defattr(644,root,root,755)
249 %attr(755,root,root) %{_libdir}/*.so.*.*
250 %{_datadir}/idl/%{name}-%{apiver}
251
252 %files devel
253 %defattr(644,root,root,755)
254 %attr(755,root,root) %{_libdir}/*.so
255 %{_libdir}/*.la
256 %{_includedir}/*
257 %{_pkgconfigdir}/*
258
259 %files static
260 %defattr(644,root,root,755)
261 %{_libdir}/*.a
262
263 %files apidocs
264 %defattr(644,root,root,755)
265 %{_gtkdocdir}/*
This page took 0.053263 seconds and 4 git commands to generate.