]> git.pld-linux.org Git - packages/evolution-data-server.git/blob - evolution-data-server.spec
- 1.7.92, updated deps
[packages/evolution-data-server.git] / evolution-data-server.spec
1 #
2 # todo:
3 # - system libical
4 #
5 # Conditional build:
6 %bcond_without  kerberos5       # build without kerberos5 support
7 %bcond_without  ldap            # build without ldap support
8 #
9 %define         basever         1.8
10 %define         apiver          1.2
11 Summary:        Evolution data server
12 Summary(pl):    Serwer danych Evolution
13 Name:           evolution-data-server
14 Version:        1.7.92
15 Release:        1
16 License:        GPL
17 Group:          Libraries
18 Source0:        http://ftp.gnome.org/pub/gnome/sources/evolution-data-server/1.7/%{name}-%{version}.tar.bz2
19 # Source0-md5:  e5cf9b7317b9b495e15b18586cacda6c
20 Patch0:         %{name}-workaround-cal-backend-leak.patch
21 Patch1:         %{name}-gcc4.patch
22 Patch2:         %{name}-as_needed-fix.patch
23 URL:            http://www.ximian.com/products/ximian_evolution/
24 BuildRequires:  ORBit2-devel >= 1:2.14.2
25 BuildRequires:  autoconf >= 2.52
26 BuildRequires:  automake
27 BuildRequires:  bison
28 BuildRequires:  db-devel
29 BuildRequires:  gnome-common >= 2.12.0
30 BuildRequires:  gnome-keyring-devel >= 0.5.2
31 %{?with_kerberos5:BuildRequires:        heimdal-devel >= 0.7}
32 BuildRequires:  intltool
33 BuildRequires:  libglade2-devel >= 1:2.6.0
34 BuildRequires:  libgnomeui-devel >= 2.15.91
35 BuildRequires:  libsoup-devel >= 2.2.96
36 BuildRequires:  libstdc++-devel
37 BuildRequires:  libtool
38 BuildRequires:  nspr-devel
39 BuildRequires:  nss-devel
40 %{?with_ldap:BuildRequires:     openldap-devel >= 2.3.0}
41 BuildRequires:  pkgconfig
42 BuildRequires:  rpmbuild(macros) >= 1.304
43 Requires(post,postun):  scrollkeeper
44 Requires:       %{name}-libs = %{version}-%{release}
45 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
46
47 %define         schemadir       /usr/share/openldap/schema
48
49 %description
50 The Evolution data server for the calendar and addressbook.
51
52 %description -l pl
53 Serwer danych Evolution dla kalendarza i ksi±¿ki adresowej.
54
55 %package -n openldap-schema-evolutionperson
56 Summary:        evolutionperson LDAP schema
57 Summary(pl):    Schemat LDAP evolutionperson
58 Group:          Networking/Daemons
59 Requires(post,postun):  sed >= 4.0
60 Requires:       openldap-servers
61
62 %description -n openldap-schema-evolutionperson
63 This package contains evolutionperson.schema for openldap server.
64
65 %description -n openldap-schema-evolutionperson -l pl
66 Ten pakiet zawiera evolutionperson.schema dla serwera openldap.
67
68 %package libs
69 Summary:        Evolution Data Server library
70 Summary(pl):    Biblioteka Evolution Data Server
71 Group:          Libraries
72 Requires:       libgnomeui >= 2.15.91
73 Requires:       libsoup >= 2.2.96
74
75 %description libs
76 This package contains Evolution Data Server library.
77
78 %description libs -l pl
79 Ten pakiet zawiera bibliotekê Evolution Data Server.
80
81 %package devel
82 Summary:        Evolution data server development files
83 Summary(pl):    Pliki programistyczne serwera danych evolution
84 Group:          Development/Libraries
85 Requires:       %{name}-libs = %{version}-%{release}
86 %{?with_kerberos5:Requires:     heimdal-devel >= 0.7}
87 # for all but libegroupwise
88 Requires:       GConf2-devel >= 2.14.0
89 Requires:       ORBit2-devel >= 1:2.14.2
90 Requires:       glib2-devel >= 1:2.12.1
91 Requires:       libgnomeui-devel >= 2.15.91
92 Requires:       libxml2-devel >= 1:2.6.26
93 # for libegroupwise
94 Requires:       libsoup-devel >= 2.2.96
95
96 %description devel
97 This package contains the files necessary to develop applications
98 using Evolution's data server libraries.
99
100 %description devel -l pl
101 Ten pakiet zawiera pliki potrzebne do tworzenia aplikacji
102 korzystaj±cych z bibliotek serwera danych Evolution.
103
104 %package static
105 Summary:        Evolution data server static libraries
106 Summary(pl):    Statyczne biblioteki serwera danych Evolution
107 Group:          Development/Libraries
108 Requires:       %{name}-devel = %{version}-%{release}
109
110 %description static
111 Evolution data server static libraries.
112
113 %description static -l pl
114 Statyczne biblioteki serwera danych Evolution.
115
116 %package apidocs
117 Summary:        e-d-s API documentation
118 Summary(pl):    Dokumentacja API e-d-s
119 Group:          Documentation
120 Requires:       gtk-doc-common
121
122 %description apidocs
123 e-d-s API documentation.
124
125 %description apidocs -l pl
126 Dokumentacja API e-d-s.
127
128 %prep
129 %setup -q
130 %patch0 -p1
131 %patch1 -p1
132 %patch2 -p1
133
134 %build
135 %{__glib_gettextize}
136 %{__intltoolize}
137 %{__libtoolize}
138 %{__aclocal}
139 %{__autoheader}
140 %{__autoconf}
141 %{__automake}
142
143 cd calendar/libical
144 %{__libtoolize}
145 %{__aclocal}
146 %{__autoheader}
147 %{__autoconf}
148 %{__automake}
149 cd ../..
150 %configure \
151         %{?with_kerberos5:--with-krb5=%{_prefix}} \
152         %{!?with_kerberos5:--with-krb5=no} \
153         %{?with_ldap:--with-openldap=yes} \
154         %{!?with_ldap:--with-openldap=no} \
155         --enable-gnome-keyring=yes \
156         --enable-gtk-doc \
157         --enable-static \
158         --with-nspr-includes=%{_includedir}/nspr \
159         --with-nspr-libs=%{_libdir} \
160         --with-nss-includes=%{_includedir}/nss \
161         --with-nss-libs=%{_libdir} \
162         --with-libdb=%{_libdir}
163         
164 %{__make} \
165         HTML_DIR=%{_gtkdocdir} \
166         GTKHTML_DATADIR=%{_datadir}/idl
167
168 %install
169 rm -rf $RPM_BUILD_ROOT
170
171 %{__make} install \
172         DESTDIR=$RPM_BUILD_ROOT \
173         GTKHTML_DATADIR=%{_datadir}/idl \
174         HTML_DIR=%{_gtkdocdir} \
175         pkgconfigdir=%{_pkgconfigdir}
176
177 rm $RPM_BUILD_ROOT%{_libdir}/%{name}-%{apiver}/{camel-providers,extensions}/*.{la,a}
178
179 install -d $RPM_BUILD_ROOT%{schemadir}
180 install addressbook/backends/ldap/evolutionperson.schema $RPM_BUILD_ROOT%{schemadir}
181
182 %find_lang %{name} --all-name
183
184 %clean
185 rm -rf $RPM_BUILD_ROOT
186
187 %post
188 %scrollkeeper_update_post
189
190 %postun
191 %scrollkeeper_update_postun
192
193 %post   libs -p /sbin/ldconfig
194 %postun libs -p /sbin/ldconfig
195
196 %post -n openldap-schema-evolutionperson
197 %openldap_schema_register %{schemadir}/evolutionperson.schema
198 %service -q ldap restart
199
200 %postun -n openldap-schema-evolutionperson
201 if [ "$1" = "0" ]; then
202         %openldap_schema_unregister %{schemadir}/evolutionperson.schema
203         %service -q ldap restart
204 fi
205
206 %files -f %{name}.lang
207 %defattr(644,root,root,755)
208 %doc AUTHORS ChangeLog NEWS* README
209 %attr(755,root,root) %{_libdir}/camel-index-control-%{apiver}
210 %attr(755,root,root) %{_libdir}/camel-lock-helper-%{apiver}
211 %dir %{_libdir}/%{name}-%{apiver}
212 %dir %{_libdir}/%{name}-%{apiver}/camel-providers
213 %attr(755,root,root) %{_libdir}/evolution-data-server-%{basever}
214 %attr(755,root,root) %{_libdir}/%{name}-%{apiver}/camel-providers/*.so
215 %{_libdir}/%{name}-%{apiver}/camel-providers/*.urls
216 %dir %{_libdir}/%{name}-%{apiver}/extensions
217 %attr(755,root,root) %{_libdir}/%{name}-%{apiver}/extensions/*.so
218 %{_libdir}/bonobo/servers/*
219
220 %if %{with ldap}
221 %{_datadir}/%{name}-%{basever}/*.schema
222 %endif
223
224 %dir %{_datadir}/%{name}-%{basever}
225 %{_datadir}/%{name}-%{basever}/glade
226 %{_datadir}/%{name}-%{basever}/weather
227 %{_datadir}/%{name}-%{basever}/zoneinfo
228 %{_pixmapsdir}/%{name}-%{basever}
229
230 %files -n openldap-schema-evolutionperson
231 %defattr(644,root,root,755)
232 %{schemadir}/*.schema
233
234 %files libs
235 %defattr(644,root,root,755)
236 %attr(755,root,root) %{_libdir}/*.so.*.*
237 %{_datadir}/idl/%{name}-%{apiver}
238
239 %files devel
240 %defattr(644,root,root,755)
241 %attr(755,root,root) %{_libdir}/*.so
242 %{_libdir}/*.la
243 %{_includedir}/*
244 %{_pkgconfigdir}/*
245
246 %files static
247 %defattr(644,root,root,755)
248 %{_libdir}/*.a
249
250 %files apidocs
251 %defattr(644,root,root,755)
252 %{_gtkdocdir}/*
This page took 0.043304 seconds and 4 git commands to generate.