]> git.pld-linux.org Git - packages/evolution-data-server.git/blob - evolution-data-server.spec
- release 2 for kill libpng12.la deps.
[packages/evolution-data-server.git] / evolution-data-server.spec
1 #
2 # todo:
3 # - system libical
4 #
5 # Conditional build:
6 %bcond_without  kerberos5       # build without kerberos5 support
7 %bcond_without  ldap            # build without ldap support
8 #
9 %define         basever         1.8
10 %define         apiver          1.2
11 Summary:        Evolution data server
12 Summary(pl):    Serwer danych Evolution
13 Name:           evolution-data-server
14 Version:        1.7.3
15 Release:        2
16 License:        GPL
17 Group:          Libraries
18 Source0:        http://ftp.gnome.org/pub/gnome/sources/evolution-data-server/1.7/%{name}-%{version}.tar.bz2
19 # Source0-md5:  8d1134598c1cefa669ecd42a85e3cd56
20 Patch0:         %{name}-GG-IM.patch
21 Patch1:         %{name}-workaround-cal-backend-leak.patch
22 Patch2:         %{name}-gcc4.patch
23 Patch3:         %{name}-no_libdb_la.patch
24 URL:            http://www.ximian.com/products/ximian_evolution/
25 BuildRequires:  ORBit2-devel >= 1:2.14.0
26 BuildRequires:  autoconf >= 2.52
27 BuildRequires:  automake
28 BuildRequires:  bison
29 BuildRequires:  db-devel
30 BuildRequires:  gnome-common >= 2.12.0
31 BuildRequires:  gnome-keyring-devel >= 0.5.1
32 %{?with_kerberos5:BuildRequires:        heimdal-devel >= 0.7}
33 BuildRequires:  intltool
34 BuildRequires:  libglade2-devel >= 1:2.5.1
35 BuildRequires:  libgnomeui-devel >= 2.15.1
36 BuildRequires:  libsoup-devel >= 2.2.94
37 BuildRequires:  libstdc++-devel
38 BuildRequires:  libtool
39 BuildRequires:  nspr-devel
40 BuildRequires:  nss-devel
41 %{?with_ldap:BuildRequires:     openldap-devel >= 2.3.0}
42 BuildRequires:  pkgconfig
43 BuildRequires:  rpmbuild(macros) >= 1.304
44 Requires(post,postun):  scrollkeeper
45 Requires:       %{name}-libs = %{version}-%{release}
46 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
47
48 %define         schemadir       /usr/share/openldap/schema
49
50 %description
51 The Evolution data server for the calendar and addressbook.
52
53 %description -l pl
54 Serwer danych Evolution dla kalendarza i ksi±¿ki adresowej.
55
56 %package -n openldap-schema-evolutionperson
57 Summary:        evolutionperson LDAP schema
58 Summary(pl):    Schemat LDAP evolutionperson
59 Group:          Networking/Daemons
60 Requires(post,postun):  sed >= 4.0
61 Requires:       openldap-servers
62
63 %description -n openldap-schema-evolutionperson
64 This package contains evolutionperson.schema for openldap server.
65
66 %description -n openldap-schema-evolutionperson -l pl
67 Ten pakiet zawiera evolutionperson.schema dla serwera openldap.
68
69 %package libs
70 Summary:        Evolution Data Server library
71 Summary(pl):    Biblioteka Evolution Data Server
72 Group:          Libraries
73 Requires:       libgnomeui >= 2.15.1
74 Requires:       libsoup >= 2.2.94
75
76 %description libs
77 This package contains Evolution Data Server library.
78
79 %description libs -l pl
80 Ten pakiet zawiera bibliotekê Evolution Data Server.
81
82 %package devel
83 Summary:        Evolution data server development files
84 Summary(pl):    Pliki programistyczne serwera danych evolution
85 Group:          Development/Libraries
86 Requires:       %{name}-libs = %{version}-%{release}
87 %{?with_kerberos5:Requires:     heimdal-devel >= 0.7}
88 # for all but libegroupwise
89 Requires:       GConf2-devel >= 2.14.0
90 Requires:       ORBit2-devel >= 1:2.14.0
91 Requires:       glib2-devel >= 1:2.11.3
92 Requires:       libgnomeui-devel >= 2.15.1
93 Requires:       libxml2-devel >= 1:2.6.26
94 # for libegroupwise
95 Requires:       libsoup-devel >= 2.2.94
96
97 %description devel
98 This package contains the files necessary to develop applications
99 using Evolution's data server libraries.
100
101 %description devel -l pl
102 Ten pakiet zawiera pliki potrzebne do tworzenia aplikacji
103 korzystaj±cych z bibliotek serwera danych Evolution.
104
105 %package static
106 Summary:        Evolution data server static libraries
107 Summary(pl):    Statyczne biblioteki serwera danych Evolution
108 Group:          Development/Libraries
109 Requires:       %{name}-devel = %{version}-%{release}
110
111 %description static
112 Evolution data server static libraries.
113
114 %description static -l pl
115 Statyczne biblioteki serwera danych Evolution.
116
117 %prep
118 %setup -q
119 %patch0 -p1
120 %patch1 -p1
121 %patch2 -p1
122 %patch3 -p1
123
124 %build
125 %{__glib_gettextize}
126 %{__intltoolize}
127 %{__libtoolize}
128 %{__aclocal}
129 %{__autoheader}
130 %{__autoconf}
131 %{__automake}
132
133 cd calendar/libical
134 %{__libtoolize}
135 %{__aclocal}
136 %{__autoheader}
137 %{__autoconf}
138 %{__automake}
139 cd ../..
140
141 %configure \
142         %{?with_kerberos5:--with-krb5=%{_prefix}} \
143         %{!?with_kerberos5:--with-krb5=no} \
144         %{?with_ldap:--with-openldap=yes} \
145         %{!?with_ldap:--with-openldap=no} \
146         --enable-gnome-keyring=yes \
147         --enable-gtk-doc \
148         --enable-static \
149         --with-nspr-includes=%{_includedir}/nspr \
150         --with-nspr-libs=%{_libdir} \
151         --with-nss-includes=%{_includedir}/nss \
152         --with-nss-libs=%{_libdir} \
153         --with-libdb=%{_libdir}
154         
155 %{__make} \
156         HTML_DIR=%{_gtkdocdir} \
157         GTKHTML_DATADIR=%{_datadir}/idl
158
159 %install
160 rm -rf $RPM_BUILD_ROOT
161
162 %{__make} install \
163         DESTDIR=$RPM_BUILD_ROOT \
164         GTKHTML_DATADIR=%{_datadir}/idl \
165         HTML_DIR=%{_gtkdocdir} \
166         pkgconfigdir=%{_pkgconfigdir}
167
168 rm $RPM_BUILD_ROOT%{_libdir}/%{name}-%{apiver}/{camel-providers,extensions}/*.{la,a}
169
170 install -d $RPM_BUILD_ROOT%{schemadir}
171 install addressbook/backends/ldap/evolutionperson.schema $RPM_BUILD_ROOT%{schemadir}
172
173 %find_lang %{name} --all-name
174
175 %clean
176 rm -rf $RPM_BUILD_ROOT
177
178 %post
179 %scrollkeeper_update_post
180
181 %postun
182 %scrollkeeper_update_postun
183
184 %post   libs -p /sbin/ldconfig
185 %postun libs -p /sbin/ldconfig
186
187 %post -n openldap-schema-evolutionperson
188 %openldap_schema_register %{schemadir}/evolutionperson.schema
189 %service -q ldap restart
190
191 %postun -n openldap-schema-evolutionperson
192 if [ "$1" = "0" ]; then
193         %openldap_schema_unregister %{schemadir}/evolutionperson.schema
194         %service -q ldap restart
195 fi
196
197 %files -f %{name}.lang
198 %defattr(644,root,root,755)
199 %doc AUTHORS ChangeLog NEWS* README
200 %attr(755,root,root) %{_libdir}/camel-index-control-%{apiver}
201 %attr(755,root,root) %{_libdir}/camel-lock-helper-%{apiver}
202 %dir %{_libdir}/%{name}-%{apiver}
203 %dir %{_libdir}/%{name}-%{apiver}/camel-providers
204 %attr(755,root,root) %{_libdir}/evolution-data-server-%{basever}
205 %attr(755,root,root) %{_libdir}/%{name}-%{apiver}/camel-providers/*.so
206 %{_libdir}/%{name}-%{apiver}/camel-providers/*.urls
207 %dir %{_libdir}/%{name}-%{apiver}/extensions
208 %attr(755,root,root) %{_libdir}/%{name}-%{apiver}/extensions/*.so
209 %{_libdir}/bonobo/servers/*
210
211 %if %{with ldap}
212 %{_datadir}/%{name}-%{basever}/*.schema
213 %endif
214
215 %dir %{_datadir}/%{name}-%{basever}
216 %{_datadir}/%{name}-%{basever}/glade
217 %{_datadir}/%{name}-%{basever}/weather
218 %{_datadir}/%{name}-%{basever}/zoneinfo
219 %{_pixmapsdir}/%{name}-%{basever}
220
221 %files -n openldap-schema-evolutionperson
222 %defattr(644,root,root,755)
223 %{schemadir}/*.schema
224
225 %files libs
226 %defattr(644,root,root,755)
227 %attr(755,root,root) %{_libdir}/*.so.*.*
228 %{_datadir}/idl/%{name}-%{apiver}
229
230 %files devel
231 %defattr(644,root,root,755)
232 %attr(755,root,root) %{_libdir}/*.so
233 %{_libdir}/*.la
234 %{_includedir}/*
235 %{_pkgconfigdir}/*
236 %{_gtkdocdir}/*
237
238 %files static
239 %defattr(644,root,root,755)
240 %{_libdir}/*.a
This page took 0.059205 seconds and 4 git commands to generate.