]> git.pld-linux.org Git - packages/enblend-enfuse.git/blob - enblend-enfuse.spec
- fix building with gcc11 c++, rel 4
[packages/enblend-enfuse.git] / enblend-enfuse.spec
1 # NOTE: g++ eats 700+MB of memory
2 #
3 # Conditional build:
4 %bcond_with     openmp          # OpenMP support (incompatible with image-cache)
5 %bcond_without  tcmalloc        # use of Google TCMalloc library
6 #
7 Summary:        Image blending with multiresolution splines
8 Summary(pl.UTF-8):      Łączenie zdjęć przy użyciu splajnów wielokrotnej rozdzielczości
9 Name:           enblend-enfuse
10 Version:        4.2
11 Release:        4
12 License:        GPL v2+
13 Group:          Applications/Graphics
14 Source0:        http://downloads.sourceforge.net/enblend/%{name}-%{version}.tar.gz
15 # Source0-md5:  e26751f393862cecfd1a113003787001
16 Patch0:         gcc11.patch
17 URL:            http://enblend.sourceforge.net/
18 BuildRequires:  OpenEXR-devel >= 1.0
19 BuildRequires:  OpenGL-GLU-devel
20 BuildRequires:  OpenGL-glut-devel
21 BuildRequires:  autoconf >= 2.59
22 BuildRequires:  automake
23 BuildRequires:  boost-devel >= 1.55
24 %{?with_openmp:BuildRequires:   gcc-c++ >= 6:4.2}
25 BuildRequires:  glew-devel
26 BuildRequires:  gnuplot
27 BuildRequires:  gsl-devel
28 BuildRequires:  help2man
29 BuildRequires:  lcms2-devel >= 2
30 %{?with_openmp:BuildRequires:   libgomp-devel}
31 BuildRequires:  libjpeg-devel
32 BuildRequires:  libpng-devel
33 BuildRequires:  libstdc++-devel >= 5:4.3
34 %{?with_tcmalloc:BuildRequires: libtcmalloc-devel}
35 BuildRequires:  libtiff-devel
36 BuildRequires:  perl-TimeDate
37 BuildRequires:  perl-base
38 BuildRequires:  pkgconfig
39 BuildRequires:  texinfo
40 BuildRequires:  tidy
41 BuildRequires:  transfig
42 BuildRequires:  vigra-devel >= 1.8
43 BuildRequires:  zlib-devel
44 Requires:       vigra >= 1.8
45 Provides:       enblend = %{version}
46 Obsoletes:      enblend
47 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
48
49 %description
50 Enblend is a tool for compositing images. Given a set of images that
51 overlap in some irregular way, Enblend overlays them in such a way
52 that the seam between the images is invisible, or at least very
53 difficult to see. Enblend does not line up the images for you. Use a
54 tool like Hugin to do that.
55
56 %description -l pl.UTF-8
57 Enblend to narzędzie do łączenia zdjęć. Po przekazaniu zbioru zdjęć
58 nachodzących na siebie w jakiś nieregularny sposób Enblend nakłada je
59 w taki sposób, że połączenia między zdjęciami są niewidoczne, albo
60 przynajmniej bardzo trudne do zobaczenia. Enblend nie wyrównuje zdjęć
61 - do tego można użyć narzędzia takiego jak Hugin.
62
63 %prep
64 %setup -q
65 %patch0 -p1
66
67 %build
68 export CXXFLAGS="%{rpmcxxflags} -std=gnu++14"
69 %configure \
70         %{?with_openmp:--enable-openmp --disable-image-cache}
71         %{!?with_tcmalloc:--without-tcmalloc}
72 %{__make}
73
74 %install
75 rm -rf $RPM_BUILD_ROOT
76
77 %{__make} install \
78         DESTDIR=$RPM_BUILD_ROOT
79
80 %clean
81 rm -rf $RPM_BUILD_ROOT
82
83 %post   -p /sbin/postshell
84 -/usr/sbin/fix-info-dir -c %{_infodir}
85
86 %postun -p /sbin/postshell
87 -/usr/sbin/fix-info-dir -c %{_infodir}
88
89 %files
90 %defattr(644,root,root,755)
91 %doc AUTHORS ChangeLog NEWS README
92 %attr(755,root,root) %{_bindir}/enblend
93 %attr(755,root,root) %{_bindir}/enfuse
94 %{_mandir}/man1/enblend.1*
95 %{_mandir}/man1/enfuse.1*
This page took 0.034243 seconds and 4 git commands to generate.