]> git.pld-linux.org Git - packages/embree.git/blob - embree.spec
- x8664 only, har depends on SSE/AVX
[packages/embree.git] / embree.spec
1 Summary:        High Performance Ray Tracing Kernels
2 Name:           embree
3 Version:        3.13.3
4 Release:        1
5 License:        Apache v2.0
6 Group:          Libraries
7 Source0:        https://github.com/embree/embree/archive/v%{version}/%{name}-%{version}.tar.gz
8 # Source0-md5:  61aee19db0341a8353289043617975a7
9 URL:            https://www.embree.org/
10 BuildRequires:  OpenGL-devel
11 BuildRequires:  cmake
12 BuildRequires:  libjpeg-devel
13 BuildRequires:  tbb-devel
14 ExclusiveArch:  %{x8664}
15 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17 %description
18 Intel® Embree is a collection of high-performance ray tracing kernels,
19 developed at Intel. The target users of Intel® Embree are graphics
20 application engineers who want to improve the performance of their
21 photo-realistic rendering application by leveraging Embree's
22 performance-optimized ray tracing kernels. The kernels are optimized
23 for the latest Intel® processors with support for SSE, AVX, AVX2, and
24 AVX-512 instructions. Intel® Embree supports runtime code selection to
25 choose the traversal and build algorithms that best matches the
26 instruction set of your CPU. We recommend using Intel® Embree through
27 its API to get the highest benefit from future improvements.
28
29 %package devel
30 Summary:        Header files for %{name} library
31 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki %{name}
32 Group:          Development/Libraries
33 Requires:       %{name} = %{version}-%{release}
34
35 %description devel
36 Header files for %{name} library.
37
38 %description devel -l pl.UTF-8
39 Pliki nagłówkowe biblioteki %{name}.
40
41 %prep
42 %setup -q
43
44 %build
45 mkdir -p build
46 cd build
47 %cmake ../ \
48         -DEMBREE_MAX_ISA=SSE4.2 \
49         -DEMBREE_IGNORE_CMAKE_CXX_FLAGS=OFF \
50         -DCMAKE_CXX_STANDARD=17 \
51         -DEMBREE_ISPC_SUPPORT=OFF \
52         -DEMBREE_TUTORIALS=OFF
53
54 %{__make}
55
56 %install
57 rm -rf $RPM_BUILD_ROOT
58
59 %{__make} -C build install \
60         DESTDIR=$RPM_BUILD_ROOT
61
62 %clean
63 rm -rf $RPM_BUILD_ROOT
64
65 %post   -p /sbin/ldconfig
66 %postun -p /sbin/ldconfig
67
68 %files
69 %defattr(644,root,root,755)
70 %doc CHANGELOG.md README.md SECURITY.md
71 %attr(755,root,root) %{_libdir}/libembree3.so.*.*.*
72 %attr(755,root,root) %ghost %{_libdir}/libembree3.so.3
73
74 %files devel
75 %defattr(644,root,root,755)
76 %attr(755,root,root) %{_libdir}/libembree3.so
77 %{_includedir}/%{name}3
78 %{_libdir}/cmake/%{name}-%{version}
79 %{_mandir}/man3/*.3embree3*
This page took 0.159228 seconds and 4 git commands to generate.