]> git.pld-linux.org Git - packages/elfutils.git/commitdiff
upstream test fix
authorJan Palus <atler@pld-linux.org>
Wed, 17 Aug 2022 11:44:07 +0000 (13:44 +0200)
committerJan Palus <atler@pld-linux.org>
Wed, 17 Aug 2022 11:44:07 +0000 (13:44 +0200)
elfutils.spec
tests.patch [new file with mode: 0644]

index d99ffc3bf1fc1cd2b1d1bf4c54fab9e2387fe603..bc20761c7102f06ab0552d6bd5cb3b388d85142a 100644 (file)
@@ -19,6 +19,7 @@ Patch3:               %{name}-align.patch
 Patch4:                %{name}-paxflags.patch
 Patch5:                %{name}-sparc.patch
 Patch6:                disable-tests.patch
+Patch7:                tests.patch
 URL:           https://sourceware.org/elfutils/
 BuildRequires: autoconf >= 2.63
 BuildRequires: automake >= 1:1.11
@@ -194,6 +195,7 @@ Plik nagłówkowy biblioteki debuginfod.
 %patch4 -p1
 %patch5 -p1
 %patch6 -p1
+%patch7 -p1
 
 %{__rm} po/stamp-po
 
diff --git a/tests.patch b/tests.patch
new file mode 100644 (file)
index 0000000..02f6f41
--- /dev/null
@@ -0,0 +1,32 @@
+From b661e39349a89a47793c4d15e9ca8df016c3871b Mon Sep 17 00:00:00 2001
+From: Sergei Trofimovich via Elfutils-devel <elfutils-devel@sourceware.org>
+Date: Sat, 6 Aug 2022 09:55:06 +0100
+Subject: [PATCH] tests: run-low_high_pc.sh: drop redundant 'lx' suffix
+
+Noticed when debugged test failure:
+
+    lowpc: 8049000, highpc: 8049000lx
+    ../sysdeps/i386/crti.S: [2def] '_init' highpc <= lowpc
+
+Signed-off-by: Sergei Trofimovich <slyich@gmail.com>
+---
+ tests/ChangeLog     | 4 ++++
+ tests/low_high_pc.c | 2 +-
+ 2 files changed, 5 insertions(+), 1 deletion(-)
+
+diff --git a/tests/low_high_pc.c b/tests/low_high_pc.c
+index 78b6ad08d..cd022b1cc 100644
+--- a/tests/low_high_pc.c
++++ b/tests/low_high_pc.c
+@@ -72,7 +72,7 @@ handle_die (Dwarf_Die *die, void *arg)
+       && highpc <= lowpc
+       && ! (dwarf_tag (die) == DW_TAG_compile_unit && highpc == lowpc))
+     {
+-      printf("lowpc: %" PRIx64 ", highpc: %" PRIx64 "lx\n", lowpc, highpc);
++      printf("lowpc: %" PRIx64 ", highpc: %" PRIx64 "\n", lowpc, highpc);
+       fail (off, name, "highpc <= lowpc");
+     }
+-- 
+2.31.1
+
This page took 5.9889 seconds and 4 git commands to generate.