]> git.pld-linux.org Git - packages/elfutils.git/commitdiff
- up to 0.141
authorsparky <sparky@pld-linux.org>
Sat, 2 May 2009 13:13:38 +0000 (13:13 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    elfutils-Werror.patch -> 1.4
    elfutils-scanf.patch -> 1.2
    elfutils.spec -> 1.92

elfutils-Werror.patch
elfutils-scanf.patch
elfutils.spec

index 9d6c022446747579c97a47e9e800725d2debde5e..1d3bbe4c5a2bc9207d2cda2d0f428a94ec4e5987 100644 (file)
@@ -37,3 +37,15 @@ diff -Nur elfutils-0.127.org/tests/Makefile.am elfutils-0.127/tests/Makefile.am
             $(if $($(*F)_no_Wunused),,-Wunused $(WEXTRA)) \
             $(if $($(*F)_no_Wformat),-Wno-format,-Wformat=2) $(CFLAGS_$(*F))
  
+--- elfutils-0.141/libcpu/Makefile.am~ 2009-05-02 14:18:41.000000000 +0200
++++ elfutils-0.141/libcpu/Makefile.am  2009-05-02 15:01:39.000000000 +0200
+@@ -33,8 +33,7 @@
+ WEXTRA = @WEXTRA@
+ AM_CFLAGS += -Wall -Wshadow -Wunused $(WEXTRA) -std=gnu99 -fpic \
+            -fdollars-in-identifiers \
+-           $($(*F)_CFLAGS) \
+-           $(if $($(*F)_no_Werror),,-Werror)
++           $($(*F)_CFLAGS)
+ INCLUDES = -I$(srcdir) -I$(srcdir)/../lib -I$(srcdir)/../libelf \
+          -I$(srcdir)/../libebl -I$(srcdir)/../libdw -I$(srcdir)/../libasm
+ LEXCOMPILE = $(LEX) $(LFLAGS) $(AM_LFLAGS) -P$(<F:lex.l=)
index 8a98743a73fc8ce24531f7231e1ed95bc4b5b6c1..a8337d19add311f76b488336eb6dff650537d07d 100644 (file)
@@ -1,49 +1,28 @@
 --- elfutils-0.137/src/addr2line.c.orig        2008-08-09 06:06:44.000000000 +0200
 +++ elfutils-0.137/src/addr2line.c     2008-09-09 22:15:16.304992337 +0200
-@@ -374,8 +374,13 @@ handle_address (const char *string, Dwfl
+@@ -437,6 +437,12 @@
+   return false;
+ }
++#if (__GLIBC__ >= 2) && (__GLIBC_MINOR__ >= 7) && (__GNUC__ >= 4) && (__GNUC_MINOR__ >= 3)
++# define SCANF_ADDR "%m"
++#else
++# define SCANF_ADDR "%a"
++#endif
++
+ static int
+ handle_address (const char *string, Dwfl *dwfl)
+ {
+@@ -447,10 +453,10 @@
        bool parsed = false;
        int n;
        char *name = NULL;
-+#if (__GLIBC__ >= 2) && (__GLIBC_MINOR__ >= 7) && (__GNUC__ >= 4) && (__GNUC_MINOR__ >= 3)
-       if (sscanf (string, "(%m[^)])%" PRIiMAX "%n", &name, &addr, &n) == 2
+-      if (sscanf (string, "(%m[^)])%" PRIiMAX "%n", &name, &addr, &n) == 2
++      if (sscanf (string, "(" SCANF_ADDR "[^)])%" PRIiMAX "%n", &name, &addr, &n) == 2
          && string[n] == '\0')
-+#else
-+      if (sscanf (string, "(%a[^)])%" PRIiMAX "%n", &name, &addr, &n) == 2
-+        && string[n] == '\0')
-+#endif
-       {
-         /* It was (section)+offset.  This makes sense if there is
-            only one module to look in for a section.  */
-@@ -415,8 +420,13 @@ handle_address (const char *string, Dwfl
-               }
-           }
-       }
-+#if (__GLIBC__ >= 2) && (__GLIBC_MINOR__ >= 7) && (__GNUC__ >= 4) && (__GNUC_MINOR__ >= 3)
-       else if (sscanf (string, "%m[^-+]%" PRIiMAX "%n", &name, &addr, &n) == 2
+       parsed = adjust_to_section (name, &addr, dwfl);
+-      else if (sscanf (string, "%m[^-+]%" PRIiMAX "%n", &name, &addr, &n) == 2
++      else if (sscanf (string, SCANF_ADDR "[^-+]%" PRIiMAX "%n", &name, &addr, &n) == 2
               && string[n] == '\0')
-+#else
-+      else if (sscanf (string, "%a[^-+]%" PRIiMAX "%n", &name, &addr, &n) == 2
-+             && string[n] == '\0')
-+#endif
        {
          /* It was symbol+offset.  */
-         GElf_Sym sym;
---- elfutils-0.137/src/Makefile.am.orig        2008-09-09 21:30:37.592989823 +0200
-+++ elfutils-0.137/src/Makefile.am     2008-09-09 22:36:04.380988147 +0200
-@@ -35,7 +35,7 @@
- AM_CFLAGS += -Wall -Wshadow -std=gnu99 $(native_ld_cflags) \
-            $(if $($(*F)_no_Werror),,-Werror) \
-            $(if $($(*F)_no_Wunused),,-Wunused $(WEXTRA)) \
--           $(if $($(*F)_no_Wformat),,-Wformat=2) $(CFLAGS_$(*F))
-+           $(if $($(*F)_no_Wformat),-Wno-format,-Wformat=2) $(CFLAGS_$(*F))
- INCLUDES = -I$(srcdir) -I$(srcdir)/../libelf -I$(srcdir)/../libebl \
-          -I$(srcdir)/../libdw -I$(srcdir)/../libdwfl \
-@@ -109,6 +109,7 @@
- nm_no_Wformat = yes
- size_no_Wformat = yes
- strings_no_Wformat = yes
-+addr2line_no_Wformat = yes
- # XXX While the file is not finished, don't warn about this
- ldgeneric_no_Wunused = yes
index 0c795c74da3fdd77df8ed3e490e2b74ed0a1862b..28f66e943b212a03e9e9df2b3cd8b9dbb2c7b186 100644 (file)
@@ -5,12 +5,12 @@
 Summary:       A collection of utilities and DSOs to handle compiled objects
 Summary(pl.UTF-8):     Zestaw narzędzi i bibliotek do obsługi skompilowanych obiektów
 Name:          elfutils
-Version:       0.137
+Version:       0.141
 Release:       1
 License:       GPL v2 with OSL linking exception
 Group:         Development/Tools
-Source0:       https://fedorahosted.org/releases/e/l/elfutils/%{name}-%{version}.tar.gz
-# Source0-md5: a24690a64268516bd413c4c3fe6c6dd4
+Source0:       https://fedorahosted.org/releases/e/l/elfutils/%{name}-%{version}.tar.bz2
+# Source0-md5: 2d0fe5651c0de1fd28e7dd006effe7d1
 Patch0:                %{name}-pl.po.patch
 Patch1:                %{name}-debian-manpages.patch
 Patch2:                %{name}-portability.patch
@@ -20,7 +20,7 @@ Patch5:               %{name}-paxflags.patch
 Patch6:                %{name}-sparc.patch
 Patch7:                %{name}-inline.patch
 Patch8:                %{name}-Werror.patch
-Patch9:                %{name}-fixes.patch
+Patch9:                %{name}-bashism.patch
 Patch10:       %{name}-scanf.patch
 URL:           https://fedorahosted.org/elfutils/
 BuildRequires: autoconf >= 2.59
@@ -156,7 +156,7 @@ rm -f po/stamp-po
 
 %build
 #%%{__gettextize}
-%{__aclocal}
+%{__aclocal} -I m4
 %{__autoheader}
 %{__autoconf}
 %{__automake}
This page took 0.765205 seconds and 4 git commands to generate.