]> git.pld-linux.org Git - packages/ekg2.git/commitdiff
- rel 3; fix openssl build auto/th/ekg2-0.4-0.20180902.3
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Thu, 20 Sep 2018 18:47:53 +0000 (20:47 +0200)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Thu, 20 Sep 2018 18:47:53 +0000 (20:47 +0200)
ekg2.spec
openssl.patch [new file with mode: 0644]

index b96142cc7ab74847b348317f5570609c1994cc61..1761f63c023bf75589a5eb21a4a9b77143419646 100644 (file)
--- a/ekg2.spec
+++ b/ekg2.spec
@@ -23,7 +23,7 @@
 %define                subver 20180902
 %endif
 
-%define                rel 2
+%define                rel 3
 
 %if %{with sqlite}
 %undefine sqlite3
@@ -45,6 +45,7 @@ Patch0:               %{name}-perl-install.patch
 Patch1:                %{name}-gtk.patch
 Patch2:                %{name}-bug-63.patch
 Patch3:                %{name}-keepalive_irc.patch
+Patch4:                openssl.patch
 URL:           http://ekg2.org/
 %{?with_aspell:BuildRequires:  aspell-devel}
 BuildRequires: autoconf
@@ -336,6 +337,7 @@ git checkout FETCH_HEAD
 %patch3 -p1
 %endif
 
+%patch4 -p1
 
 touch po/Makefile.in.in
 find -name *.c > po/POTFILES.in
diff --git a/openssl.patch b/openssl.patch
new file mode 100644 (file)
index 0000000..8504dd9
--- /dev/null
@@ -0,0 +1,31 @@
+--- ekg2-20180902/plugins/sim/simlite.c~       2018-08-01 15:34:40.000000000 +0200
++++ ekg2-20180902/plugins/sim/simlite.c        2018-09-20 20:44:14.370347788 +0200
+@@ -185,7 +185,7 @@ char *sim_key_fingerprint(const char *ui
+       RSA *key = sim_key_read(uid, NULL);
+       unsigned char md_value[EVP_MAX_MD_SIZE], *buf, *newbuf;
+       char *result = NULL;
+-      EVP_MD_CTX ctx;
++      EVP_MD_CTX *ctx;
+       unsigned int md_len;
+       int size, i;
+@@ -208,10 +208,14 @@ char *sim_key_fingerprint(const char *ui
+               size = i2d_RSAPublicKey(key, &newbuf);
+       else
+               size = i2d_RSAPrivateKey(key, &newbuf);
+-      
+-      EVP_DigestInit(&ctx, EVP_sha1());       
+-      EVP_DigestUpdate(&ctx, buf, size);
+-      EVP_DigestFinal(&ctx, md_value, &md_len);
++
++      ctx = EVP_MD_CTX_create();
++      if (!ctx)
++              return NULL;
++      EVP_DigestInit(ctx, EVP_sha1());        
++      EVP_DigestUpdate(ctx, buf, size);
++      EVP_DigestFinal(ctx, md_value, &md_len);
++      EVP_MD_CTX_free(ctx);
+       free(buf);
+
This page took 0.050007 seconds and 4 git commands to generate.