]> git.pld-linux.org Git - packages/ekg.git/commitdiff
- reverted, should be on DEVEL
authorAdam Gołębiowski <adamg@pld-linux.org>
Wed, 26 Dec 2007 23:55:48 +0000 (23:55 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    ekg-LDFLAGS.patch -> 1.6
    ekg-external_libgadu.patch -> 1.3
    ekg-lock_reason.patch -> 1.3

ekg-LDFLAGS.patch
ekg-external_libgadu.patch
ekg-lock_reason.patch

index f9e9d6bc477a52feed604248f64c0bb466be7403..0613697ed36d9c328e41fe5c85533c492dabf761 100644 (file)
                fi
            else 
                enable_aspell=no
+--- lib/Makefile.in    2006-04-18 21:05:11.000000000 +0200
++++ lib/Makefile.in-new        2007-05-31 23:18:35.346799383 +0200
+@@ -12,7 +12,8 @@
+ CC = @CC@ 
+ CFLAGS = @CFLAGS_LIBGADU@ -I. -I..
+-LIBS = @LIBS_LIBGADU@
++LDFLAGS = @LDFLAGS@
++LIBS = @LIBS@ @LIBS_LIBGADU@
+ MAKE = @MAKE@
+ AR = @AR@
+@@ -56,7 +57,7 @@
+ shared:       dep $(SHARED)
+ $(SHARED): $(LOBJS)
+-      $(CC) -shared -Wl,-soname,libgadu.so.$(VERSION_MAJOR) -o $(SHARED) $(LOBJS) $(LIBS) -lc
++      $(CC) $(LDFLAGS) -shared -Wl,-soname,libgadu.so.$(VERSION_MAJOR) -o $(SHARED) $(LOBJS) $(LIBS) -lc
+       $(LN_S) -f $(SHARED) $(SHAREDM)
+       $(LN_S) -f $(SHARED) $(SHAREDMM)
 --- src/Makefile.in    2007-04-28 22:02:22.000000000 +0200
 +++ src/Makefile.in-new        2007-05-31 23:20:07.254747976 +0200
 @@ -28,10 +28,10 @@
  
- ekg:  $(OBJS) comptime.c
+ ekg:  $(OBJS) comptime.c @libgadu_a@
        $(CC) $(CFLAGS) -c -o comptime.o comptime.c
--      $(CC) $(CFLAGS) -o ekg $(OBJS) comptime.o $(LDFLAGS) $(LIBS)
-+      $(CC) $(LDFLAGS) $(CFLAGS) -o ekg $(OBJS) comptime.o $(LIBS)
+-      $(CC) $(CFLAGS) -o ekg $(OBJS) comptime.o -L../lib @lgadu@ @libgadu_a@ $(LDFLAGS) $(LIBS)
++      $(CC) $(LDFLAGS) $(CFLAGS) -o ekg $(OBJS) comptime.o -L../lib @lgadu@ @libgadu_a@ $(LIBS)
  
  ioctld:       ioctld.c
 -      $(CC) $(CFLAGS) ioctld.c -o ioctld $(LIBS) @IOCTLD_OBJS@
index 1bb72464b05915b75c34ac2f0df53f3deaa3f0b8..00548eb4f43caf4f45d44391a8658da6ff95b02c 100644 (file)
@@ -214,3 +214,79 @@ diff -Nur src.orig/xmalloc.c src/xmalloc.c
  
  void ekg_oom_handler()
  {
+--- src/Makefile.in    2007-06-20 10:30:09.886922984 +0200
++++ src/Makefile.in-new        2007-06-20 10:33:36.693827460 +0200
+@@ -28,7 +28,7 @@
+ ekg:  $(OBJS) comptime.c @libgadu_a@
+       $(CC) $(CFLAGS) -c -o comptime.o comptime.c
+-      $(CC) $(LDFLAGS) $(CFLAGS) -o ekg $(OBJS) comptime.o -L../lib @lgadu@ @libgadu_a@ $(LIBS)
++      $(CC) $(LDFLAGS) $(CFLAGS) -o ekg $(OBJS) comptime.o @lgadu@ @libgadu_a@ $(LIBS)
+ ioctld:       ioctld.c
+       $(CC) $(LDFLAGS) $(CFLAGS) ioctld.c -o ioctld $(LIBS) @IOCTLD_OBJS@
+--- Makefile.in        2006-08-05 17:46:21.000000000 +0200
++++ Makefile.in-new    2007-06-20 10:43:18.322620629 +0200
+@@ -15,10 +15,7 @@
+ #
+-all:  configure libgadu @ekg@ @make_ekgwap@
+-
+-libgadu:
+-      cd lib && $(MAKE) all
++all:  configure @ekg@ @make_ekgwap@
+ ekg:  
+       cd src && $(MAKE) all
+@@ -31,10 +28,7 @@
+ #
+-dep:  dep-libgadu @dep_ekg@
+-
+-dep-libgadu:
+-      cd lib && $(MAKE) dep
++dep:  @dep_ekg@
+ dep-ekg:
+       cd src && $(MAKE) dep
+@@ -46,10 +40,7 @@
+ #
+-install:      all install-libgadu @install_ekg@ @install_ekgwap@
+-
+-install-libgadu:
+-      cd lib && $(MAKE) install
++install:      all @install_ekg@ @install_ekgwap@
+ install-ekg:  install-ekg-data install-ekg-man
+       cd src && $(MAKE) install
+@@ -93,10 +84,7 @@
+ #
+-clean:        clean-libgadu @clean_ekg@ clean-examples clean-compat
+-
+-clean-libgadu:
+-      cd lib && $(MAKE) clean
++clean:        @clean_ekg@ clean-examples clean-compat
+ clean-ekg:
+       cd src && $(MAKE) clean
+@@ -109,13 +97,10 @@
+ #
+-distclean:    distclean-libgadu @distclean_ekg@ distclean-examples distclean-compat
++distclean:    @distclean_ekg@ distclean-examples distclean-compat
+       rm -f *~ config.log config.cache config.status config.h Makefile
+       rm -f config.h.in configure aclocal.m4
+-distclean-libgadu:
+-      cd lib && $(MAKE) distclean
+-
+ distclean-ekg:
+       cd src && $(MAKE) distclean
index 098e4ddcfb51c3d2e06f46ec22bc37c59270c806..8dd6b9d23b664437818449eda90f31db6a602cc9 100644 (file)
@@ -48,9 +48,9 @@ diff -burN ekg-1.6.orig/src/commands.c ekg-1.6/src/commands.c
  
 -                      if (config_reason) {
 +                      if (config_reason && !config_lock_reason) {
-                               iso_to_cp((unsigned char *) config_reason);
+                               iso_to_cp(config_reason);
                                gg_change_status_descr(sess, config_status, config_reason);
-                               cp_to_iso((unsigned char *) config_reason);
+                               cp_to_iso(config_reason);
 diff -burN ekg-1.6.orig/src/stuff.c ekg-1.6/src/stuff.c
 --- ekg-1.6.orig/src/stuff.c   2006-08-18 00:20:55.000000000 +0200
 +++ ekg-1.6/src/stuff.c        2006-08-18 00:35:53.000000000 +0200
This page took 0.117117 seconds and 4 git commands to generate.