]> git.pld-linux.org Git - packages/ekg.git/blob - ekg.spec
c072c3c0860a371a34478930a66e758884e9360b
[packages/ekg.git] / ekg.spec
1 #
2 # Conditional build:
3 %bcond_without  aspell          # without spell checking
4 %bcond_without  voip            # without VoIP support
5 %bcond_without  python          # with python support
6 %bcond_without  pthread         # build with Posix threads support
7 %bcond_with     ioctl_daemon    # with ioctl_daemon (suid root)
8 %bcond_with     lock_reason     # with lock_reason patch
9 #
10 Summary:        A client compatible with Gadu-Gadu
11 Summary(de.UTF-8):      Ein Cliente kompatibel mit Gadu-Gadu
12 Summary(es.UTF-8):      Un cliente compatible con Gadu-Gadu
13 Summary(it.UTF-8):      Un cliente compatibile con Gadu-Gadu
14 Summary(pl.UTF-8):      Klient kompatybilny z Gadu-Gadu
15 Name:           ekg
16 Version:        1.7
17 Release:        16
18 Epoch:          4
19 License:        GPL v2
20 Group:          Applications/Communications
21 Source0:        http://ekg.chmurka.net/%{name}-%{version}.tar.gz
22 # Source0-md5:  2aa92b56517fdf09d75519a105772b74
23 Source1:        %{name}.conf
24 Patch0:         %{name}-LDFLAGS.patch
25 Patch1:         %{name}-lock_reason.patch
26 Patch2:         %{name}-external_libgadu.patch
27 Patch3:         %{name}-giflib.patch
28 Patch4:         %{name}-openssl.patch
29 URL:            http://ekg.chmurka.net/
30 BuildRequires:  %{_bindir}/perl
31 %{?with_aspell:BuildRequires:   aspell-devel}
32 BuildRequires:  autoconf
33 BuildRequires:  automake
34 BuildRequires:  giflib-devel >= 5.1
35 BuildRequires:  libgadu-devel >= 4:1.7.0
36 %{?with_voip:BuildRequires:     libgsm-devel}
37 BuildRequires:  libjpeg-devel
38 BuildRequires:  ncurses-devel
39 BuildRequires:  openssl-devel >= 0.9.7d
40 BuildRequires:  pkgconfig
41 %if %{with python}
42 BuildRequires:  python
43 BuildRequires:  python-devel
44 BuildRequires:  python-modules
45 %endif
46 BuildRequires:  readline-devel
47 BuildRequires:  zlib-devel
48 Requires:       libgadu >= 4:1.7.0
49 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
50
51 %description
52 EKG ("Eksperymentalny Klient Gadu-Gadu") is an open source gadu-gadu
53 client for UNIX systems. Gadu-Gadu is an instant messaging program,
54 very popular in Poland.
55
56 EKG features include:
57   - irssi-like ncurses interface
58   - sending and receiving files
59   - voice conversations
60   - launching shell commands on certain events
61   - reading input from pipe
62   - python scripting support
63   - speech synthesis (using an external program)
64   - encryption support
65
66 Please note that the program is not internationalized and all messages
67 are in Polish (although the commands are in English).
68
69 %description -l de.UTF-8
70 Ein Cliente kompatibel mit Gadu-Gadu.
71
72 %description -l es.UTF-8
73 Un cliente compatible con Gadu-Gadu.
74
75 %description -l it.UTF-8
76 Un cliente compatibile con Gadu-Gadu.
77
78 %description -l pl.UTF-8
79 EKG ("Eksperymentalny Klient Gadu-Gadu") jest open source'owym
80 klientem gadu-gadu dla systemów uniksowych. Gadu-Gadu to popularny w
81 Polsce komunikator internetowy.
82
83 Możliwości EKG:
84   - interfejs użytkownika podobny do irssi,
85   - wysyłanie i odbieranie plików,
86   - rozmowy głosowe,
87   - uruchamianie poleceń powłoki w określonych sytuacjach,
88   - wczytywanie wejścia z potoku,
89   - wsparcie dla skryptów w języku Python,
90   - synteza mowy (z użyciem zewnętrznego programu),
91   - wsparcie dla szyfrowania.
92
93 Program nie jest umiędzynarodowiony i wszystkie komunikaty są po
94 polsku (jednak komendy są w języku angielskim).
95
96 %prep
97 %setup -q
98 %patch0 -p0
99 %if %{with lock_reason}
100 %patch1 -p1
101 %endif
102 %patch2 -p0
103 %patch3 -p1
104 %patch4 -p1
105
106 %build
107 %{__aclocal} -I m4
108 %{__autoheader}
109 %{__autoconf}
110 %configure \
111         CFLAGS_LIBGADU="%{rpmcflags}" \
112         --enable-dynamic \
113         --enable-shared \
114         --enable-static \
115 %if %{with pthread}
116         --with-pthread \
117 %else
118         --without-pthread \
119 %endif
120         --without-bind \
121         %{?with_python:--with-python} \
122         %{!?with_voip:--without-libgsm} \
123         %{?with_aspell:--enable-aspell} \
124         %{?with_ioctl_daemon:--enable-ioctld}
125
126 %{__make}
127
128 %if %{with ioctl_daemon}
129 %{__make} -C src ioctld
130 %endif
131
132 %install
133 rm -rf $RPM_BUILD_ROOT
134 install -d $RPM_BUILD_ROOT%{_sysconfdir}
135
136 %{__make} install install-ekl2 \
137         DESTDIR=$RPM_BUILD_ROOT
138
139 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}
140
141 # For libgadu-devel
142
143 rm -f examples/Makefile examples/Makefile.in examples/.cvsignore
144 rm -rf examples/CVS
145
146 %if %{with ioctl_daemon}
147 install src/ioctld $RPM_BUILD_ROOT%{_bindir}
148 %endif
149
150 %clean
151 rm -rf $RPM_BUILD_ROOT
152
153 %files
154 %defattr(644,root,root,755)
155 %doc docs/{7thguard,dcc,files,gdb,python,sim,themes,ui-ncurses,vars,voip}.txt
156 %{?with_aspell:%doc docs/slownik.txt}
157 %doc ChangeLog docs/{FAQ,README,TODO,ULOTKA} docs/emoticons.{ansi,sample}
158 %attr(755,root,root) %{_bindir}/e*
159 %{?with_ioctl_daemon:%attr(4755,root,root) %{_bindir}/ioctld}
160 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*.conf
161 %{_datadir}/ekg
162 %{_mandir}/man1/*
163 %lang(pl) %{_mandir}/pl/man1/*
This page took 0.114 seconds and 2 git commands to generate.