]> git.pld-linux.org Git - packages/eigen.git/blob - eigen.spec
- x32 rebuild
[packages/eigen.git] / eigen.spec
1 Summary:        Template library for linear algebra
2 Summary(pl.UTF-8):      Biblioteka szablonów do algebry liniowej
3 Name:           eigen
4 Version:        2.0.17
5 Release:        2
6 Epoch:          1
7 License:        LGPL v3+ or GPL v2+
8 Group:          Development/Libraries
9 Source0:        http://bitbucket.org/eigen/eigen/get/%{version}.tar.bz2
10 # Source0-md5:  2dfd1e2765d82c306adbfcd6a0eb324b
11 URL:            http://eigen.tuxfamily.org/
12 BuildRequires:  cmake >= 2.6.2
13 BuildRequires:  rpmbuild(macros) >= 1.577
14 Requires:       libstdc++-devel
15 Obsoletes:      eigen-devel
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %description
19 Eigen is a C++ template library for linear algebra: vectors, matrices,
20 and related algorithms. It is versatile, fast, elegant and
21 compiler-friendly.
22
23 Eigen handles, without code duplication and in a completely integrated
24 way:
25  - both fixed-size and dynamic-size matrices and vectors
26  - both dense and sparse (the latter is still experimental) matrices
27    and vectors
28  - both plain matrices/vectors and abstract expressions
29  - both column-major (the default) and row-major matrix storage
30  - both basic matrix/vector manipulation and many more advanced,
31    specialized modules providing algorithms for linear algebra,
32    geometry, quaternions, or advanced array manipulation.
33
34 %description -l pl.UTF-8
35 Eigen to biblioteka szablonów C++ do algebry liniowej: wektorów,
36 macierzy i związanych z nimi algorytmów. Jest elastyczna, szybka,
37 elegancka i przyjazna dla kompilatorów.
38
39 Obsługuje bez powielania kodu i w całkowicie zintegrowany sposób:
40  - macierze i wektory o stałym i dynamicznym rozmiarze
41  - macierze i wektory gęste i rzadkie (te drugie jeszcze
42    eksperymentalnie)
43  - zwykłe macierze/wektory jak i abstrakcyjne wyrażenia
44  - przechowywanie danych kolumnowe (domyślne) oraz wierszowe
45  - podstawowe operacje na macierzach/wektorach, jak i wiele
46    bardziej zaawansowanych, specjalizowanych modułów z algorytmami
47    algebry liniowej, geometrii, kwaternionów i zaawansowanych operacji
48    na tablicach.
49
50 %prep
51 %setup -q -n eigen-eigen-b23437e61a07
52
53 %build
54 install -d build
55 cd build
56 %cmake .. \
57         -DCMAKE_CXX_COMPILER_WORKS=1 \
58         -DCMAKE_CXX_COMPILER="%{__cc}"
59
60 %{__make}
61
62 %install
63 rm -rf $RPM_BUILD_ROOT
64
65 %{__make} -C build install \
66         DESTDIR=$RPM_BUILD_ROOT
67
68 %clean
69 rm -rf $RPM_BUILD_ROOT
70
71 %files
72 %defattr(644,root,root,755)
73 %{_includedir}/eigen2
74 %{_npkgconfigdir}/eigen2.pc
This page took 0.05971 seconds and 3 git commands to generate.