]> git.pld-linux.org Git - packages/ebtables.git/blob - ebtables.spec
- fixed usage for sh
[packages/ebtables.git] / ebtables.spec
1 %define         ver     2.0.10
2 %define         vermin  4
3 Summary:        Ethernet Bridge Tables
4 Summary(pl.UTF-8):      Ethernet Bridge Tables - filtrowanie i translacja adresów dla Ethernetu
5 Name:           ebtables
6 Version:        %{ver}.%{vermin}
7 Release:        5
8 License:        GPL v2+
9 Group:          Networking/Daemons
10 Source0:        http://downloads.sourceforge.net/ebtables/%{name}-v%{ver}-%{vermin}.tar.gz
11 # Source0-md5:  506742a3d44b9925955425a659c1a8d0
12 Source1:        %{name}.init
13 Source2:        %{name}-config
14 Patch0:         ebtables-audit.patch
15 Patch1:         ebtables-linkfix.patch
16 Patch2:         ebtables-norootinst.patch
17 Patch3:         ipv6_netmask_printing_fix.patch
18 URL:            http://ebtables.sourceforge.net/
19 BuildRequires:  rpmbuild(macros) >= 1.268
20 Requires(post,preun):   /sbin/chkconfig
21 Requires:       rc-scripts
22 Obsoletes:      iptables-ebtables
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 The ebtables project is the Linux 2.5.x (and above) Link Layer
27 firewalling subsystem, a patch for 2.4.x is maintained too. It
28 delivers for Linux the functionality of Ethernet frame filtering, all
29 kinds of frame NAT (Network Address Translation) and frame matching.
30 The ebtables infrastructure is a part of the standard Linux 2.5.x (and
31 above) kernels.
32
33 %description -l pl.UTF-8
34 Projekt ebtables to podsystem firewallingu na poziomie łącza dla
35 Linuksa w wersjach 2.5.x i nowszych (dostępna jest też łata do 2.4.x).
36 Dostarcza dla Linuksa funkcjonalność filtrowania ramek ethernetowych,
37 wszystkie rodzaje translacji adresów (NAT) dla ramek oraz
38 dopasowywanie ramek. Infrastruktura ebtables jest częścią
39 standardowych jąder Linuksa w wersjach 2.5.x i nowszych.
40
41 %prep
42 %setup -q -n %{name}-v%{ver}-%{vermin}
43 %patch0 -p1
44 %patch1 -p1
45 %patch2 -p1
46 %patch3 -p1
47
48 %build
49 %{__make} \
50         CC="%{__cc}" \
51         CFLAGS="%{rpmcflags}" \
52         LIBDIR="%{_libdir}/ebtables" \
53         BINDIR="%{_sbindir}" \
54         MANDIR="%{_mandir}"
55
56 %install
57 rm -rf $RPM_BUILD_ROOT
58 install -d $RPM_BUILD_ROOT{/etc/sysconfig,/etc/rc.d/init.d,%{_sysconfdir}} \
59         $RPM_BUILD_ROOT{%{_sbindir},%{_libdir}/ebtables,%{_mandir}/man8}
60
61 install ebtables{,-restore,-save}       $RPM_BUILD_ROOT%{_sbindir}
62 install ethertypes              $RPM_BUILD_ROOT%{_sysconfdir}
63 install ebtables.8              $RPM_BUILD_ROOT%{_mandir}/man8
64 install extensions/*.so *.so    $RPM_BUILD_ROOT%{_libdir}/ebtables
65 %{__sed} -i -e "s|__EXEC_PATH__|%{_sbindir}|g" $RPM_BUILD_ROOT%{_sbindir}/ebtables-save
66
67 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/ebtables
68 install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/ebtables-config
69
70 %clean
71 rm -rf $RPM_BUILD_ROOT
72
73 %post
74 /sbin/chkconfig --add ebtables
75
76 %preun
77 if [ $1 -eq 0 ]; then
78         %service ebtables stop
79         /sbin/chkconfig --del ebtables
80 fi
81
82 %files
83 %defattr(644,root,root,755)
84 %doc ChangeLog INSTALL THANKS
85 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ethertypes
86 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/ebtables-config
87 %attr(754,root,root) /etc/rc.d/init.d/ebtables
88 %attr(755,root,root) %{_sbindir}/ebtables
89 %attr(755,root,root) %{_sbindir}/ebtables-restore
90 %attr(755,root,root) %{_sbindir}/ebtables-save
91 %dir %{_libdir}/ebtables
92 %attr(755,root,root) %{_libdir}/ebtables/libebt*.so
93 %{_mandir}/man8/ebtables.8*
This page took 0.065749 seconds and 4 git commands to generate.