]> git.pld-linux.org Git - packages/dtc.git/blob - dtc.spec
- up to 1.2.0
[packages/dtc.git] / dtc.spec
1 # Conditional build:
2 %bcond_without  verbose         # verbose build (V=1)
3
4 Summary:        The Device Tree Compiler
5 Summary(pl.UTF-8): Kompilator drzewiastej struktury urządzeń
6 Name:           dtc
7 Version:        1.2.0
8 Release:        0.1
9 License:        GPL v2 (dtc), GPL/BSD (fdt library)
10 Group:          Libraries
11 Source0:        http://www.jdl.com/software/%{name}-v%{version}.tgz
12 # Source0-md5:  0f1841de79abbff57691adc31d5f3525
13 URL:            http://git.jdl.com/gitweb/
14 BuildRequires:  bison
15 BuildRequires:  flex
16 Requires:       %{name}-doc = %{version}-%{release}
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %{?debug:%define with_verbose 1}
20
21 %description
22 The Device Tree Compiler, dtc, takes as input a device-tree in a given
23 format and outputs a device-tree in another format. Typically, the
24 input format is "dts", a human readable source format, and creates a
25 "dtb", or binary format as output.
26
27 %description -l pl.UTF-8
28 Kompilator drzewiastej struktury urządzeń, dtc, przyjmuje na wejściu
29 dane w jednym formacie by na wyjściu wyprodukować strukturę danych w
30 innym. Najczęściej format wejściowy to "dts", intuicyjny i łatwy w
31 odczycie (tzw. human readable), natomiast wyjściowy to "dtb" lub
32 inaczej format binarny.
33
34 %package devel
35 Summary:        Header files for fdt library
36 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki fdt
37 Group:          Development/Libraries
38 Requires:       %{name}-doc = %{version}-%{release}
39 # does not require base. see README.license
40
41 %description devel
42 Header files for fdt library.
43
44 %description devel -l pl.UTF-8
45 Pliki nagłówkowe biblioteki fdt.
46
47 %package static
48 Summary:        Static fdt library
49 Summary(pl.UTF-8):      Statyczna biblioteka fdt
50 Group:          Development/Libraries
51 Requires:       %{name}-devel = %{version}-%{release}
52
53 %description static
54 Static fdt library.
55
56 %description static -l pl.UTF-8
57 Statyczna biblioteka fdt.
58
59 %package doc
60 Summary:        Dtc documentation
61 Summary(pl.UTF-8):      Dokumentacja dla dtc
62 Group:          Development/Libraries
63
64 %description doc
65 Dtc package documentation.
66
67 %description doc -l pl.UTF-8
68 Dokumentacja pakietu dtc.
69
70 %prep
71 %setup -q -n %{name}-v%{version}
72
73 %build
74 %{__make} \
75         %{?with_verbose:V=1} \
76         CC="%{__cc}" \
77         CFLAGS="%{rpmcflags}"
78
79 %install
80 rm -rf $RPM_BUILD_ROOT
81 %{__make} install \
82         %{?with_verbose:V=1} \
83         PREFIX=%{_prefix} \
84         LIBDIR=%{_libdir} \
85         DESTDIR=$RPM_BUILD_ROOT
86
87 %clean
88 rm -rf $RPM_BUILD_ROOT
89
90 %files
91 %defattr(644,root,root,755)
92 %attr(755,root,root) %{_bindir}/dtc
93
94 %files devel
95 %defattr(644,root,root,755)
96 %{_includedir}/fdt.h
97 %{_includedir}/libfdt.h
98
99 %files static
100 %defattr(644,root,root,755)
101 %{_libdir}/libfdt.a
102
103 %files doc
104 %doc TODO README.license Documentation/manual.txt
This page took 0.197293 seconds and 4 git commands to generate.