]> git.pld-linux.org Git - packages/dracut.git/commitdiff
- dracut doesn't play with mksh which is /bin/sh in PLD, so force bash
authorJan Rękorajski <baggins@pld-linux.org>
Wed, 21 Mar 2012 22:54:46 +0000 (22:54 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    bash-sh.patch -> 1.1
    dracut.spec -> 1.8

bash-sh.patch [new file with mode: 0644]
dracut.spec

diff --git a/bash-sh.patch b/bash-sh.patch
new file mode 100644 (file)
index 0000000..6edda11
--- /dev/null
@@ -0,0 +1,21 @@
+--- /dev/null  2012-03-21 19:30:19.123295831 +0100
++++ dracut-017/modules.d/01bash/module-setup.sh        2012-03-21 23:46:14.717134386 +0100
+@@ -0,0 +1,18 @@
++#!/bin/bash
++# -*- mode: shell-script; indent-tabs-mode: nil; sh-basic-offset: 4; -*-
++# ex: ts=8 sw=4 sts=4 et filetype=sh
++
++check() {
++    return 0
++}
++
++depends() {
++    return 0
++}
++
++install() {
++    # If another shell is already installed, do not use bash
++    [[ -x $initdir/bin/sh ]] && return
++
++    inst /bin/bash && ln -sf bash "${initdir}/bin/sh"
++}
index 6f3f0378a76194bb9f1c51b62fdd3e25e21847d6..d04afafcf327ea62d3553486816e52992220a44e 100644 (file)
@@ -1,7 +1,7 @@
 Summary:       Initramfs generator using udev
 Name:          dracut
 Version:       017
-Release:       0.3
+Release:       0.5
 License:       GPL v2+
 Group:         Base
 Source0:       ftp://www.kernel.org/pub/linux/utils/boot/dracut/%{name}-%{version}.tar.xz
@@ -9,6 +9,7 @@ Source0:        ftp://www.kernel.org/pub/linux/utils/boot/dracut/%{name}-%{version}.tar
 Source1:       pld.conf
 Patch0:                no-rh.patch
 Patch1:                create-target-dir-for-symlink.patch
+Patch2:                bash-sh.patch
 URL:           https://dracut.wiki.kernel.org/
 BuildRequires: docbook-style-xsl
 BuildRequires: libxslt-progs
@@ -95,6 +96,7 @@ configuration.
 %setup -q
 %patch0 -p1
 %patch1 -p1
+%patch2 -p1
 
 %build
 %{__make}
@@ -148,6 +150,8 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{dracutlibdir}/modules.d/00bootchart/*.sh
 %dir %{dracutlibdir}/modules.d/00dash
 %attr(755,root,root) %{dracutlibdir}/modules.d/00dash/*.sh
+%dir %{dracutlibdir}/modules.d/01bash
+%attr(755,root,root) %{dracutlibdir}/modules.d/01bash/*.sh
 %dir %{dracutlibdir}/modules.d/05busybox
 %attr(755,root,root) %{dracutlibdir}/modules.d/05busybox/*.sh
 %dir %{dracutlibdir}/modules.d/10i18n
This page took 0.058513 seconds and 4 git commands to generate.