]> git.pld-linux.org Git - packages/dpkg.git/blob - dpkg.spec
f61fa7b28f9caf14bd67a6ec7c40243785e95ed1
[packages/dpkg.git] / dpkg.spec
1 Summary:        Package maintenance system for Debian Linux
2 Name:           dpkg
3 Version:        1.6.14
4 Release:        1
5 License:        GPL
6 Group:          Utilities/File
7 Group(pl):      Narzêdzia/Pliki
8 Source:         ftp://ftp.debian.org/debian/dists/potato/main/source/base/%{name}_%{version}.tar.gz
9 Patch0:         dpkg-no-debiandoc.patch
10 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
11
12 %description
13 This package contains the programs which handle the installation and
14 removal of packages on your system.
15
16 The primary interface for the dpkg suite is the `dselect' program; a
17 more low-level and less user-friendly interface is available in the
18 form of the `dpkg' command.
19
20 In order to unpack and build Debian source packages you will need to
21 install the developers' package `dpkg-dev' as well as this one.
22
23 %prep
24 %setup -q
25 %patch0 -p1
26
27 %build
28 gettextize --copy --force
29 %configure \
30         --enable-shared \
31         --without-dselect \
32         --with-admindir=/var/lib/%{name}
33
34 %{__make} docdir=%{_defaultdocdir}/%{name}-%{version}
35
36 %install
37 rm -rf $RPM_BUILD_ROOT
38 install -d $RPM_BUILD_ROOT%{_defaultdocdir}/dpkg
39
40 %{__make} install \
41         DESTDIR=$RPM_BUILD_ROOT
42
43 strip --strip-unneeded $RPM_BUILD_ROOT{%{_bindir},%{_sbindir}}/* || :
44
45 gzip -9nf $RPM_BUILD_ROOT%{_defaultdocdir}/%{name}/* \
46         $RPM_BUILD_ROOT%{_mandir}/man*/* \
47         $RPM_BUILD_ROOT%{_mandir}/*/man*/*
48
49 %find_lang dpkg
50
51 %clean
52 rm -rf $RPM_BUILD_ROOT
53
54 %files -f dpkg.lang
55 %defattr(644,root,root,755)
56 %doc doc/database-structure.fig doc/internals.sgml
57 %doc $RPM_BUILD_ROOT%{_defaultdocdir}/%{name}/*
58 %attr(755,root,root) %{_bindir}/822-date
59 %attr(755,root,root) %{_bindir}/dpkg*
60 %dir %{_libdir}/dpkg
61 %dir %{_libdir}/dpkg/methods
62 %dir %{_libdir}/dpkg/parsechangelog
63 %dir %{_libdir}/dpkg/methods/disk
64 %dir %{_libdir}/dpkg/methods/floppy
65 %{_libdir}/dpkg/controllib.pl
66 %attr(755,root,root) %{_libdir}/dpkg/mksplit
67 %dir %{_libdir}/dpkg/methods/*/desc*
68 %dir %{_libdir}/dpkg/methods/*/names
69 %attr(755,root,root) %dir %{_libdir}/dpkg/methods/*/install
70 %attr(755,root,root) %dir %{_libdir}/dpkg/methods/*/setup
71 %attr(755,root,root) %dir %{_libdir}/dpkg/methods/*/update
72 %attr(755,root,root) %dir %{_libdir}/dpkg/parsechangelog/debian
73 %attr(755,root,root) %{_sbindir}/start-stop-daemon
74 %attr(755,root,root) %{_sbindir}/dpkg-divert
75 %attr(755,root,root) %{_sbindir}/update-alternatives
76 %attr(755,root,root) %{_sbindir}/update-rc.d
77 %dir /var/lib/dpkg
78 /var/lib/dpkg/*
79 %{_mandir}/man1/822-date.1*
80 %{_mandir}/man1/dpkg*
81 %{_mandir}/man5/*
82 %{_mandir}/man8/dpkg*
83 %{_mandir}/man8/start-stop*
84 %{_mandir}/man8/update*
85 %lang(ja) %{_mandir}/ja/man1/dpkg*
86 %lang(ja) %{_mandir}/ja/man5/*
87 %lang(ja) %{_mandir}/ja/man8/dpkg*
88 %lang(ja) %{_mandir}/ja/man8/start-stop*
89 %lang(ja) %{_mandir}/ja/man8/update*
90 %lang(sv) %{_mandir}/sv/man5/*
This page took 0.043997 seconds and 2 git commands to generate.