]> git.pld-linux.org Git - packages/dpkg.git/blame - dpkg.spec
- updated _noautoreq_perl; release 2
[packages/dpkg.git] / dpkg.spec
CommitLineData
4f40d504
ER
1#
2# Conditional build:
3%bcond_with alternatives # build alternatives package
4
aea5b33f 5Summary: Package maintenance system for Debian Linux
b81e7419 6Summary(pl.UTF-8): Program do obsługi pakietów Debiana
aea5b33f 7Name: dpkg
c9532625 8Version: 1.22.2
37f40194 9Release: 2
99403999 10License: GPL v2+
71d0ff61 11Group: Applications/File
9f070fe3 12Source0: http://ftp.debian.org/debian/pool/main/d/dpkg/%{name}_%{version}.tar.xz
c9532625
JB
13# Source0-md5: 591fe669ae36c1c93a8658bd650e38a6
14URL: https://packages.debian.org/search?keywords=dpkg
c823dd8d 15BuildRequires: automake
dcaefd63 16BuildRequires: bzip2-devel
c9532625
JB
17BuildRequires: gettext-tools >= 0.19.8
18BuildRequires: libmd-devel
19BuildRequires: libselinux-devel >= 2.3
20BuildRequires: libstdc++-devel >= 6:4.7
21BuildRequires: ncurses-devel >= 5
22BuildRequires: perl-base >= 1:5.32.1
23BuildRequires: perl-tools-pod >= 1:5.32.1
1c3e1c0e 24BuildRequires: pkgconfig
c9532625 25BuildRequires: po4a >= 0.59
04081f34 26BuildRequires: rpm-build >= 4.6
1c3e1c0e 27BuildRequires: rpm-perlprov
c172ea00 28BuildRequires: rpmbuild(macros) >= 1.754
3477ad18
JB
29BuildRequires: tar >= 1:1.22
30BuildRequires: xz
31BuildRequires: xz-devel
589726b5 32BuildRequires: zlib-devel
c9532625 33BuildRequires: zstd-devel
80622688 34Requires: perl-base
607070d7 35BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
aea5b33f 36
392fa822 37# blacklist false positives
37f40194 38%define _noautoreq_perl at extra file
392fa822 39
aea5b33f 40%description
99403999
JB
41This package contains the programs to handle deb packages known from
42Debian.
aea5b33f 43
f8701fb4
JR
44%description -l pl.UTF-8
45Ten pakiet zawiera narzędzia do obsługi pakietów deb znanych z
71d0ff61 46Debiana.
289d26c0 47
99403999
JB
48%package -n libdpkg-devel
49Summary: dpkg library and header files
50Summary(pl.UTF-8): Biblioteka i pliki nagłówkowe dpkg
51Group: Development/Libraries
184a11e8
JB
52Requires: bzip2-devel
53Requires: xz-devel
54Requires: zlib-devel
99403999
JB
55
56%description -n libdpkg-devel
57dpkg library and header files.
58
59%description -n libdpkg-devel -l pl.UTF-8
60Biblioteka i pliki nagłówkowe dpkg.
61
1750f640
ER
62%package alternatives
63Summary: Maintain symbolic links determining default commands
64Summary(pl.UTF-8): Utrzymywanie dowiązań symbolicznych określających domyślne polecenia
65Group: Applications/System
66Requires: %{name} = %{version}-%{release}
67
68%description alternatives
69alternatives creates, removes, maintains and displays information
70about the symbolic links comprising the alternatives system. The
71alternatives system is a reimplementation of the Debian alternatives
72system.
73
74%description alternatives -l pl.UTF-8
75alternatives tworzy, usuwa, utrzymuje i wyświetla informacje o
76dowiązaniach symbolicznych obejmujących system alternatyw. System
77alternatyw to reimplementacja systemu alternatyw ("alternatives") z
78Debiana.
79
b5ec5adf
MK
80%package -n zsh-completion-dpkg
81Summary: ZSH completion for dpkg command
82Summary(pl.UTF-8): Dopełnianianie parametrów w ZSH dla polecenia dpkg
83Group: Applications/Shells
84Requires: %{name} = %{version}-%{release}
85Requires: zsh
86BuildArch: noarch
87
88%description -n zsh-completion-dpkg
89ZSH completion for dpkg command.
90
91%description -n zsh-completion-dpkg -l pl.UTF-8
92Dopełnianianie parametrów w ZSH dla polecenia dpkg.
93
aea5b33f
JR
94%prep
95%setup -q
aea5b33f
JR
96
97%build
c9532625
JB
98# dpkg expects <md5.h> from FreeBSD-compatible libmd (not libmd5)
99CPPFLAGS="%{rpmcppflags} -I/usr/include/libmd"
71d0ff61 100%configure \
e2582a24 101 PO4A="true" \
b5ec5adf 102 --disable-devel-docs \
3477ad18 103 --disable-dselect \
99403999 104 --disable-silent-rules \
3477ad18 105 --disable-start-stop-daemon \
c9532625
JB
106 %{!?with_alternatives:--disable-update-alternatives} \
107 --with-admindir=/var/lib/%{name} \
108 --with-zshcompletionsdir=%{zsh_compdir}
aea5b33f 109
dcaefd63 110%{__make}
aea5b33f
JR
111
112%install
113rm -rf $RPM_BUILD_ROOT
aea5b33f
JR
114%{__make} install \
115 DESTDIR=$RPM_BUILD_ROOT
116
4f40d504 117%if %{with alternatives}
99403999 118%{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/alternatives/README
4f40d504 119%endif
47be6b2f 120
b5ec5adf
MK
121# packaged as doc
122%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/doc/dpkg
123
ddae01a5
JB
124# obsoleted by pkg-config
125%{__rm} $RPM_BUILD_ROOT%{_libdir}/libdpkg.la
126
99403999
JB
127# dpkg for main part, dpkg-dev for perl-based build script
128# don't use --all-name to avoid e.g. dselect inclusion
aea5b33f 129%find_lang dpkg
99403999
JB
130%find_lang dpkg-dev
131cat dpkg-dev.lang >>dpkg.lang
aea5b33f
JR
132
133%clean
134rm -rf $RPM_BUILD_ROOT
135
136%files -f dpkg.lang
137%defattr(644,root,root,755)
99403999 138%doc AUTHORS ChangeLog README THANKS TODO
aea5b33f 139%attr(755,root,root) %{_bindir}/dpkg*
b5ec5adf 140%attr(755,root,root) %{_sbindir}/dpkg-fsys-usrunmess
47be6b2f 141%dir %{_sysconfdir}/dpkg
99403999 142%dir %{_sysconfdir}/dpkg/dpkg.cfg.d
47be6b2f 143
47be6b2f 144%dir %{_datadir}/dpkg
fa52672c 145%{_datadir}/dpkg/abitable
47be6b2f
ER
146%{_datadir}/dpkg/cputable
147%{_datadir}/dpkg/ostable
b5ec5adf 148%{_datadir}/dpkg/tupletable
3e75a3a3 149%{_datadir}/dpkg/*.mk
b5ec5adf
MK
150%{_datadir}/dpkg/*.specs
151
152%dir %{_datadir}/dpkg/sh
153%{_datadir}/dpkg/sh/dpkg-error.sh
154
155%dir %{_libexecdir}/dpkg
156%attr(755,root,root) %{_libexecdir}/dpkg/dpkg-db-backup
c9532625 157%attr(755,root,root) %{_libexecdir}/dpkg/dpkg-db-keeper
99403999
JB
158
159%{perl_vendorlib}/Dpkg.pm
d52c6c83 160%{perl_vendorlib}/Dpkg
47be6b2f 161
aea5b33f 162%dir /var/lib/dpkg
99403999
JB
163%dir /var/lib/dpkg/info
164%dir /var/lib/dpkg/parts
165%dir /var/lib/dpkg/updates
166
167%{_mandir}/man1/dpkg*.1*
b8a00aaf 168%{_mandir}/man3/Dpkg.3*
99403999
JB
169%{_mandir}/man3/Dpkg::*.3*
170%{_mandir}/man5/deb*.5*
171%{_mandir}/man5/dpkg.cfg.5*
efe61112 172%{_mandir}/man5/dsc.5*
b5ec5adf 173%{_mandir}/man7/deb-version.7*
c9532625 174%{_mandir}/man7/dpkg-build-api.7*
b5ec5adf 175%{_mandir}/man8/dpkg-fsys-usrunmess.8.*
99403999
JB
176%lang(de) %{_mandir}/de/man1/dpkg*.1*
177%lang(de) %{_mandir}/de/man5/deb*.5*
178%lang(de) %{_mandir}/de/man5/dpkg.cfg.5*
efe61112 179%lang(de) %{_mandir}/de/man5/dsc.5*
b5ec5adf 180%lang(de) %{_mandir}/de/man7/deb-version.7*
c9532625 181%lang(de) %{_mandir}/de/man7/dpkg-build-api.7*
b5ec5adf 182%lang(de) %{_mandir}/de/man8/dpkg-fsys-usrunmess.8.*
99403999
JB
183%lang(es) %{_mandir}/es/man1/dpkg*.1*
184%lang(es) %{_mandir}/es/man5/deb*.5*
185%lang(es) %{_mandir}/es/man5/dpkg.cfg.5*
99403999
JB
186%lang(fr) %{_mandir}/fr/man1/dpkg*.1*
187%lang(fr) %{_mandir}/fr/man5/deb*.5*
188%lang(fr) %{_mandir}/fr/man5/dpkg.cfg.5*
b5ec5adf
MK
189%lang(fr) %{_mandir}/fr/man5/dsc.5*
190%lang(fr) %{_mandir}/fr/man7/deb-version.7*
c9532625 191%lang(fr) %{_mandir}/fr/man8/dpkg-fsys-usrunmess.8.*
42d55ea9
JB
192%lang(it) %{_mandir}/it/man1/dpkg*.1*
193%lang(it) %{_mandir}/it/man5/deb*.5*
194%lang(it) %{_mandir}/it/man5/dpkg.cfg.5*
3e75a3a3
JB
195%lang(ja) %{_mandir}/ja/man1/dpkg*.1*
196%lang(ja) %{_mandir}/ja/man5/deb*.5*
197%lang(ja) %{_mandir}/ja/man5/dpkg.cfg.5*
efe61112
JB
198%lang(nl) %{_mandir}/nl/man1/dpkg*.1*
199%lang(nl) %{_mandir}/nl/man5/deb*.5*
200%lang(nl) %{_mandir}/nl/man5/dpkg.cfg.5*
b5ec5adf
MK
201%lang(nl) %{_mandir}/nl/man5/dsc.5*
202%lang(nl) %{_mandir}/nl/man7/deb-version.7*
c9532625 203%lang(nl) %{_mandir}/nl/man7/dpkg-build-api.7*
b5ec5adf 204%lang(nl) %{_mandir}/nl/man8/dpkg-fsys-usrunmess.8.*
99403999
JB
205%lang(pl) %{_mandir}/pl/man1/dpkg*.1*
206%lang(pl) %{_mandir}/pl/man5/deb*.5*
207%lang(pl) %{_mandir}/pl/man5/dpkg.cfg.5*
b5ec5adf
MK
208%lang(pt) %{_mandir}/pt/man1/dpkg*.1*
209%lang(pt) %{_mandir}/pt/man5/deb*.5*
210%lang(pt) %{_mandir}/pt/man5/dpkg.cfg.5*
211%lang(pt) %{_mandir}/pt/man5/dsc.5*
212%lang(pt) %{_mandir}/pt/man7/deb-version.7*
c9532625 213%lang(pt) %{_mandir}/pt/man7/dpkg-build-api.7*
b5ec5adf 214%lang(pt) %{_mandir}/pt/man8/dpkg-fsys-usrunmess.8.*
99403999
JB
215%lang(sv) %{_mandir}/sv/man1/dpkg*.1*
216%lang(sv) %{_mandir}/sv/man5/deb*.5*
217%lang(sv) %{_mandir}/sv/man5/dpkg.cfg.5*
b5ec5adf
MK
218%lang(sv) %{_mandir}/sv/man5/dsc.5*
219%lang(sv) %{_mandir}/sv/man7/deb-version.7*
c9532625 220%lang(sv) %{_mandir}/sv/man7/dpkg-build-api.7*
b5ec5adf 221%lang(sv) %{_mandir}/sv/man8/dpkg-fsys-usrunmess.8.*
99403999
JB
222
223%files -n libdpkg-devel
224%defattr(644,root,root,755)
b5ec5adf 225%doc doc/README.* doc/*.txt
99403999
JB
226%{_libdir}/libdpkg.a
227%{_includedir}/dpkg
b5ec5adf 228%{_aclocaldir}/dpkg*.m4
99403999 229%{_pkgconfigdir}/libdpkg.pc
1750f640 230
4f40d504 231%if %{with alternatives}
1750f640
ER
232%files alternatives
233%defattr(644,root,root,755)
234%dir %{_sysconfdir}/alternatives
235%attr(755,root,root) %{_bindir}/update-alternatives
236%{_mandir}/man1/update-alternatives.1*
237%lang(de) %{_mandir}/de/man1/update-alternatives.1*
238%lang(es) %{_mandir}/es/man1/update-alternatives.1*
239%lang(fr) %{_mandir}/fr/man1/update-alternatives.1*
240%lang(it) %{_mandir}/it/man1/update-alternatives.1*
241%lang(ja) %{_mandir}/ja/man1/update-alternatives.1*
242%lang(pl) %{_mandir}/pl/man1/update-alternatives.1*
243%lang(sv) %{_mandir}/sv/man1/update-alternatives.1*
4f40d504
ER
244%dir /var/lib/dpkg/alternatives
245%endif
b5ec5adf
MK
246
247%files -n zsh-completion-dpkg
248%defattr(644,root,root,755)
17034733 249%{zsh_compdir}/_dpkg-parsechangelog
This page took 0.270114 seconds and 4 git commands to generate.