]> git.pld-linux.org Git - packages/dpkg.git/blame - dpkg.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/dpkg.git] / dpkg.spec
CommitLineData
4f40d504
ER
1#
2# Conditional build:
3%bcond_with alternatives # build alternatives package
4
aea5b33f 5Summary: Package maintenance system for Debian Linux
b81e7419 6Summary(pl.UTF-8): Program do obsługi pakietów Debiana
aea5b33f 7Name: dpkg
efe61112
JB
8Version: 1.18.10
9Release: 1
99403999 10License: GPL v2+
71d0ff61 11Group: Applications/File
3477ad18 12Source0: ftp://ftp.debian.org/debian/pool/main/d/dpkg/%{name}_%{version}.tar.xz
efe61112 13# Source0-md5: ccff17730c0964428fc186ded2f2f401
42d55ea9 14Patch0: %{name}-md5.patch
99403999 15URL: http://packages.debian.org/search?keywords=dpkg
dcaefd63 16BuildRequires: bzip2-devel
efe61112 17BuildRequires: gettext-tools >= 0.19
dcaefd63 18BuildRequires: libselinux-devel
dc9ed1c4 19BuildRequires: perl-tools-pod
1c3e1c0e 20BuildRequires: pkgconfig
1c3e1c0e 21BuildRequires: rpm-perlprov
1750f640 22BuildRequires: rpmbuild(macros) >= 1.654
3477ad18
JB
23BuildRequires: tar >= 1:1.22
24BuildRequires: xz
25BuildRequires: xz-devel
589726b5 26BuildRequires: zlib-devel
80622688 27Requires: perl-base
607070d7 28BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
aea5b33f 29
392fa822 30# blacklist false positives
c4540769 31%define _noautoreq_perl extra file in Tie::ExtraHash
392fa822 32
aea5b33f 33%description
99403999
JB
34This package contains the programs to handle deb packages known from
35Debian.
aea5b33f 36
f8701fb4
JR
37%description -l pl.UTF-8
38Ten pakiet zawiera narzędzia do obsługi pakietów deb znanych z
71d0ff61 39Debiana.
289d26c0 40
99403999
JB
41%package -n libdpkg-devel
42Summary: dpkg library and header files
43Summary(pl.UTF-8): Biblioteka i pliki nagłówkowe dpkg
44Group: Development/Libraries
184a11e8
JB
45Requires: bzip2-devel
46Requires: xz-devel
47Requires: zlib-devel
99403999
JB
48
49%description -n libdpkg-devel
50dpkg library and header files.
51
52%description -n libdpkg-devel -l pl.UTF-8
53Biblioteka i pliki nagłówkowe dpkg.
54
1750f640
ER
55%package alternatives
56Summary: Maintain symbolic links determining default commands
57Summary(pl.UTF-8): Utrzymywanie dowiązań symbolicznych określających domyślne polecenia
58Group: Applications/System
59Requires: %{name} = %{version}-%{release}
60
61%description alternatives
62alternatives creates, removes, maintains and displays information
63about the symbolic links comprising the alternatives system. The
64alternatives system is a reimplementation of the Debian alternatives
65system.
66
67%description alternatives -l pl.UTF-8
68alternatives tworzy, usuwa, utrzymuje i wyświetla informacje o
69dowiązaniach symbolicznych obejmujących system alternatyw. System
70alternatyw to reimplementacja systemu alternatyw ("alternatives") z
71Debiana.
72
aea5b33f
JR
73%prep
74%setup -q
42d55ea9 75%patch0 -p1
aea5b33f
JR
76
77%build
663dd486
JB
78# "ac_cv_header_md5_h=no" to disable error on md5.h from libmd5
79# (dpkg expects this header from FreeBSD-compatible libmd, having different API)
71d0ff61 80%configure \
663dd486 81 ac_cv_header_md5_h=no \
e2582a24 82 PO4A="true" \
3477ad18 83 --disable-dselect \
4f40d504 84 %{!?with_alternatives:--disable-update-alternatives} \
99403999 85 --disable-silent-rules \
3477ad18 86 --disable-start-stop-daemon \
99403999 87 --with-admindir=/var/lib/%{name}
aea5b33f 88
dcaefd63 89%{__make}
aea5b33f
JR
90
91%install
92rm -rf $RPM_BUILD_ROOT
aea5b33f
JR
93%{__make} install \
94 DESTDIR=$RPM_BUILD_ROOT
95
4f40d504 96%if %{with alternatives}
99403999 97%{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/alternatives/README
4f40d504 98%endif
47be6b2f 99
ddae01a5
JB
100# obsoleted by pkg-config
101%{__rm} $RPM_BUILD_ROOT%{_libdir}/libdpkg.la
102
99403999
JB
103# dpkg for main part, dpkg-dev for perl-based build script
104# don't use --all-name to avoid e.g. dselect inclusion
aea5b33f 105%find_lang dpkg
99403999
JB
106%find_lang dpkg-dev
107cat dpkg-dev.lang >>dpkg.lang
aea5b33f
JR
108
109%clean
110rm -rf $RPM_BUILD_ROOT
111
112%files -f dpkg.lang
113%defattr(644,root,root,755)
99403999 114%doc AUTHORS ChangeLog README THANKS TODO
aea5b33f 115%attr(755,root,root) %{_bindir}/dpkg*
47be6b2f 116%dir %{_sysconfdir}/dpkg
99403999 117%dir %{_sysconfdir}/dpkg/dpkg.cfg.d
47be6b2f 118
47be6b2f 119%dir %{_datadir}/dpkg
fa52672c 120%{_datadir}/dpkg/abitable
47be6b2f
ER
121%{_datadir}/dpkg/cputable
122%{_datadir}/dpkg/ostable
123%{_datadir}/dpkg/triplettable
3e75a3a3 124%{_datadir}/dpkg/*.mk
99403999
JB
125
126%{perl_vendorlib}/Dpkg.pm
d52c6c83 127%{perl_vendorlib}/Dpkg
47be6b2f 128
aea5b33f 129%dir /var/lib/dpkg
99403999
JB
130%dir /var/lib/dpkg/info
131%dir /var/lib/dpkg/parts
132%dir /var/lib/dpkg/updates
133
134%{_mandir}/man1/dpkg*.1*
b8a00aaf 135%{_mandir}/man3/Dpkg.3*
99403999
JB
136%{_mandir}/man3/Dpkg::*.3*
137%{_mandir}/man5/deb*.5*
138%{_mandir}/man5/dpkg.cfg.5*
efe61112 139%{_mandir}/man5/dsc.5*
99403999
JB
140%lang(de) %{_mandir}/de/man1/dpkg*.1*
141%lang(de) %{_mandir}/de/man5/deb*.5*
142%lang(de) %{_mandir}/de/man5/dpkg.cfg.5*
efe61112 143%lang(de) %{_mandir}/de/man5/dsc.5*
99403999
JB
144%lang(es) %{_mandir}/es/man1/dpkg*.1*
145%lang(es) %{_mandir}/es/man5/deb*.5*
146%lang(es) %{_mandir}/es/man5/dpkg.cfg.5*
99403999
JB
147%lang(fr) %{_mandir}/fr/man1/dpkg*.1*
148%lang(fr) %{_mandir}/fr/man5/deb*.5*
149%lang(fr) %{_mandir}/fr/man5/dpkg.cfg.5*
42d55ea9
JB
150%lang(it) %{_mandir}/it/man1/dpkg*.1*
151%lang(it) %{_mandir}/it/man5/deb*.5*
152%lang(it) %{_mandir}/it/man5/dpkg.cfg.5*
3e75a3a3
JB
153%lang(ja) %{_mandir}/ja/man1/dpkg*.1*
154%lang(ja) %{_mandir}/ja/man5/deb*.5*
155%lang(ja) %{_mandir}/ja/man5/dpkg.cfg.5*
efe61112
JB
156%lang(nl) %{_mandir}/nl/man1/dpkg*.1*
157%lang(nl) %{_mandir}/nl/man5/deb*.5*
158%lang(nl) %{_mandir}/nl/man5/dpkg.cfg.5*
99403999
JB
159%lang(pl) %{_mandir}/pl/man1/dpkg*.1*
160%lang(pl) %{_mandir}/pl/man5/deb*.5*
161%lang(pl) %{_mandir}/pl/man5/dpkg.cfg.5*
99403999
JB
162%lang(sv) %{_mandir}/sv/man1/dpkg*.1*
163%lang(sv) %{_mandir}/sv/man5/deb*.5*
164%lang(sv) %{_mandir}/sv/man5/dpkg.cfg.5*
99403999
JB
165
166%files -n libdpkg-devel
167%defattr(644,root,root,755)
168%{_libdir}/libdpkg.a
169%{_includedir}/dpkg
170%{_pkgconfigdir}/libdpkg.pc
1750f640 171
4f40d504 172%if %{with alternatives}
1750f640
ER
173%files alternatives
174%defattr(644,root,root,755)
175%dir %{_sysconfdir}/alternatives
176%attr(755,root,root) %{_bindir}/update-alternatives
177%{_mandir}/man1/update-alternatives.1*
178%lang(de) %{_mandir}/de/man1/update-alternatives.1*
179%lang(es) %{_mandir}/es/man1/update-alternatives.1*
180%lang(fr) %{_mandir}/fr/man1/update-alternatives.1*
181%lang(it) %{_mandir}/it/man1/update-alternatives.1*
182%lang(ja) %{_mandir}/ja/man1/update-alternatives.1*
183%lang(pl) %{_mandir}/pl/man1/update-alternatives.1*
184%lang(sv) %{_mandir}/sv/man1/update-alternatives.1*
4f40d504
ER
185%dir /var/lib/dpkg/alternatives
186%endif
This page took 0.124994 seconds and 4 git commands to generate.