]> git.pld-linux.org Git - packages/double-conversion.git/blob - double-conversion.spec
- updated to 3.3.0
[packages/double-conversion.git] / double-conversion.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # static library
4 %bcond_without  tests           # build without tests
5
6 Summary:        Library providing binary-decimal and decimal-binary routines for IEEE doubles
7 Summary(pl.UTF-8):      Biblioteka dostarczająca przejścia binarno-dziesiętne i dziesiętno-binarne dla typów double IEEE
8 Name:           double-conversion
9 Version:        3.3.0
10 Release:        1
11 License:        BSD
12 Group:          Libraries
13 #Source0Download: https://github.com/google/double-conversion/releases
14 Source0:        https://github.com/google/double-conversion/archive/v%{version}/%{name}-%{version}.tar.gz
15 # Source0-md5:  b344abb64084a4a1d98a43e67752989b
16 URL:            https://github.com/google/double-conversion
17 BuildRequires:  cmake >= 3.0
18 BuildRequires:  libstdc++-devel
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 This project (double-conversion) provides binary-decimal and
23 decimal-binary routines for IEEE doubles.
24
25 The library consists of efficient conversion routines that have been
26 extracted from the V8 JavaScript engine. The code has been refactored
27 and improved so that it can be used more easily in other projects.
28
29 %description -l pl.UTF-8
30 Projekt double-conversion dostarcza funkcje przejścia
31 binarno-dziesiętne i dziesiętno-binarne dla typów double IEEE.
32
33 Biblioteka składa się z wydajnych funkcji konwersji, wyciągniętych z
34 silnika JavaScriptu V8. Kod został zrefaktorowany i ulepszony, dzięki
35 czemu może być łatwiej używany w innych projektach.
36
37 %package devel
38 Summary:        Header files for double-conversion library
39 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki double-conversion
40 Group:          Development/Libraries
41 Requires:       %{name} = %{version}-%{release}
42 Requires:       libstdc++-devel
43
44 %description devel
45 Contains header files for developing applications that use the
46 double-conversion library.
47
48 There is extensive documentation in double-conversion.h.
49
50 %description devel -l pl.UTF_8
51 Ten pakiet zawiera pliki nagłówkowe do tworzenia aplikacji
52 wykorzystujących bibliotekę double-conversion.
53
54 W pliku double-conversion.h zawarta jest obszerna dokumentacja.
55
56 %package static
57 Summary:        Static double-conversion library
58 Summary(pl.UTF-8):      Statyczna biblioteka double-conversion
59 Group:          Development/Libraries
60 Requires:       %{name}-devel = %{version}-%{release}
61
62 %description static
63 Static double-conversion library.
64
65 %description static -l pl.UTF-8
66 Statyczna biblioteka double-conversion.
67
68 %prep
69 %setup -q
70
71 %build
72 %if %{with static_libs}
73 install -d build-static
74 cd build-static
75 %cmake .. \
76         -DBUILD_SHARED_LIBS=OFF
77
78 %{__make}
79 cd ..
80 %endif
81
82 install -d build
83 cd build
84 %cmake .. \
85         %{?with_tests:-DBUILD_TESTING=ON}
86
87 %{__make}
88
89 %{?with_tests:ctest}
90
91 %install
92 rm -rf $RPM_BUILD_ROOT
93
94 %if %{with static_libs}
95 %{__make} -C build-static install \
96         DESTDIR=$RPM_BUILD_ROOT
97 %endif
98
99 %{__make} -C build install \
100         DESTDIR=$RPM_BUILD_ROOT
101
102 %clean
103 %{__rm} -rf $RPM_BUILD_ROOT
104
105 %post   -p /sbin/ldconfig
106 %postun -p /sbin/ldconfig
107
108 %files
109 %defattr(644,root,root,755)
110 %doc AUTHORS Changelog LICENSE README.md
111 %attr(755,root,root) %{_libdir}/libdouble-conversion.so.*.*.*
112 %attr(755,root,root) %ghost %{_libdir}/libdouble-conversion.so.3
113
114 %files devel
115 %defattr(644,root,root,755)
116 %attr(755,root,root) %{_libdir}/libdouble-conversion.so
117 %{_includedir}/double-conversion
118 %{_libdir}/cmake/double-conversion
119
120 %if %{with static_libs}
121 %files static
122 %defattr(644,root,root,755)
123 %{_libdir}/libdouble-conversion.a
124 %endif
This page took 0.205894 seconds and 4 git commands to generate.