]> git.pld-linux.org Git - packages/dosemu.git/blob - dosemu.spec
- obsolete
[packages/dosemu.git] / dosemu.spec
1 # NOTE: if /dev/shm is mounted, it cannot be mounted with noexec
2 #
3 # Conditional build:
4 %bcond_with     static          # link statically
5 %bcond_with     AC
6 %bcond_without  htmldocs        # do not build documentation in HTML
7 %bcond_without  sdl             # SDL support
8 %bcond_without  x               # X support
9 %bcond_with     samba           # samba support
10 #
11 %define         smarthogver     0.1.0
12 %define         smbrel          01
13
14 Summary:        A DOS emulator
15 Summary(de.UTF-8):      DOS-Emulator
16 Summary(es.UTF-8):      Emulador DOS
17 Summary(fr.UTF-8):      Emulateur DOS
18 Summary(pl.UTF-8):      Emulator DOS-a
19 Summary(pt_BR.UTF-8):   Emulador DOS
20 Summary(tr.UTF-8):      DOS öykünümcüsü
21 Name:           dosemu
22 Version:        1.4.0.7
23 Release:        1%{?with_samba:.smb%{smbrel}}
24 License:        GPL v2
25 Group:          Applications/Emulators
26 # git archive --format=tar --prefix=dosemu-1.4.0.7/ dosemu-1.4.0.7 | xz > dosemu-1.4.0.7.tar.xz
27 Source0:        %{name}-%{version}.tar.xz
28 # Source0-md5:  842303d611ac5d0932825a34afd67d72
29 #Source2:       %{name}-sys.tar.gz
30 Source3:        %{name}-PRZECZYTAJ_TO
31 Source4:        %{name}-README.PLD
32 Source5:        %{name}.desktop
33 Source6:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-pl-man-pages.tar.bz2
34 # Source6-md5:  7a8abf5c656e6b99bdd03a4783751895
35 Source7:        smarthog-%{smarthogver}.tgz
36 # Source7-md5:  a9f64e8e90382ac3426c39caecd7f64f
37 #Patch0:                %{name}-man-pages.patch
38 Patch2:         %{name}-%{name}_conf.patch
39 Patch3:         %{name}-doSgmlTools.patch
40 Patch4:         %{name}-makehtml.patch
41 Patch5:         http://pascalek.pers.pl/files/projects/Samba4DosEmu/%{name}-1.4.0-samba-beta2.patch.gz
42 # Patch5-md5:   1e4b8f494f4067012daabf3971e6f3e7
43 Patch6:         http://pascalek.pers.pl/files/projects/Samba4DosEmu/s4d-beta2-fix1.patch
44 Patch7:         %{name}-lpt4.patch
45 Patch8:         %{name}-Xquit.patch
46 URL:            http://www.dosemu.org/
47 %{?with_sdl:BuildRequires:      SDL-devel}
48 BuildRequires:  alsa-lib-devel >= 0.9
49 BuildRequires:  autoconf >= 2.59-9
50 BuildRequires:  bin86
51 BuildRequires:  bison
52 BuildRequires:  docbook-dtd30-sgml
53 BuildRequires:  docbook-style-dsssl
54 BuildRequires:  flex
55 %{?with_static:BuildRequires:   glibc-static}
56 BuildRequires:  gpm-devel
57 %{?with_samba:BuildRequires:    libcli_smb-devel}
58 BuildRequires:  libsndfile-devel
59 BuildRequires:  lynx
60 %{?with_htmldocs:BuildRequires: openjade}
61 %{?with_htmldocs:BuildRequires: perl-base}
62 %{?with_htmldocs:BuildRequires: sgml-tools}
63 BuildRequires:  slang-devel
64 %{?with_static:BuildRequires:   slang-static}
65 BuildRequires:  unzip
66 BuildRequires:  util-linux
67 %if %{with x}
68 %if !%{with AC}
69 BuildRequires:  xorg-app-bdftopcf
70 BuildRequires:  xorg-app-mkfontdir
71 BuildRequires:  xorg-lib-libX11-devel
72 BuildRequires:  xorg-lib-libXext-devel
73 BuildRequires:  xorg-lib-libXxf86vm-devel
74 %if %{with static}
75 BuildRequires:  xorg-lib-libX11-static
76 BuildRequires:  xorg-lib-libXext-static
77 BuildRequires:  xorg-lib-libXxf86vm-static
78 %endif
79 %endif
80 %if %{with AC}
81 BuildRequires:  X11-devel
82 %{?with_static:BuildRequires:   X11-static}
83 %endif
84 %endif
85 Obsoletes:      xdosemu
86 Conflicts:      dosemu-freedos-minimal < 2.0.33
87 Conflicts:      kernel < 2.0.28
88 Conflicts:      mtools < 3.6
89 ExclusiveArch:  %{ix86} %{x8664}
90 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
91
92 %define         _dosemudir      /var/lib/dosemu
93 %define         specflags       -fomit-frame-pointer
94
95 %description
96 Dosemu is a DOS emulator. Once you've installed dosemu, start the DOS
97 emulator by typing in the "dos" command.
98
99 You need to install dosemu if you use DOS programs and you want to be
100 able to run them on your GNU/Linux system. You may also need to
101 install the dosemu-freedos-* packages.
102
103 %description -l pl.UTF-8
104 Dosemu to Emulator systemu DOS. Po zainstalowaniu możesz go uruchomić
105 komendą "dos".
106
107 Jeśli korzystasz z dosowych programów i chciałbyś je uruchamiać na
108 twoim linuksowym systemie zainstaluj dosemu. Możesz też potrzebować
109 pakietów dosemu-freedos-*.
110
111 %description -l pt_BR.UTF-8
112 Essa é uma versão do emulador DOS que foi projetada para rodar em
113 sessões X Window. Oferece suporte para gráficos VGA bem como suporte
114 para mouse.
115
116 %package utils
117 Summary:        Utilities for dosemu
118 Summary(pl.UTF-8):      Programy pomocnicze do dosemu
119 Group:          Applications/Emulators
120 Requires:       %{name} = %{version}-%{release}
121
122 %description utils
123 Utilities for dosemu: dexeconfig, hdinfo, mkhdimage, mkfatimage16.
124
125 %description utils -l pl.UTF-8
126 Programy pomocnicze dla dosemu: dexeconfig, hdinfo, mkhdimage,
127 mkfatimage16.
128
129 %package SDL
130 Summary:        SDL plugin for dosemu
131 Summary(pl.UTF-8):      Wtyczka SDL dla dosemu
132 Group:          Libraries
133 Requires:       %{name} = %{version}-%{release}
134
135 %description SDL
136 SDL plugin for dosemu.
137
138 %description SDL -l pl.UTF-8
139 Wtyczka SDL dla dosemu.
140
141 %package X
142 Summary:        X plugin for dosemu
143 Summary(pl.UTF-8):      Wtyczka X dla dosemu
144 Group:          Libraries
145 Requires:       %{name} = %{version}-%{release}
146
147 %description X
148 X plugin for dosemu.
149
150 %description X -l pl.UTF-8
151 Wtyczka X dla dosemu.
152
153 %prep
154 %setup -q -a6 -a7
155
156 %patch2 -p1
157 %patch3 -p1
158 %patch4 -p1
159 %{?with_samba:%patch5 -p1}
160 %{?with_samba:%patch6 -p1}
161 %patch7 -p1
162 %patch8 -p1
163
164 %build
165 ./mkpluginhooks enable plugin_keyboard off plugin_kbd_unicode on \
166 plugin_extra_charset on plugin_term on plugin_translate on plugin_demo off
167
168 %{__autoconf}
169 # configure2_13 must be used though because of ./default-configure
170
171 # non-X version
172 %configure2_13 \
173         %{?with_static:--enable-linkstatic} \
174         --enable-new-intcode \
175         --enable-aspi \
176         %{!?with_x:--without-x}
177
178 %{__make} \
179         WAIT=no
180
181 %{__make} -C man
182 mv -f man/dosemu.bin.1 man/dosemu.1
183 echo '.so dosemu.1' > man/dos.1
184 mv -f man/ru/dosemu.bin.1 man/ru/dosemu.1
185 echo '.so dosemu.1' > man/ru/dos.1
186
187 mv -f pl/man1/dos.1 pl/man1/dosemu.1
188 echo '.so dosemu.1' > pl/man1/dos.1
189 echo '.so dosemu.1' > pl/man1/xdosemu.1
190 echo '.so dosemu.1' > pl/man1/dosdebug.1
191
192 %if %{with htmldocs}
193 # documentation
194 %{__make} -C src/doc/DANG html
195 %{__make} -C src/doc/HOWTO html
196 %{__make} -C src/doc/README html
197
198 find src/doc -name "*.html" -exec cp -f '{}' doc/ ';'
199 %endif
200
201 %install
202 rm -rf $RPM_BUILD_ROOT
203 install -d $RPM_BUILD_ROOT{%{_bindir},%{_sysconfdir},%{_pixmapsdir},%{_desktopdir}} \
204         $RPM_BUILD_ROOT{%{_mandir}/man1,%{_mandir}/{pl,ru}/man1} \
205         $RPM_BUILD_ROOT%{_dosemudir}/bootdir/{dosemu,freedos/doc/fdkernel} \
206         $RPM_BUILD_ROOT%{_libdir}/dosemu
207
208 #%%{__make} install \
209 #       DESTDIR=$RPM_BUILD_ROOT
210
211 install bin/midid $RPM_BUILD_ROOT%{_bindir}/midid
212 install bin/dosemu.bin $RPM_BUILD_ROOT%{_bindir}/dosemu
213 ln -sf dosemu $RPM_BUILD_ROOT%{_bindir}/dos
214 %if %{with x}
215 ln -sf dosemu $RPM_BUILD_ROOT%{_bindir}/xdos
216 ln -sf dosemu $RPM_BUILD_ROOT%{_bindir}/xdosemu
217 ln -sf dosemu $RPM_BUILD_ROOT%{_bindir}/xdosexec
218 %endif
219
220 install bin/libplugin*.so  $RPM_BUILD_ROOT%{_libdir}/dosemu
221
222 install bin/{dosdebug,mkfatimage16} $RPM_BUILD_ROOT%{_bindir}
223 install src/tools/periph/{dexeconfig,hdinfo,mkhdimage} $RPM_BUILD_ROOT%{_bindir}
224 ln -sf dos $RPM_BUILD_ROOT%{_bindir}/dosexec
225
226 install etc/dosemu.xpm $RPM_BUILD_ROOT%{_pixmapsdir}
227 install etc/dosemu.users.example $RPM_BUILD_ROOT%{_sysconfdir}/dosemu.users
228 install etc/global.conf $RPM_BUILD_ROOT%{_dosemudir}/global.conf
229 install etc/dosemu.conf $RPM_BUILD_ROOT%{_sysconfdir}/dosemu.conf
230
231 install man/{dosemu.1,dosdebug.1,xdosemu.1,dos.1,mkfatimage16.1} $RPM_BUILD_ROOT%{_mandir}/man1
232 install pl/man1/{dosemu.1,dosdebug.1,xdosemu.1,dos.1} $RPM_BUILD_ROOT%{_mandir}/pl/man1
233 install man/ru/{dosemu.1,dosdebug.1,xdosemu.1,dos.1,mkfatimage16.1} $RPM_BUILD_ROOT%{_mandir}/ru/man1
234
235 install commands/*.com $RPM_BUILD_ROOT%{_dosemudir}/bootdir/dosemu
236 install commands/*.sys $RPM_BUILD_ROOT%{_dosemudir}/bootdir/dosemu
237 install smarthog-%{smarthogver}/*.exe   $RPM_BUILD_ROOT%{_dosemudir}/bootdir/dosemu
238 cp %{SOURCE3} PRZECZYTAJ_TO
239 cp %{SOURCE4} README.PLD
240 install %{SOURCE5} $RPM_BUILD_ROOT%{_desktopdir}
241
242 rm -f doc/{configuration,dosemu.lsm}
243
244 %clean
245 rm -rf $RPM_BUILD_ROOT
246
247 %files
248 %defattr(644,root,root,755)
249 %doc QuickStart COPYING ChangeLog* doc/* README.PLD
250 %lang(pl) %doc PRZECZYTAJ_TO
251 %dir %{_dosemudir}
252 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/dosemu.conf
253 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/dosemu.users
254 %config(noreplace) %verify(not md5 mtime size) %{_dosemudir}/global.conf
255 %attr(755,root,root) %{_bindir}/dos
256 %attr(755,root,root) %{_bindir}/dosdebug
257 %attr(755,root,root) %{_bindir}/dosemu
258 %attr(755,root,root) %{_bindir}/dosexec
259 %attr(755,root,root) %{_bindir}/midid
260 %dir %{_libdir}/dosemu
261 %{_libdir}/dosemu/libplugin_alsa.so
262 %{_libdir}/dosemu/libplugin_gpm.so
263 %{_libdir}/dosemu/libplugin_sndfile.so
264 %{_libdir}/dosemu/libplugin_term.so
265 %dir %{_dosemudir}/bootdir
266 %dir %{_dosemudir}/bootdir/dosemu
267 %{_dosemudir}/bootdir/dosemu/*
268 %{_mandir}/man1/d*
269 %lang(pl) %{_mandir}/pl/man1/d*
270 %lang(ru) %{_mandir}/ru/man1/d*
271 %{_pixmapsdir}/dosemu.xpm
272 %if %{with x}
273 %attr(755,root,root) %{_bindir}/xdos*
274 %{_mandir}/man1/xdosemu.1*
275 %lang(pl) %{_mandir}/pl/man1/xdosemu.1*
276 %lang(ru) %{_mandir}/ru/man1/xdosemu.1*
277 %{_desktopdir}/dosemu.desktop
278 %endif
279
280 %files utils
281 %defattr(644,root,root,755)
282 %attr(755,root,root) %{_bindir}/dexeconfig
283 %attr(755,root,root) %{_bindir}/hdinfo
284 %attr(755,root,root) %{_bindir}/mkhdimage
285 %attr(755,root,root) %{_bindir}/mkfatimage16
286 %{_mandir}/man1/mkfatimage16.1*
287 %lang(ru) %{_mandir}/ru/man1/mkfatimage16.1*
288
289 %if %{with sdl}
290 %files SDL
291 %defattr(644,root,root,755)
292 %attr(755,root,root) %{_libdir}/dosemu/libplugin_sdl.so
293 %endif
294
295 %if %{with x}
296 %files X
297 %defattr(644,root,root,755)
298 %attr(755,root,root) %{_libdir}/dosemu/libplugin_X.so
299 %endif
This page took 0.141776 seconds and 4 git commands to generate.